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1.  INTRODUCTION  

Large area, high-resolution, three-dimensional (3D) mapping of a planetary’s surface is not 
only essential for performing key science investigations on the generation and evolution of the 
planet’s surface, but also critical for planning and supporting existing and future surface 
robotic missions as well as human exploration. Over the past 20 years, 3D mapping of the 
Moon surface has only been done for larger areas with low-resolution data, or for very small 
areas with higher-resolution data.  
 
Large area lower-resolution 3D mapping work usually refers to the global lunar digital terrain 
models (DTMs) created from the Lunar Orbiter Laser Altimeter (LOLA) and LOLA blended 
with the SELenological and Engineering Explorer (SELENE) DTMs from the Kaguya Team at 
118 m/pixel and 60 m/pixel, respectively, or using the Lunar Reconnaissance Orbiter Camera 
(LROC) Wide Angle Camera (WAC) images at 75 m/pixel resolution. On the other hand, 
smaller area higher-resolution 3D mapping work usually employs the LROC Narrow Angle 
Camera (NAC) images at 0.5-1.5 m/pixel producing DTMs at about 5m/pixel using 
photogrammetry or DTMs at 0.5-1.5 m/pixel using photoclinometry. 
 
This Product User Guide (PUG) describes the work done at UCL to create a novel DTM product 
based on single images at the highest possible spatial resolution using ≤1m LROC-NAC images. 
 
The limitations of having to trade-off between “large area” and “high-resolution”, for lunar 3D 
mapping is a consequence of three different aspects. Firstly, lower-resolution data such as 
LROC WAC and Chang’E-2 (CE-2) generally have better stereo coverage, whereas the main 
high-resolution data to date (LROC NAC) only has limited stereo coverage (≤1% of the lunar 
surface). Secondly, the photogrammetry and photoclinometry processes are complex and 
subject to different errors (or artefacts) at each of their different processing stages, which 
require specialist expertise to deal with these complexities in order to produce high-quality 
DTM products, especially over large areas. Thirdly, the expensive computational cost from 
existing photogrammetry and photoclinometry pipelines makes it extremely difficult to 
achieve large area high-resolution coverage. Other UCL DTM datasets have employed the open 
source CASP-GO (Tao et al., 2018) to produce a LROC NAC DTM mosaic of the Aristarchus 
crater (Putri & Muller, 2020). 
 
In this work, we experiment with a previously developed single-input-image-based rapid 
surface modelling system, called MADNet (Multi-scale generative Adversarial u-net with 
Dense convolutional and up-projection blocks) (Tao et al., RS, 2021), exploring large area 
high-resolution DTM production using a set of co-registered CE-2 and LROC NAC images and 
DTMs that are co-aligned with the global reference DTM from LOLA-SELENE. In contrast with 
traditional photogrammetric methods, where two overlapping images (with a suitable stereo 
angle, typically ≥8˚) are used as inputs to derive a DTM, MADNet only requires a single image 
as input to derive a DTM, firstly in relative height units (normalised), and then by using a 
referencing coarse resolution DTM (e.g., the globally available LOLA-SELENE DTM) to 
produce the final DTM product. The above differences are illustrated in Figure 1, where we 
show a simplified flow diagram of the photogrammetric DTM pipeline and the deep learning-
based single-image DTM pipeline (e.g., MADNet). See (Tao et al., RS, 2021) for more 
details. 
 
Von Kármán is a large lunar impact crater that is located in the southern hemisphere on the 
far side of the Moon. The crater is about 180 km (110 mi) in diameter and lies within an 
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immense impact crater known as the South Pole–Aitken basin of roughly 2,500 km (1,600 mi) 
in diameter and 13 km (8.1 mi) deep. 

 
Figure 1. Illustration of the major differences between the photogrammetric DTM pipeline and the deep 
learning-based single-image DTM pipeline (e.g., MADNet) discussed here. Taken from (Tao et al., RS, 2021). 

 
1.1 Instrument and Datasets 
In this work, we focus on the von Karman crater area on the lunar far side, where the Chinese 
CE-4 mission landed the “Yutu-2” rover in January 2019. Large area high-resolution DTM 
mosaics, covering the whole von Karman crater, are produced here from 7m CE-2 images at 14 
m/pixel for CE-2 and at 1 m/pixel for LROC NAC images. Cascaded 3D co-alignments (CE-2 
to LOLA-SELENE and LROC NAC to CE-2) have been achieved to guarantee precise global 
congruence with respect to LOLA-SELENE. 
 
In this work, a total of 370 LROC NAC images (consisting of 252 images at ≈50 cm/pixel and 
118 images at ≈1 m/pixel) are used. Initially 507 images were found using the LROC NAC 
product’s coverage shapefiles to cover the von Karman crater. The input LROC NAC images 
are automatically co-registered with the CE-2 image using ENVI® Modeler and are then 
manually inspected and filtered for quality control. The 50 cm/pixel images (DTM at 1 m/pixel) 
have a priority in the DTM mosaicing process over the 1 m/pixel images (DTM at 2 m/pixel) if 
they overlap. Some LROC NAC images that contain severe shading issue are excluded. The 14 
m/pixel CE-2 MADNet DTM is used to fill remaining DTM gaps at the end of the process. 
 
An overview of the area covered, and the input LOLA-SELENE, CE-2, LROC NAC datasets, are 
shown in Figure 2. As the proposed method only requires single images as inputs, the 3D 
mapping area for LROC NAC could therefore be greatly enlarged to cover the whole area 
without any targeted or serendipitous observations being available. There is only one stereo-
pair available in this area. 
 
Further information on how the CE-2 mosaics (7m ORI and 20m DTM) can be found in Ren 
et al. (2014) and Xin et al. (2020). 
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Figure 2. An overview of the 3D mapping area at von Karman crater (centred at 44.8°S 175.9°E). Shown in the 
background is the 14 m/pixel co-registered CE-2 DTM (colourised and hill-shaded). Shown on the foreground 
are the 50 cm/pixel and 1 m/pixel input LROC NAC images. 

1.2 Abbreviations and Acronyms 
CE-2   Chang’E-2 (CNSA) 
CNSA  Chinese National Space Agency 
DTM   Digital Terrain Model 
ESA  European Space Agency 
JAXA  Japanese Space Agency 
LOLA  Lunar Orbiter Laser Altimeter 
LROC  Lunar Reconnaissance Orbiter Camera (NASA) 
NAC  Narrow Angle Camera 
NASA  National Space Aeronautics Agency 
ORI   OrthoRectified Images 
PDS  Planetary Data System (NASA) 
PSA   Planetary Science Archive (ESA) 
PUG   Product User Guide 
SELENE SELenological and Engineering Explorer (JAXA) 
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UCL   University College London 
WAC   Wide Angle Camera 
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2. SCIENTIFIC OBJECTIVES 

All results shown here are produced covering the whole von Karman crater which is about 180 
km in diameter and lies within an immense impact crater known as the South Pole–Aitken 
basin. The northern third of this formation is overlain by the rim and outer rampart of the 
walled plain Leibnitz, forming a deep indentation in the formation. The remainder of the outer 
wall is roughly circular in shape, although it is irregular and heavily worn by subsequent 
impacts. The interior of Von Kármán has been subjected to flooding by lava flows after the 
original crater formed, leaving the southern portion of the floor nearly flat. This surface has a 
lower albedo than the surrounding terrain and is nearly as dark as the interior of Leibnitz. 
There is a central peak at the location where the midpoint of the original Von Kármán was 
formed, which joins with the rougher surface in the northern part of the crater. On 3 January 
2019, the Chinese spacecraft Chang'E 4 landed inside the crater Von Kármán, becoming the 
first spacecraft to soft-land on the far side of the Moon. 
 
2.1 Acknowledgements 
Users are requested to acknowledge the dataset by mentioning it in any relevant figure captions 
and within acknowledgement within their publications to cite both the DOI of the dataset and 
the paper describing the processing system, assessment, and mosaic generation: 
 
Tao, Yu, Jan-Peter Muller, Susan J. Conway, Siting Xiong, Sebastian H. G. Walter, and Bin Liu. 
2023. "Large Area High-Resolution 3D Mapping of the Von Kármán Crater: Landing Site for 
the Chang’E-4 Lander and Yutu-2 Rover" Remote Sens. 2023 15, no. 10: 2643. 
https://doi.org/10.3390/rs15102643 
 
The research leading to these results received initial funding from the UKSA Aurora 
programme (2018–2021) under grant ST/S001891/1, as well as partial funding from the STFC 
MSSL Consolidated Grant ST/K000977/1. The processing was supported by JPL contract no. 
1668434. We thank Emily Law for all of her support for this work. 
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3. DATA PRODUCT GENERATION 

The processing core of this work is the MADNet deep learning based single-image DTM 
estimation system described in (Tao et al., RS, 2021). MADNet is based on the relativistic 
Generative Adversarial Network (GAN) framework. For the MADNet generator network, a 
fully convolutional U-net architecture is employed, consisting of four stacks of dense 
convolution blocks as the encoder and five stacks of up-projection blocks as the decoder. The 
network architecture of the MADNet that is used in this work is shown in Figure 3 and the 
overall processing chain is shown in Figure 4. For a detailed description of the method, please 
refer to (Tao et al., RS, 2021). 

 
Figure 3. MADNet 2.0 network architecture. 

 
Figure 4. Flow diagram of the overall MADNet auto-DTM system. 

 
The training dataset for the MADNet Moon model consists of 22,084 ORI-DTM training 
pairs (512*512 pixels at 5 m/pixel) which were formed using 392 pairs of single-strip 
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downsampled 5 m/pixel LROC NAC PDS ORIs and 5 m/pixel DTMs with horizontal and 
vertical flipping.  
 
The processing of the CE-2 referencing dataset includes reprojection of the CE-2 ORI and 
DTM into LOLA-SELENE geocontext and vertical co-alignment of the CE-2 DTM and LOLA-
SELENE DTM. N.B. CE-2 ORI has good spatial co-registration w.r.t. LOLA-SELENE but 
vertical differences of 2 km - 5 km. 
 
The LROC NAC ORI processing includes initial input selection (509 single-strip EDR data 
downloaded) and screening (370 out of 507 selected) for quality and shadow control; USGS-
ISIS based pre-processing (lronac2isis, lronaccal, lronacecho, spiceinit) for format 
conversion (from PDS to ISIS CUBE), geometric calibration, artefact/noise removal and 
SPICE kernel initialisation, USGS-ISIS map-projection and orthorectification (cam2map) 
w.r.t. LOLA-SELENE DTM. 
 
The LROC NAC MADNet DTM processing follows the standard MADNet 2.0 processing 
chain that is described in (Tao et al., RS, 2021) and the final LROC NAC MADNet DTM 
mosaicing and CE-2 gap filling process uses the standard NASA Ames Stereo Pipeline’s DTM 
mosaicing routine.  
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4. ARCHIVE FORMAT AND CONTENT 

4.1 Product Type 
The final output of the mapping work includes a 1m/pixel LROC-NAC DTM mosaic with CE-
2 MADNet DTM used for gap filling. The area covered is about 260×209 km2 of the von 
Karman crater (see Figure 7 for the DTM coverage and Figure 2 for the ORI coverage), a 
14m/pixel CE-2 MADNet DTM covering about a larger area of 302×213km2 of the same area 
is also produced as the reference DTM of the LROC-NAC MADNet DTMs. It should be noted 
that all final outputs are 3D co-aligned with the reference LOLA-SELENE DTM using the B-
spline fitting based 3D co-alignment method described previously (Tao et al., RS, 2021b). 
The complete set of von Karman crater LROC NAC DTM products contains the following 
types of products: 
• DTM mosaic 
• single-strip ORIs 
 

 
Figure 5. Intensity-height representation of all the 50cm and 1m resolution LROC-NAC DTM strips auto-
coregistered to the underlying 14m MADNet 2.0 DTM background within Harris® ENVI®. The display 
programme stretches each DTM strip to maximise the contrast and does not indicate that the DTMs are offset at 
all from the background DTM. 
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Figure 6 Same as Figure 5 except the footprints of each DTM is displayed showing the density of coverage of the 
DTMs. 
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Figure 7. Overview map of final 1 m/pixel LROC-NAC MADNet DTM mosaic with CE-2 MADNet DTM for gap 
filling over Von Karman Crater. 

 
Figure 8. Final radiometrically adjusted ORI mosaic created by JPL from the 1m DTM 
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The filename, pixel size and extents of the delivered von Karman crater DTM and ORI 
datasets are summarised in the following table. 
 

Table 1. Summary of CE-2 and LROC-NAC products created 

Filename  Grid 
m 

NS NL Size 
(Gb) 

Top-left 
lon,lat 
extent 

Bottom-
right 
lon,lat 

CE2-VonKarman-MADNet-DTM-14m-
coaligned.tif 

14 21,600 15,200 1.3 169.982 E  
41.987 S 

179.955 E 
49.004 S 

CE2-VonKarman-MADNet-DTM-14m-
coaligned.tif.ovr 

pyra
mid 

   169.982 E  
41.987 S 

179.955 E 
49.004 S 

CE2-VonKarman-ORI-projected-7m.tif 7 43,473  30,432 1.3 169.982 E  
41.987 S 

179.955 E 
49.004 S 

LRO-NAC-ORIs/*.tif (∑=370) 50cm 
or 1m 

- - 369.7 - - 

LROC-NAC-VonKarman-MADNet-
DTM-mosaic-1m-coaligned.tif 

1 260,597 209,818 72.1 171.330 E 
42.046 S 

171.925 E 
48.938 S 

LROC-NAC-VonKarman-MADNet-
DTM-mosaic-1m-coaligned.tif.ovr 

pyra
mid 

   171.330 E 
42.046 S 

171.925 E 
48.938 S 

LRO_NAC_Mosaic_50cmpp_VonKar
man_v2.tif 

50cm 513,977 419,101 201 171.4493 E 
42.01882 S 

179.9243 E 
48.9294 S 

LRO_NAC_Mosaic_50cmpp_VonKar
man_v2.tif.ovr 

pyra
mid 

- - 33 171.4493 E 
42.01882 S 

179.9243 E 
48.9294 S 

 
4.2 DTM/ORI Specification 
• Projection: Equirectangular 1 
• Moon radius reference: 1,737,400.00 m 
 
4.3 Product Example and Usage 
 
MADNet 2.0 is first applied to the 7m Chang’E-2 ORI image to produce a 14m DTM of the 
whole area. This is shown in Figure 9 using colour intensity height hill-shading for the CE2 
mosaic and greyscale for the base reference of LOLA-SELENE over the base reference DTM. 
A preliminary analysis of the quality of the MADNet 14m CE-2 and LOLA-SELENE DTM 
compared with the original 20m CE-2 DTM is shown in Figure 10. This demonstrates the 
close congruence between the CE-2 MADNet DTM and the LOLA-SELENE DTM. 

 
1 https://en.wikipedia.org/wiki/Equirectangular_projection  
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Figure 9. MADNet applied to CE-2 (Chang’E-2) DTM to generate a 14m DTM superimposed on a 60m base DTM 
from SELENE+LOLA. 

 
Figure 10. CE-2 7 m ORI superimposed on the 14m DTM where 2 profiles were extracted to show the high degree 
of agreement between the CE-2 MADNet DTM (14m) and the 60m (resampled) LOLA-SELENE DTM. 

 
Figure 11 shows an example of the 2.8 m/pixel LROC-NAC MADNet result produced using a 
1.4 m/pixel LROC-NAC image compared with the 5 m/pixel PDS DTM product generated using 
the standard Socet® photogrammetric process. A preliminary analysis of the quality of the 
MADNet 14 m/pixel CE-2 and LROC-NAC 2.8 m/pixel DTM compared with the 5 m/pixel PDS 
DTM product is shown in Figure 12. This demonstrates the close congruence between all the 3 
datasets as well as the fine-scale detail in the MADNet DTM compared with the other two 
datasets. 
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Figure 11. An example of a crop of the input LROC NAC image (left) and the 2 DTMs from PDS and MADNet 
(product ID: M1303619844).  

 
Figure 12. LROC-NAC MADNet DTM (upper-left) and ORI (lower-left) superimposed on the CE-2 ORI (upper-
left) and MADNet DTM (lower-left) where 4 profiles were extracted to show the high degree of agreement 
between the CE-2 14 m/pixel MADNet, the 5 m/pixel PDS and the 2.8 m/pixel MADNet DTMs. 

The DTM and ORI file in GeoTiff format can be opened in GIS/image processing software 
such as ArcGIS, QGIS, and ENVI. Projection and mapping information is embedded in the 
header of the Geotiff file. 
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The best way to visually inspect a DTM is via a colourised hill-shaded display. The following 
instructions show how to create a colourised hill-shaded view of the DTM product in QGIS. 

1. Import the DTM via: Layer -> Add layer -> Add Raster Layer -> Select the Raster 
dataset(s) -> Add -> Close 

2. Create shaded relief image: left click to select the DTM -> Raster -> Analysis -> 
Hillshade -> Select the illumination parameters (e.g., z=2, azimuth=330, 
elevation=60) under “Hillshade” click “…” -> save to file -> choose a filename and end 
with .tif -> OK -> run -> close 

3. Adjust the display setting of the shaded relief image: right click the hill-shaded relief 
image -> Properties -> Symbology -> under “Color Rendering” select “Blending 
mode” -> “Overlay” -> adjust “Brightness” as “-60” -> Apply -> OK. 

4. Adjust the display setting of the DTM: right click the DTM -> Properties -> 
Symbology -> under “Band Rendering” select “Render type” as “Singleband 
pseudocolor” -> under “Min/Max Value Settings” select Min/Max -> under “Color 
ramp” select a colour ramp then select “Invert Color Ramp” -> click “Classify” -> 
Apply -> OK 

 
Other important notes: 

1. Put the hillshaded relief image layer in front of the colourised DTM layer. 
2. Do not use transparency for the hillshaded relief image layer as the selected “Overlay” 

display mode is doing this. 
3. You can use z=3 if a strong hill-shading effect is required. 
4. Always create a group for the colourised DTM and hillshaded relief image and use the 

group icon to toggle display of the colourised hillshaded DTM. 
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5. KNOWN ISSUES 

Evaluation of the product has not yet been performed. For general known issues of the 
MADNet derived DTM products, please refer to (Tao et al., RS, 2021). 
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6. SOFTWARE 

The processing uses UCL’s in-house MADNet 2.0 single-image DTM estimation system. 
 
 
 
 
 


