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Procedure Summary

oj ecti ves

This Herschel OBSM nominal procedure is used to per

SPU RAM Data DRAM ground image update from memory d
several PACS SPU RAM Data DRAM memory areas. It is
SPU SWL and SPU LWL subsystems.

form a PACS
ump of one or
used for both

The memory dump is commanded using TC(6,5) and the memory
locations content is received on ground in TM(6,6) packets.
The procedure assumes that the command stack has al ready been
generated using the OBSM system and is ready for lo ading on the
Manual Stack. The command stack generation activity is not
covered by this procedure.

Summary of Constraints
CDMU in Operational Mode
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established
Memory areas are Dumped through TC(6,5); this TC wi Il be delayed

when there is an ongoing:

- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Spacecraft Configuration

Start of Procedure

nd of Procedure

CDMU in Operational Mode

- PACS instrument in INIT mode (DPU ASW running)
- SPU ON

- DPU-SPU connection established

Same as start

Ref erence Fil e(s)

I nput Command Sequences

Qut put Command Sequences

OFCP424m
OFCP4240

Ref erenced Di spl ays

ANDs GRDs

SLDs

Configuration Control Information

Status  : Version 1 - Unchanged

Last Checkin: 04/09/08
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Procedure Flowchart Overview
’ START of Procedure ‘
Verify initial conditions
@ OFCP4249
SPU SWL SPU SWL SPU LWL
or
SPU LWL
@ OFCP4249 OFCP4240
THEN ¥ ELSE THEN_, ELSE
Image Updatein e—— Image Momtor —
LIVE mode In LIVE mode
OFCP424n OFCPA240 OFCPA2dp
9 18
nuaI Stack manipulation O . gn;nual Stack manipulation O ’
MCS OBSM preparation for MCS OBSM preparation for
Load command stack file for Image undate in RETRIEVAL Load command stack file for Image undate in RETRIEVAL
PACS SPU SWL RAM Data O e PACS SPU LWL RAM Data e e
DRAM dump on Manual Stack DRAM dump on Manual Stack
O OFC}-’AZAm @ OFC‘PAZAH @ OFCPA240 @ OFC‘PAZAp
MCS OBSM preparation for Retrieve and process TM(6,6) MCS OBSM preparation for Retrieve and process TM(6,6)
Image update in LIVE mode packets Image update in LIVE mode packets
OFC}-’AZAm @ OFC‘PAZAH @ OFCPA240 @ OFC‘PAZAp
Upload command(s) to dump Upload command(s) to dump
the PACS SPU SWL RAM Save merged image the PACS SPU LWL RAM Save merged image
Data DRAM Data DRAM
Y
O OFCP42im (® OFCPA240
Verify reception of TM(6,6) Verify reception of TM(6,6)
Y
. OFCP4Zim OFCPAZ40
Save merged image Save merged image

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08

END of Procedure ‘
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Next Step:
1 Verify initial conditions 2
Check:
- PACS instrument in INI T node (DPU ASW running)
- SPU ON
- DPU-SPU connection established
Instrument SOE to confirm PACS instrument mode and SPU
status.
Next Step:
2 SPU SWL SPU SWL 3
or SPU LWL 12
SPU LWL
type: [Switch]
Next Step:
3 IF THEN 4
Image Update in LIVE mode ELSE 9
type: [If]

Next Step:
4 Manual Stack manipulation 5
Load command stack file for PACS SPU SWL RAM Data D RAN
dump on Manual Stack
NOTE:
The current procedure assumes that the memory dump in
Live mode is performed using commands with immediat e
execution.
Select the File -> LoadSt ack option from the main
menu of the Manual Stack window
4.1 IF
PACS Nominal
Status  : Version 1 - Unchanged

Last Checkin: 04/09/08
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Ste
No.

Activity/ Remar ks

TC/ TLM Di spl ay/ Branch

Al T Comment

Select file

PASPDDSW DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASPDDSW

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASPDDSW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPDDSW1, ID 0003, Version 001 associated to the
memory image:

PASPDDSW_DI_0002001_C_PASPDDSW1_0003001_2007_337T0832
0.sun043

4.2

EL

SE
PACS Redundant

Select file

PASDDSWR_DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASDDSWR

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASDDSWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASDDSWR1, ID 0003, Version 001 associated to the
memory image:

PASDDSWR_DI_0002001_C_PASDDSWR1_0003001_2007_337T0832
0.sun043

Status

: Version 1 - Unchanged
Last Checkin: 04/09/08
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4.3 Check command stack loaded

Check that loaded stack contains one or several TCs
PC028380

Display the Manual Stack in 'Full mode' and check t hat
the Menory | Dparameter in the PC028380 command(s) is
setto 54 hex:

Menory | D = 54 hex

Not e:

The Memory ID of the target memory device is stored in
the MSB of the 16-bit long Mem ID TC parameter.

The LSB of the same parameter carries the most

significant 8 bits of the Start Address.

Execute Telecommand TC
DPU_MEMORY_DUMP PC028380

Command Paraneter(s) :
DPU_MEMORY_BLOCK_I D PP009380 54xx hex

DPU_MEMORY_ADDR PP003380 <hex> (Def)

DPU_DATA_LENGTH PP008380 <dec> (Def)

TC Control Flags :
GBM | L DSE
o\ o oo
Subsch. ID: 90
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

ext Step:
5 MCS OBSM preparation for Image update in LI VE mode 6

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

5.1 Select 'Image UPDATE' from the menu

Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Updat e.

The 'Image Catalog' window opens.

5.2 Select image to be updated

5.2.1 IF
PACS Nominal

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 6 of 15
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Select the image to be updated for the memory devic e
PASPDDSW

The 'Image UPDATE' window opens.

5.2.2 ELSE
PACS Redundant

Select the image to be updated for the memory devic e
PASDDSVR.

The 'Image UPDATE' window opens.

5.3 Start dump TM processing

In LI VE mode, processing of incoming real-time
telemetry starts automatically after the image
selection.

ext Step:
load command(s) to dump the PACS SPU SWL RAM Data 7
DRAM

6 Upl

Upl i nk the PC028380 memory dump command(s) with ARM GO

For each command, one or more TM(6,6) packets must be
received on ground.

ext Step:
7 Verify reception of TM(6,6) 8

Not e:
One or more TM(6,6) packets will be received for ea ch
memory dump command uplinked.

7.1 IF
PACS Prime

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1152

Type : 6

Subtype : 6

PI1:

PI2:

7.2 ELSE
PACS Redundant

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 7 of 15
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Ste
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Verify Packet Reception
MEMORY_DUMP
Packet Mnemonic : MEMORY_DUMP
APID : 1153
Type : 6
Subtype : 6
PI1:
PI2:
7.3 Check OBSM dump packet processing
Check that the OBSM is processing the incoming memo ry
dump packets.
ext Step:
8 Save merged image END
Save merged image with new | D.
End of Sequence
TC Seq. Nane : OFCP424n ()
OFCP424n PACS SPU SWL RAM Data DRAM image update in Retrieva
mode
Ti meTag Type:
Sub Schedul e | D:
O
ext Step:
9 MCS OBSM preparation for Image update in RE TRIEVAL 10
mode
Not e:
It is assumed that the OBSM application is already
running and the OBSM Desktop is displayed on the MC S
client.
Starting the OBSM application is not covered by the
current procedure.
9.1 Select 'Image UPDATE' from the menu
Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Updat e.
The 'Image Catalog' window opens.
9.2 Select image to be updated

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08
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9.2.1

PACS Nominal

Select the image to be updated for the memory devic
PASPDDSW

The 'Image UPDATE' window opens.

9.2.2

ELSE

PACS Redundant

Select the image to be updated for the memory devic
PASDDSVR.

The 'Image UPDATE' window opens.

9.3

rt dump TM packets processing

Set retrieval start time and start retrieval of TM
packets using the PLAY buttons.

10

Re

trieve and process TM(6,6) packets

ext Step:
11

Use the  STEP button to retrieve and process the
TM(6,6) packets, packet by packet and starting from
the time shown in the packet time field.

OR

Use the  PLAY button to retrieve and process the
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to
retrieve and process packets, starting from the tim
shown in the packet time field. This processing wil
stop automatically when a packet is received which
creation time is greater than the one contained in
end time field.

the

11

Sa

e merged image

ext Step:
END

Save merged image with new | D.

End of Sequence

Status

OFCP4240

TC Seq. Nane : OFCP4240 ( )

PACS SPU LWL RAM Data DRAM image update in Live mod

Ti meTag Type: B
Sub Schedul e | D:

: Version 1 - Unchanged
Last Checkin: 04/09/08
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ext Step:

12 IF THEN 13

Image Monitor ELSE 18

In LIVE mode

type: [If]

ext Step:

13 Manual Stack manipulation 14

Load command stack file for PACS SPU LWL RAM Data D RAN

dump on Manual Stack

NOTE:

The current procedure assumes that the memory dump in

Live mode is performed using commands with immediat e

execution.

Select the File -> LoadSt ack option from the main

menu of the Manual Stack window
131 IF

PACS Nominal

Select file

PASPDDLW DI _XXXXYYY_N_NoMbdel _NoModel _YYYY_DDDThhmmss.

machi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB

SM/PASPDDLW

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on

image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for

stack generation

File name exanpl es

- No model associated to the memory image:

PASPDDLW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.

sun043

- CT PASPDDLW1, ID 0003, Version 001 associated to the

memory image:

PASPDDLW_DI_0002001_C_PASPDDLW1_0003001_2007_337T0®32

0.sun043
13.2 ELSE

PACS Redundant

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 10 of 15



Doc No. :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue : 3.0
Issue Date: 13/04/10

Update PACS SPU RAM Data DRAM ground image via me mory dump ;‘- HERSCHEIL \\K&\\\\k&k\k

File: H_FCP_OBS_4249.xIs C
Author: Istefanov-hp L PLANCK : i

.

p

.

Sa

Ste
No. Ti me Acti vity/ Remar ks TC/ TLM Di spl ay/ Branch| AIT Comment

Select file

PASDDLWR_DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASDDLWR

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASDDLWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASDDLWR1, ID 0003, Version 001 associated to the
memory image:

PASDDLWR_DI_0002001_C_PASDDLWR1_0003001_2007_337T0®832
0.sun043

133

(@]

heck command stack loaded

Check that loaded stack contains one or several TCs
PC028380

Display the Manual Stack in 'Full mode' and check t hat
the Menory | Dparameter in the PC028380 command(s) is
setto 74 hex:

Menory I D = 74 hex

Not e:

The Memory ID of the target memory device is stored in
the MSB of the 16-bit long Mem ID TC parameter.

The LSB of the same parameter carries the most

significant 8 bits of the Start Address.

Execute Telecommand TC
DPU_MEMORY_DUMP PC028380

Command Par anet er (s)
DPU_MEMORY_BLOCK_I D PP009380 74xx

DPU_MEMORY_ADDR PP003380 <hex> (Def)

DPU_DATA_LENGTH PP008380 <dec> (Def)

TC Control Flags :
Subsch. ID: 90

Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

ext Step:
14 MCS OBSM preparation for Image update in LI VE mode 15

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 11 of 15
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Not e:
It is assumed that the OBSM application is already
running and the OBSM Desktop is displayed on the MC S
client.
Starting the OBSM application is not covered by the
current procedure.
14.1 Select 'Image UPDATE' from the menu
Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Updat e.
The 'Image Catalog' window opens.
14.2 Select image to be updated
14.2.1 IF
PACS Nominal
Select the image to be updated for the memory devic e
PASPDDLW
The 'Image UPDATE' window opens.
14.2.2 ELSE
PACS Redundant
Select the image to be updated for the memory devic e
PASDDLV\R.
The 'Image UPDATE' window opens.
14.3 Start dump TM processing
In LI VE mode, processing of incoming real-time
telemetry starts automatically after the image
selection.
ext Step:
15 Upload command(s) to dump the PACS SPU LWL RAM Data 16
DRAM
Upl i nk the PC028380 memory dump command(s) with ARM GO
For each command, one or more TM(6,6) packets must be
received on ground.

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 12 of 15
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ext Step:
16 Verify reception of TM(6,6) 17

Not e:
One or more TM(6,6) packets will be received for ea ch
memory dump command uplinked.

16.1 IF
PACS Prime

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1152

Type : 6

Subtype : 6

PI1:

PI2:

16.2 ELSE
PACS Redundant

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1153

Type : 6

Subtype : 6

PI1:

PI2:

16.3

(@]

heck OBSM dump packet processing

Check that the OBSM is processing the incoming memo ry
dump packets.

ext Step:
17 Save merged image END

Save merged image with new | D.

End of Sequence

TC Seq. Nane : OFCP424p ()
OFCP424p PACS SPU LWL RAM Data DRAM image update in Retrieva
mode

Ti meTag Type:
Sub Schedul e | D:

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 13 of 15
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ext Step:
18 MCS OBSM preparation for Image update in RE TRIEVAL 19
mode

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

18.1 Select 'Image UPDATE' from the menu

Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Updat e.

The 'Image Catalog' window opens.

18.2 Select image to be updated

18.2.1 IF
PACS Nominal

Select the image to be updated for the memory devic e
PASPDDLW

The 'Image UPDATE' window opens.

18.2.2 ELSE
PACS Redundant

Select the image to be updated for the memory devic e
PASDDLWR.

The 'Image UPDATE' window opens.

18.3 Start dump TM packets processing

Set retrieval start time and start retrieval of TM
packets using the PLAY buttons.

ext Step:
19 Retrieve and process TM(6,6) packets 20

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 14 of 15
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Use the  STEP button to retrieve and process the
TM(6,6) packets, packet by packet and starting from
the time shown in the packet time field.

OR

Use the  PLAY button to retrieve and process the
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to
retrieve and process packets, starting from the tim
shown in the packet time field. This processing wil
stop automatically when a packet is received which
creation time is greater than the one contained in
end time field.

the

20 Save merged image

ext Step:
END

Save merged image with new | D.

End of Sequence

|[End of Procedur e|

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08
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