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This Herschel OBSM nominal procedure is used to per form the dump 
monitoring of one or several PACS SPU RAM Data DRAM  memory areas. 
It is used for both SPU SWL and SPU LWL subsystems.
The memory dump is commanded using TC(6,5) and the memory 
locations content is received on ground in TM(6,6) packets.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

CDMU in Operational Mode
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established

Memory areas are Dumped through TC(6,5); this TC wi ll be delayed 
when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established

End of Procedure

Same as start

Input Command Sequences

Output Command Sequences

OFCP424i        
OFCP424k        

ANDs GRDs SLDs

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 05/09/08   2 1 Created  lstefanov-hp    
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP4248
TC Seq. Name :OFCP4248 (  )
PACS SPU RAM Data DRAM dump monitoring

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check:
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established

 

Instrument SOE to confirm PACS instrument mode and SPU 
status.

 

 

 2      SPU SWL
or
SPU LWL

type: [Switch]

 Next Step:
 SPU SWL 3
 SPU LWL 12

 

 3      IF
Image Monitor
In LIVE mode

type: [If]

 Next Step:
 THEN 4
 ELSE 9

 

End of Sequence 

OFCP424i
TC Seq. Name :OFCP424i (  )
PACS SPU SWL RAM Data DRAM dump monitoring in LIVE 
mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 4      Manual Stack manipulation
Load command stack file for PACS SPU SWL RAM Data D RAM 
dump on Manual Stack

 

 Next Step:
  5

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 4.1    IF
PACS Nominal

 

   

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

PASPDDSW_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPDDSW

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASPDDSW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPDDSW1, ID 0003, Version 001 associated to the 
memory image:

PASPDDSW_DI_0002001_C_PASPDDSW1_0003001_2007_337T09332
0.sun043

 

 

 4.2    ELSE
PACS Redundant

 

   

Select file

PASDDSWR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASDDSWR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASDDSWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASDDSWR1, ID 0003, Version 001 associated to the 
memory image:

PASDDSWR_DI_0002001_C_PASDDSWR1_0003001_2007_337T09332
0.sun043
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 4.3    Check command stack loaded 

 

   

Check that loaded stack contains one or several TCs  
PC028380

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the PC028380 command(s) is 
set to 54 hex:

Memory ID = 54 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

54xx hex  
 <hex> (Def)
 <dec> (Def)

TC  

 

 5      MCS OBSM preparation for Image monitor in L IVE mode

 

 Next Step:
  6

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 5.2    Select image to be monitored

 

   

 

 5.2.1  IF
PACS Nominal
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the image to be monitored for the memory dev ice 
PASPDDSW.

The 'Image MONITOR' window opens.

 

 

 5.2.2  ELSE
PACS Redundant

 

   

Select the image to be monitored for the memory dev ice 
PASDDSWR.

The 'Image MONITOR' window opens.

 

 

 5.3    Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 6      Upload command(s) to dump the PACS SPU SWL RAM Data 
DRAM

 

 Next Step:
  7

Uplink the PC028380 memory dump command(s) with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.

 

 

 7      Verify reception of TM(6,6)

 

 Next Step:
  8

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 7.1    IF
PACS Prime

 

   

Verify Packet Reception

MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1152
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 7.2    ELSE
PACS Redundant
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Verify Packet Reception

MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1153
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 8      Check contents of memory dump packets

 

 Next Step:
  END

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 8.1    Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP424j
TC Seq. Name :OFCP424j (  )
PACS SPU SWL RAM Data DRAM dump monitoring in 
Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 9      MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  10

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 9.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 9.2    Select image to be monitored

 

   

 

 9.2.1  IF
PACS Nominal

 

   

Select the image to be monitored for the memory dev ice 
PASPDDSW.

The 'Image MONITOR' window opens.

 

 

 9.2.2  ELSE
PACS Redundant

 

   

Select the image to be monitored for the memory dev ice 
PASDDSWR.

The 'Image MONITOR' window opens.

 

 

 9.3    Start dump TM packets processing

 

   

Set retrieval start time and start retrieval of TM 
packets using the PLAY buttons.

 

 

 10     Retrieve and process TM(6,6) packets

 

 Next Step:
  11

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 11     Check contents of memory dump packets

 

 Next Step:
  END

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 11.1   Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP424k
TC Seq. Name :OFCP424k (   )
PACS SPU LWL RAM Data DRAM dump monitoring in LIVE 
mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 12     IF
Image Monitor
In LIVE mode

type: [If]

 Next Step:
 THEN 13
 ELSE 18

 

 13     Manual Stack manipulation
Load command stack file for PACS SPU LWL RAM Data D RAM 
dump on Manual Stack

 

 Next Step:
  14

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 13.1   IF
PACS Nominal

 

   

Select file

PASPDDLW_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPDDLW

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

PASPDDLW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPDDLW1, ID 0003, Version 001 associated to the 
memory image:

PASPDDLW_DI_0002001_C_PASPDDLW1_0003001_2007_337T09332
0.sun043

 

 

 13.2   ELSE
PACS Redundant

 

   

Select file

PASDDLWR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASDDLWR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASDDLWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASDDLWR1, ID 0003, Version 001 associated to the 
memory image:

PASDDLWR_DI_0002001_C_PASDDLWR1_0003001_2007_337T09332
0.sun043

 

 

 13.3   Check command stack loaded 

 

   

Check that loaded stack contains one or several TCs  
PC028380

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the PC028380 command(s) is 
set to 74 hex:

Memory ID = 74 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

74xx  
 <hex> (Def)
 <dec> (Def)

TC  

 

 14     MCS OBSM preparation for Image monitor in L IVE mode

 

 Next Step:
  15

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 14.1   Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 14.2   Select image to be monitored

 

   

 

 14.2.1  IF
PACS Nominal

 

   

Select the image to be monitored for the memory dev ice 
PASPDDLW.

The 'Image MONITOR' window opens.

 

 

 14.2.2  ELSE
PACS Redundant

 

   

Select the image to be monitored for the memory dev ice 
PASDDLWR.

The 'Image MONITOR' window opens.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 14.3   Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 15     Upload command(s) to dump the PACS SPU LWL RAM Data 
DRAM

 

 Next Step:
  16

Uplink the PC028380 memory dump command(s) with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.

 

 

 16     Verify reception of TM(6,6)

 

 Next Step:
  17

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 16.1   IF
PACS Prime

 

   

Verify Packet Reception

MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1152
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 16.2   ELSE
PACS Redundant

 

   

Verify Packet Reception

MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1153
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 17     Check contents of memory dump packets

 

 Next Step:
  END

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 17.1   Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP424l
TC Seq. Name :OFCP424l (  )
PACS SPU LWL RAM Data DRAM dump monitoring in 
Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 18     MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  19

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 18.1   Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 18.2   Select image to be monitored

 

   

 

 18.2.1  IF
PACS Nominal

 

   

Select the image to be monitored for the memory dev ice 
PASPDDLW.

The 'Image MONITOR' window opens.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 18.2.2  ELSE
PACS Redundant

 

   

Select the image to be monitored for the memory dev ice 
PASDDLWR.

The 'Image MONITOR' window opens.

 

 

 18.3   Start dump TM packets processing

 

   

Set retrieval start time and start retrieval of TM 
packets using the PLAY buttons.

 

 

 19     Retrieve and process TM(6,6) packets

 

 Next Step:
  20

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 20     Check contents of memory dump packets

 

 Next Step:
  END

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 20.1   Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

End of Procedure
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