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Procedure Summary

oj ecti ves

This Herschel OBSM nominal procedure is used to per form a PACS
SPU RAM Ext ground image update from memory dump of one or
several PACS SPU RAM Ext memory areas. It is used f or both SPU
SWL and SPU LWL subsystems.
The memory dump is commanded using TC(6,5) and the memory
locations content is received on ground in TM(6,6) packets.
The procedure assumes that the command stack has al ready been
generated using the OBSM system and is ready for lo ading on the
Manual Stack. The command stack generation activity is not
covered by this procedure.

Summary of Constraints
CDMU in Operational Mode
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established
Memory areas are Dumped through TC(6,5); this TC wi Il be delayed

when there is an ongoing:

- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Spacecraft Configuration

Start of Procedure

nd of Procedure

CDMU in Operational Mode

- PACS instrument in INIT mode (DPU ASW running)
- SPU ON

- DPU-SPU connection established

Same as start

Ref erence Fil e(s)

I nput Command Sequences

Qut put Conmmand Sequences

OFCP424e
OFCP424g

Ref erenced Di spl ays

ANDs GRDs

SLDs

Configuration Control Information

Status  : Version 1 - Unchanged

Last Checkin: 04/09/08
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Procedure Flowchart Overview
’ START of Procedure ‘
Verify initial conditions
@ OFCP4247
SPU SWL SPU SWL SPU LWL
or
SPU LWL
@ OFCP4247 OFCP424g
THEN ¥ ELSE THEN_, ELSE
Image Updatein e—— Image Momtor —
LIVE mode In LIVE mode
D @ OFC‘:’AZAf OFCPA24g @ OFCPA2dh
wanual Stack manipulation WCS OBSM preparation for nuaI Stack manipulation MCS OBSM preparation for
Load command stack file for Image undate in RETRIEVAL Load command stack file for Image undate in RETRIEVAL
PACS SPU SWL RAM Ext O e PACS SPU LWL RAM Ext e e
dump on Manual Stack dump on Manual Stack
OFC‘PAZAe @ OFC‘:’AZAf @ OFCPA24g @ OFC‘PAZAh
MCS OBSM preparation for Retrieve and process TM(6,6) MCS OBSM preparation for Retrieve and process TM(6,6)
Image update in LIVE mode packets Image update in LIVE mode packets
OFC‘PAZAe @ OFC‘:’AZAf @ OFCPA24g @ OFC‘PAZAh
Upload command(s) to dump Save merged image Upload command(s) to dump Save merged image
the PACS SPU SWL RAM Ext gedimag the PACS SPU LWL RAM Ext gedimag
Y
OFCPA2de (® OFCPA24g
Verify reception of TM(6,6) Verify reception of TM(6,6)
Y
® OFCPazZie OFCPAZ4g

Save merged image

Save merged image

J

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08

END of Procedure ‘
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Next Step:
1 Verify initial conditions 2
Check:
- PACS instrument in INI T node (DPU ASW running)
- SPU ON
- DPU-SPU connection established
Instrument SOE to confirm PACS instrument mode and SPU
status.
Next Step:
2 SPU SWL SPU SWL 3
or SPU LWL 12
SPU LWL
type: [Switch]
Next Step:
3 IF THEN 4
Image Update in LIVE mode ELSE 9
type: [If]

Next Step:
4 Manual Stack manipulation 5
Load command stack file for PACS SPU SWL RAM Ext du mp
on Manual Stack
NOTE:
The current procedure assumes that the memory dump in
Live mode is performed using commands with immediat e
execution.
Select the File -> LoadSt ack option from the main
menu of the Manual Stack window
4.1 IF
PACS Nominal
Status  : Version 1 - Unchanged
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Select file

PASPRESW DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASPRESW

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASPRESW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPRESWL, ID 0003, Version 001 associated to the
memory image:

PASPRESW_DI_0002001_C_PASPRESW1_0003001_2007_337T0®832
0.sun043

4.2

EL

SE
PACS Redundant

Select file

PASRESWR_DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASRESWR

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASRESWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASRESWR1, ID 0003, Version 001 associated to the
memory image:

PASRESWR_DI_0002001_C_PASRESWR1_0003001_2007_337T0832
0.sun043

Status

: Version 1 - Unchanged
Last Checkin: 04/09/08
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4.3 Check command stack loaded

Check that loaded stack contains one or several TCs
PC028380

Display the Manual Stack in 'Full mode' and check t hat
the Menory | Dparameter in the PC028380 command(s) is
setto 52 hex:

Menory I D = 52 hex

Not e:

The Memory ID of the target memory device is stored in
the MSB of the 16-bit long Mem ID TC parameter.

The LSB of the same parameter carries the most

significant 8 bits of the Start Address.

Execute Telecommand TC
DPU_MEMORY_DUMP PC028380

Command Paraneter(s) :
DPU_MEMORY_BLOCK_I D PP009380 52xx hex

DPU_MEMORY_ADDR PP003380 <hex> (Def)

DPU_DATA_LENGTH PP008380 <dec> (Def)

TC Control Flags :
GBM | L DSE
o\ o oo
Subsch. ID: 90
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

ext Step:
5 MCS OBSM preparation for Image update in LI VE mode 6

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

5.1 Select 'Image UPDATE' from the menu

Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Updat e.

The 'Image Catalog' window opens.

5.2 Select image to be updated

5.2.1 IF
PACS Nominal

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 6 of 15
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Select the image to be updated for the memory devic e
PASPRESW

The 'Image UPDATE' window opens.

5.2.2 ELSE
PACS Redundant

Select the image to be updated for the memory devic e
PASRESVR.

The 'Image UPDATE' window opens.

5.3 Start dump TM processing

In LI VE mode, processing of incoming real-time
telemetry starts automatically after the image
selection.

ext Step:
load command(s) to dump the PACS SPU SWL RAM Ext 7

6 Upl

Upl i nk the PC028380 memory dump command(s) with ARM GO

For each command, one or more TM(6,6) packets must be
received on ground.

ext Step:
7 Verify reception of TM(6,6) 8

Not e:
One or more TM(6,6) packets will be received for ea ch
memory dump command uplinked.

7.1 IF
PACS Prime

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1152

Type : 6

Subtype : 6

PI1:

PI2:

7.2 ELSE
PACS Redundant

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 7 of 15
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Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1153

Type : 6

Subtype : 6

PI1:

PI2:

7.3 Check OBSM dump packet processing

Check that the OBSM is processing the incoming memo ry
dump packets.

ext Step:
8 Save merged image END

Save merged image with new | D.

End of Sequence

TC Seq. Name : OFCP424f ()
OFCP424f PACS SPU SWL RAM Ext image update in Retrieval mode

Ti meTag Type:
Sub Schedul e | D:

ext Step:
9 MCS OBSM preparation for Image update in RE TRIEVAL 10
mode

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

9.1 Select 'Image UPDATE' from the menu

Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Updat e.

The 'Image Catalog' window opens.

9.2 Select image to be updated

9.2.1 IF
PACS Nominal

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 8 of 15
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Select the image to be updated for the memory devic
PASPRESW

The 'Image UPDATE' window opens.

9.2.2 ELSE
PACS Redundant

Select the image to be updated for the memory devic
PASRESVR.

The 'Image UPDATE' window opens.

9.3 Start dump TM packets processing

Set retrieval start time and start retrieval of TM
packets using the PLAY buttons.

10 Retrieve and process TM(6,6) packets

ext Step:
11

Use the  STEP button to retrieve and process the
TM(6,6) packets, packet by packet and starting from
the time shown in the packet time field.

OR

Use the  PLAY button to retrieve and process the
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to
retrieve and process packets, starting from the tim
shown in the packet time field. This processing wil
stop automatically when a packet is received which
creation time is greater than the one contained in
end time field.

the

11 Save merged image

ext Step:
END

Save merged image with new | D.

End of Sequence

TC Seq. Nane : OFCP424g ( )
OFCP424g PACS SPU LWL RAM Ext image update in Live mode
Ti meTag Type: B
Sub Schedule ID:

12 IF
Image Monitor
In LIVE mode

type: [If]

ext Step:
THEN 13
ELSE 18

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08
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ext Step:

13 Manual Stack manipulation 14
Load command stack file for PACS SPU LWL RAM Ext du mp
on Manual Stack
NOTE:
The current procedure assumes that the memory dump in
Live mode is performed using commands with immediat e
execution.
Select the File -> LoadSt ack option from the main
menu of the Manual Stack window

13.1 IF
PACS Nominal
Select file
PASPRELW DI _XXXXYYY_N_NoMdel _NoModel _YYYY_DDDThhmmss.
machi ne
from directory
/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASPRELW
as indicated by the OBSM engineer
IMPORTANT:
XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation
YYYY_DDD hhmmss- depend on stack generation time
machine - depends on the name of the machine used for
stack generation
File name exanpl es
- No model associated to the memory image:
PASPRELW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043
- CT PASPRELWL1, ID 0003, Version 001 associated to the
memory image:
PASPRELW_DI_0002001_C_PASPRELW1_0003001_2007_337T09332
0.sun043

13.2 ELSE
PACS Redundant
Select file
PASRELWR_DI _XXXXYYY_N_NoMbdel _NoModel _YYYY_DDDThhmmss.
nmachi ne
from directory
/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASRELWR
as indicated by the OBSM engineer

Status  : Version 1 - Unchanged
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IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASRELWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASRELWR1, ID 0003, Version 001 associated to the
memory image:

PASRELWR_DI_0002001_C_PASRELWR1_0003001_2007_337T08B32
0.sun043

133

(@]

heck command stack loaded

Check that loaded stack contains one or several TCs
PC028380

Display the Manual Stack in 'Full mode' and check t hat
the Menory | Dparameter in the PC028380 command(s) is
setto 72 hex:

Menory I D = 72 hex

Not e:

The Memory ID of the target memory device is stored in
the MSB of the 16-bit long Mem ID TC parameter.

The LSB of the same parameter carries the most

significant 8 bits of the Start Address.

Execute Telecommand TC
DPU_MEMORY_DUMP PC028380

Command Par anmeter(s) :
DPU_MEMORY_BLOCK_I D PP009380 72xx

DPU_MEMORY_ADDR PP003380 <hex> (Def)

DPU_DATA_LENGTH PP008380 <dec> (Def)

TC Control Flags :
GBM | L DSE
PR Ve
Subsch. 1D : 90
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

ext Step:
14 MCS OBSM preparation for Image update in LI VE mode 15

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08 Page 11 of 15
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141

%]

elect 'Image UPDATE' from the menu

Select the | mage menu of the OBSM Deskt op.

From the Image menu, select Updat e.

The 'Image Catalog' window opens.

14.2 Select image to be updated

14.2.1 IR
PACS Nominal

Select the image to be updated for the memory devic e
PASPRELW

The 'Image UPDATE' window opens.

14.2.2 ELSE
PACS Redundant

Select the image to be updated for the memory devic e
PASRELWR.

The 'Image UPDATE' window opens.

14.3 Start dump TM processing

In LI VE mode, processing of incoming real-time
telemetry starts automatically after the image
selection.

ext Step:

15 Upload command(s) to dump the PACS SPU LWL RAM Ext 16

Upl i nk the PC028380 memory dump command(s) with ARM GO

For each command, one or more TM(6,6) packets must be
received on ground.

ext Step:
16 Verify reception of TM(6,6) 17

Not e:
One or more TM(6,6) packets will be received for ea ch
memory dump command uplinked.

Status  : Version 1 - Unchanged
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16.1 IF
PACS Prime

Verify Packet Reception

MEMORY_DUMP
Packet Mnemonic :
APID : 1152
Type : 6
Subtype : 6
PI1:

PI2:

MEMORY_DUMP

16.2 ELSE
PACS Redundant

Verify Packet Reception

MEMORY_DUMP
Packet Mnemonic :
APID : 1153
Type : 6
Subtype : 6
PI1:

PI2:

MEMORY_DUMP

16.3

(@]

heck OBSM dump packet processing

Check that the OBSM is processing the incoming memo
dump packets.

17 Save merged image

ext Step:
END

Save merged image with new | D.

End of Sequence

TC Seq. Name : OFCP424h ()
OFCP424h PACS SPU LWL RAM Ext image update in Retrieval mode
Ti meTag Type:
Sub Schedul e |D:

18 MCS OBSM preparation for Image update in RE

mode

TRIEVAL

ext Step:
19

Not e:

It is assumed that the OBSM application is already
running and the OBSM Desktop is displayed on the MC
client.

Starting the OBSM application is not covered by the
current procedure.

Status  : Version 1 - Unchanged
Last Checkin: 04/09/08
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18.1 Select 'Image UPDATE' from the menu

Select the | mage menu of the OBSM Deskt op.

From the Image menu, select Updat e.

The 'Image Catalog' window opens.
18.2 Select image to be updated
18.2.1 IF

PACS Nominal

Select the image to be updated for the memory devic e

PASPRELW

The 'Image UPDATE' window opens.
18.2.2 ELSE

PACS Redundant

Select the image to be updated for the memory devic e

PASRELV\R.

The 'Image UPDATE' window opens.
18.3 Start dump TM packets processing

Set retrieval start time and start retrieval of TM

packets using the PLAY buttons.

ext Step:

19 Retrieve and process TM(6,6) packets 20

Use the  STEP button to retrieve and process the

TM(6,6) packets, packet by packet and starting from

the time shown in the packet time field.

OR

Use the  PLAY button to retrieve and process the

TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to

retrieve and process packets, starting from the tim e

shown in the packet time field. This processing wil |

stop automatically when a packet is received which

creation time is greater than the one contained in the

end time field.

Status  : Version 1 - Unchanged
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ext Step:
20 Save merged image END

Save merged image with new | D.

End of Sequence

[End of Procedur €|

Status  : Version 1 - Unchanged
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