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Procedure Summary

oj ecti ves

This Herschel OBSM nominal procedure is used to per form the dump
monitoring of one or several PACS SPU DRAM memory a reas. Itis
used for both SPU SWL and SPU LWL subsystems.

The memory dump is commanded using TC(6,5) and the memory
locations content is received on ground in TM(6,6) packets.

The procedure assumes that the command stack has al ready been
generated using the OBSM system and is ready for lo ading on the
Manual Stack. The command stack generation activity is not

covered by this procedure.

Summary of Constraints

CDMU in Operational Mode

- PACS instrument in INIT mode (DPU ASW running)
- SPU ON

- DPU-SPU connection established

Memory areas are Dumped through TC(6,5); this TC wi Il be delayed
when there is an ongoing:

- TC(6,2) Load Memory Using Absolute Addresses

- TC(6,5) Dump Memory Using Absolute Addresses

- TC(6,9) Check Memory Using Absolute Addresses

- TC(8,4,1,1) Copy Memory

Spacecraft Configuration

Start of Procedure
CDMU in Operational Mode
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established

nd of Procedure

Same as start

Ref erence Fil e(s)

I nput Command Sequences

Qut put Command Sequences
OFCP424R
OFCP424T

Ref erenced Di spl ays

ANDs GRDs SLDs

Configuration Control Information

Status  : Version 2 - Unchanged
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Procedure Flowchart Overview
START of Procedure
Verify initial conditions
OFCP4244
SPU SWL SPU SWL SPU LWL
or
SPU LWL
@ OFCP4244 OFCP424T
THEN IF ELSE THEN ELSE
—e__ Image Monitor e— Image Momtor —
In LIVE mode In LIVE mode
OFCPA24S OFCPA24T OFCP424U
9 18
nuaI Stack manipulation O . gn;nual Stack manipulation O ’
MCS OBSM preparation for MCS OBSM preparation for
Foadeonmandblacinelic Image monitor in RETRIEVAL L) GO SRS Image monitor in RETRIEVAL
PACS SPU SWL DRAM dump g PACS SPU LWL DRAM dump g
mode mode
on Manual Stack on Manual Stack
C OFC}-’AZAR @ OFC‘PAZAS @ OFCPAZAT @ OFC‘PAZAU
MCS OBSM preparation for Retrieve and process TM(6,6) MCS OBSM preparation for Retrieve and process TM(6,6)
Image monitor in LIVE mode packets Image monitor in LIVE mode packets
O OFC}-’AZAR @ OFC‘PAZAS @ OFCPAZAT @ OFC‘PAZAU
Upload command(s) to dump Check contents of memory Upload command(s) to dump Check contents of memory
the PACS SPU SWL DRAM dump packets the PACS SPU LWL DRAM dump packets
Y
O OFCP424R @ OFCPA24T
Verify reception of TM(6,6) Verify reception of TM(6,6)
Y
. OFCP424R O OFCPAZAT
Check contents of memory Check contents of memory
dump packets dump packets
k J
J

END of Procedure ‘
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Next Step:
1 Verify initial conditions 2
Check:
- PACS instrument in INI T node (DPU ASW running)
- SPU ON
- DPU-SPU connection established
Instrument SOE to confirm PACS instrument mode and SPU
status.
Next Step:
2 SPU SWL SPU SWL 3
or SPU LWL 12
SPU LWL
type: [Switch]
Next Step:
3 IF THEN 4
Image Monitor ELSE 9
In LIVE mode
type: [If]

menu of the Manual Stack window

Next Step:

4 Manual Stack manipulation 5

Load command stack file for PACS SPU SWL DRAM dump on

Manual Stack

NOTE:

The current procedure assumes that the memory dump in

Live mode is performed using commands with immediat e

execution.

Select the File -> LoadSt ack option from the main

PACS Nominal

Status  : Version 2 - Unchanged
Last Checkin: 05/09/08
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Ste
No.

Activity/ Remar ks

TC/ TLM Di spl ay/ Branch

Al T Comment

Select file

PASPRDSW DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASPRDSW

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASPRDSW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPRDSW1, ID 0003, Version 001 associated to the
memory image:

PASPRDSW_DI_0002001_C_PASPRDSW1_0003001_2007_337T0832
0.sun043

4.2

EL

SE
PACS Redundant

Select file

PASRDSWR_DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASRDSWR

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

File name exanpl es
- No model associated to the memory image:

PASRDSWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASRDSWR1, ID 0003, Version 001 associated to the
memory image:

PASRDSWR_DI_0002001_C_PASRDSWR1_0003001_2007_337T0832
0.sun043

Status

: Version 2 - Unchanged
Last Checkin: 05/09/08
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4.3 Check command stack loaded

Check that loaded stack contains one or several TCs
PC028380

Display the Manual Stack in 'Full mode' and check t hat
the Menory | Dparameter in the PC028380 command(s) is
setto 51 hex:

Menory I D = 51 hex

Not e:

The Memory ID of the target memory device is stored in
the MSB of the 16-bit long Mem ID TC parameter.

The LSB of the same parameter carries the most

significant 8 bits of the Start Address.

Execute Telecommand TC
DPU_MEMORY_DUMP PC028380

Command Paraneter(s) :
DPU_MEMORY_BLOCK_I D PP009380 51xx hex

DPU_MEMORY_ADDR PP003380 <hex> (Def)

DPU_DATA_LENGTH PP008380 <dec> (Def)

TC Control Flags :
GBM | L DSE
o\ o oo
Subsch. ID: 90
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

ext Step:
5 MCS OBSM preparation for Image monitor in L IVE mode 6

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

5.1 Select 'Image MONITOR' from the menu

Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Moni t or .

The 'Image Catalog' window opens.

5.2 Select image to be monitored

5.2.1 IF
PACS Nominal

Status  : Version 2 - Unchanged
Last Checkin: 05/09/08 Page 6 of 15
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Select the image to be monitored for the memory dev ice
PASPRDSW

The 'Image MONITOR' window opens.

5.2.2 ELSE
PACS Redundant

Select the image to be monitored for the memory dev ice
PASRDSVR.

The 'Image MONITOR' window opens.

5.3 Start dump TM processing

In LI VE mode, processing of incoming real-time
telemetry starts automatically after the image
selection.

ext Step:
load command(s) to dump the PACS SPU SWL DRAM 7

6 Upl

Upl i nk the PC028380 memory dump command(s) with ARM GO

For each command, one or more TM(6,6) packets must be
received on ground.

ext Step:
7 Verify reception of TM(6,6) 8

Not e:
One or more TM(6,6) packets will be received for ea ch
memory dump command uplinked.

7.1 IF
PACS Prime

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1152

Type : 6

Subtype : 6

PI1:

PI2:

7.2 ELSE
PACS Redundant

Status  : Version 2 - Unchanged
Last Checkin: 05/09/08 Page 7 of 15
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Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1153

Type : 6

Subtype : 6

PI1:

PI2:

ext Step:
8 Check contents of memory dump packets END

Verify that there are NO OBSM reported differences
between the memory dump data and the ground image u sed
for monitoring.

| F there are di f f er ences reported by OBSM between the
dump data and the ground image, the nerged i mage shall
be saved for offline analysis.

8.1 Save merged image

| F there are m smat ches reported by OBSM, save merged
image with new | D.

Conduct off-line analysis of the reported mismatche S.

End of Sequence

TC Seq. Nane : OFCP424S ()
OFCP424S PACS SPU SWL DRAM dump monitoring in Retrieval mode

Ti meTag Type:
Sub Schedule ID:

ext Step:
9 MCS OBSM preparation for Image monitor in R ETRIEVAL 10
mode

Not e:

It is assumed that the OBSM application is already

running and the OBSM Desktop is displayed on the MC S
client.

Starting the OBSM application is not covered by the

current procedure.

9.1 Select 'Image MONITOR' from the menu

Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Moni t or .

The 'Image Catalog' window opens.

Status  : Version 2 - Unchanged
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9.2 Select image to be monitored
9.2.1 IF

PACS Nominal

Select the image to be monitored for the memory dev ice

PASPRDSW

The 'Image MONITOR' window opens.
9.2.2 ELSE

PACS Redundant

Select the image to be monitored for the memory dev ice

PASRDSVR.

The 'Image MONITOR' window opens.
9.3 Start dump TM packets processing

Set retrieval start time and start retrieval of TM

packets using the PLAY buttons.

ext Step:

10 Retrieve and process TM(6,6) packets 11

Use the  STEP button to retrieve and process the

TM(6,6) packets, packet by packet and starting from

the time shown in the packet time field.

OR

Use the  PLAY button to retrieve and process the

TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to

retrieve and process packets, starting from the tim e

shown in the packet time field. This processing wil |

stop automatically when a packet is received which

creation time is greater than the one contained in the

end time field.

ext Step:

11 Check contents of memory dump packets END

Verify that there are NO OBSM reported differences

between the memory dump data and the ground image u sed

for monitoring.

| F there are di f f er ences reported by OBSM between the

dump data and the ground image, the nerged i mage shall

be saved for offline analysis.

Status  : Version 2 - Unchanged
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111

%]

ve merged image

| F there are m smat ches reported by OBSM, save merged
image with new | D.

Conduct off-line analysis of the reported mismatche S.

End of Sequence

TC Seq. Nane : OFCP424T ( )
OFCP424T PACS SPU LWL DRAM dump monitoring in LIVE mode

TimeTag Type: B
Sub Schedule ID:

ext Step:
12 IF THEN 13
Image Monitor ELSE 18
In LIVE mode

type: [If]

ext Step:
13 Manual Stack manipulation 14

Load command stack file for PACS SPU LWL DRAM dump on
Manual Stack

NOTE:

The current procedure assumes that the memory dump in
Live mode is performed using commands with immediat e
execution.

Select the File -> LoadSt ack option from the main
menu of the Manual Stack window

13.1 IF
PACS Nominal

Select file

PASPRDLW DI _XXXXYYY_N_NoMddel _NoModel _YYYY_DDDThhmss.
nmachi ne

from directory

/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASPRDLW

as indicated by the OBSM engineer

IMPORTANT:

XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation

YYYY_DDD hhmmss- depend on stack generation time

machine - depends on the name of the machine used for
stack generation

Status  : Version 2 - Unchanged
Last Checkin: 05/09/08 Page 10 of 15
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File name exanpl es
- No model associated to the memory image:
PASPRDLW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043
- CT PASPRDLW1, ID 0003, Version 001 associated to the
memory image:
PASPRDLW_DI_0002001_C_PASPRDLW1_0003001_2007_337T0®32
0.sun043

13.2 ELSE
PACS Redundant
Select file
PASRDLWR_DI _XXXXYYY_N_NoMdel _NoModel _YYYY_DDDThhmmss.
machi ne
from directory
/home/pmcsops/HPMCS/SESSION/current/data/ CMD/STACKS /OB
SM/PASRDLWR
as indicated by the OBSM engineer
IMPORTANT:
XXXXYYYY= Image ID(X) and Version(Y) - depend on
image used for stack generation
YYYY_DDD hhmmss- depend on stack generation time
machine - depends on the name of the machine used for
stack generation
File name exanpl es
- No model associated to the memory image:
PASRDLWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043
- CT PASRDLWR1, ID 0003, Version 001 associated to the
memory image:
PASRDLWR_DI_0002001_C_PASRDLWR1_0003001_2007_337T0832
0.sun043

13.3 Check command stack loaded
Check that loaded stack contains one or several TCs
PC028380
Display the Manual Stack in 'Full mode' and check t hat
the Menory | Dparameter in the PC028380 command(s) is
setto 71 hex:
Menory ID = 71 hex
Not e:
The Memory ID of the target memory device is stored in
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most
significant 8 bits of the Start Address.

Status  : Version 2 - Unchanged
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Execute Telecommand
DPU_MEMORY_DUMP

Command Paraneter(s) :
DPU_MEMORY_BLOCK_I D
DPU_MEMORY_ADDR
DPU_DATA_LENGTH

PP009380
PP003380
PP008380

TC Control Flags :

Subsch. ID: 90
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

TC
PC028380

71xx
<hex> (Def)
<dec> (Def)

14

S OBSM preparation for Image monitor in L

IVE mode

ext Step:
15

Not e:

It is assumed that the OBSM application is already
running and the OBSM Desktop is displayed on the MC
client.

Starting the OBSM application is not covered by the
current procedure.

141

%]

2lect 'Image MONITOR' from the menu

Select the | mage menu of the OBSM Deskt op.

From the Image menu, select Moni t or .

The 'Image Catalog' window opens.

14.2

%]

2lect image to be monitored

14.2.1

PACS Nominal

Select the image to be monitored for the memory dev
PASPRDLW

The 'Image MONITOR' window opens.

ice

14.2.2

LSE
PACS Redundant

Select the image to be monitored for the memory dev
PASRDLWR.

The 'Image MONITOR' window opens.

ice

Status

Last Checkin: 05/09/08

: Version 2 - Unchanged
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14.3 Start dump TM processing

In LI VE mode, processing of incoming real-time
telemetry starts automatically after the image
selection.

15 Upload command(s) to dump the PACS SPU LWL DRAM

ext Step:
16

Upl i nk the PC028380 memory dump command(s) with ARM GO

For each command, one or more TM(6,6) packets must be
received on ground.

16 Verify reception of TM(6,6)

ext Step:
17

Not e:
One or more TM(6,6) packets will be received for ea ch
memory dump command uplinked.

16.1 IF
PACS Prime

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1152

Type : 6

Subtype : 6

PI1:

PI2:

16.2 ELSE
PACS Redundant

Verify Packet Reception

MEMORY_DUMP

Packet Mnemonic : MEMORY_DUMP
APID : 1153

Type : 6

Subtype : 6

PI1:

PI2:

17 Check contents of memory dump packets

ext Step:
END

Verify that there are NO OBSM reported differences
between the memory dump data and the ground image u sed
for monitoring.

Status  : Version 2 - Unchanged
Last Checkin: 05/09/08
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| F there are di f f er ences reported by OBSM between the
dump data and the ground image, the nerged i mage shall
be saved for offline analysis.
17.1 Save merged image
| F there are m smat ches reported by OBSM, save merged
image with new | D.
Conduct off-line analysis of the reported mismatche S.
End of Sequence
TC Seq. Name : OFCP424U ()
OFCP424U PACS SPU LWL DRAM dump monitoring in Retrieval mode
Ti meTag Type:
Sub Schedul e | D:
O
ext Step:
18 MCS OBSM preparation for Image monitor in R ETRIEVAL 19
mode
Not e:
It is assumed that the OBSM application is already
running and the OBSM Desktop is displayed on the MC S
client.
Starting the OBSM application is not covered by the
current procedure.
18.1 Select 'Image MONITOR' from the menu
Select the | mage menu of the OBSM Deskt op.
From the Image menu, select Moni t or .
The 'Image Catalog' window opens.
18.2 Select image to be monitored
18.2.1 IF
PACS Nominal
Select the image to be monitored for the memory dev ice
PASPRDLW
The 'Image MONITOR' window opens.

Status  : Version 2 - Unchanged
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18.2.2 ELSE

PACS Redundant

Select the image to be monitored for the memory dev ice

PASRDLV\R.

The 'Image MONITOR' window opens.
18.3 Start dump TM packets processing

Set retrieval start time and start retrieval of TM

packets using the PLAY buttons.

ext Step:

19 Retrieve and process TM(6,6) packets 20

Use the  STEP button to retrieve and process the

TM(6,6) packets, packet by packet and starting from

the time shown in the packet time field.

OR

Use the  PLAY button to retrieve and process the

TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to

retrieve and process packets, starting from the tim e

shown in the packet time field. This processing wil |

stop automatically when a packet is received which

creation time is greater than the one contained in the

end time field.

ext Step:

20 Check contents of memory dump packets END

Verify that there are NO OBSM reported differences

between the memory dump data and the ground image u sed

for monitoring.

| F there are di f f er ences reported by OBSM between the

dump data and the ground image, the nerged i mage shall

be saved for offline analysis.
20.1 Save merged image

| F there are m smat ches reported by OBSM, save merged

image with new | D.

Conduct off-line analysis of the reported mismatche S.

End of Sequence

[End of Procedure]

Status  : Version 2 - Unchanged
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