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This Herschel OBSM nominal procedure is used to exe cute the PACS 
SPU OBS full image upload in instrument INIT mode ( DPU 
Application SW running). It is called by the FOP PA CS procedures 
H_FCP_PAC_NLSM and H_FCP_PAC_RLSM.
The SPU OBS is loaded simultaneously into both SPU- SWL and SPU-
LWL memories.
The three OBS image segments (seg_rth, seg_init and  seg_pmco) are 
loaded into the PACS SPU EEPROM memory and the imag e integrity 
after upload is checked via checksum calculation an d 
verification. The checksum calculation is commanded  
simultaneously to both SPU-SWL and SPU-LWL memory.
The memory dumps are commanded separatelly for SPU- SWL and SPU-
LWL.

The SPU-SWL and SPU-LWL EEPROM OBS image checksum v erification is 
executed in the calling procedure H_FCP_PAC_NLSM or  
H_FCP_PAC_RLSM.

This procedure assumes that the memory load and mem ory check 
command stacks have already been generated using th e OBSM system 
and are ready for loading on the Manual Stack. The command stack 
generation activity is not covered by this proc

CDMU in Operational Mode
- PACS in INIT mode (DPU ASW running)
- SPU ON
- SPU-DMC communication established

Memory dumps must be commanded separatelly for SPU- SWL and SPU-
LWL. Patch and checksum calculation may use S&L MID . 

Memory areas are Loaded through TC(6,5) and Checked  through 
TC(6,9); this TCs will be delayed when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- PACS in INIT mode (DPU ASW running)
- SPU ON
- SPU-DMC communication established

End of Procedure

Same as start except:
- New PACS SPU OBS image loaded in DMC PM memory

Input Command Sequences

Procedure Summary

Objectives

Summary of Constraints

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e
Output Command Sequences

OFCP4210        

ANDs GRDs SLDs
PA000380    
PA029380    

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 30/01/08   1 1 Created  lstefanov-hp    

 18/06/09   2.5 2

1. added current steps 2, 3, 4 and 5, with sub-steps, to dump the PACS SPU OBS image 
from EEPROM SWL and LWL before patch�
2. step 6 and sub-steps updated to separate patch stack load for Prime and Redundant�
3. step 6 updated for PACS SPU OBS v.13.96�
4. added current step 8 to separate check stack load from patch stack load�
5. added current steps 10, 11, 12 and 13, with sub-steps, to dump the PACS SPU OBS 
image from EEPROM SWL and LWL after patch�
6. added current step 14 to include return to calling procedure�
7. updated Attachment1 for SPU OBS v.13.96  lstefanov-hp    

Configuration Control Information

Referenced Displays
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP4210
TC Seq. Name :OFCP4210 (  )
Load PACS SPU OBS in INIT mode and check image

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check:
- PACS instrument in INIT mode (DPU ASW running)
- SPU ON
- DPU-SPU connection established

 

Instrument SOE to confirm PACS instrument mode and SPU 
status.

 

Note:
Initial conditions are verified in calling procedur e 
H_FCP_PAC_NLSM or H_FCP_PAC_RLSM.

 

 

 2      Manual Stack manipulation
Load command stack file for PACS SPU current OBS du mp 
from SWL EEPROM on Manual Stack

 

 Next Step:
  3

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 2.1    IF
PACS Nominal

 

   

Select file

PASPEPSW_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPEPSW

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

e
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File name examples

- No model associated to the memory image:

PASPEPSW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPEPSW1, ID 0003, Version 001 associated to the 
memory image:

PASPEPSW_DI_0002001_C_PASPEPSW1_0003001_2007_337T09332
0.sun043

 

 

 2.2    ELSE
PACS Redundant

 

   

Select file

PASEPSWR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASEPSWR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASEPSWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASEPSWR1, ID 0003, Version 001 associated to the 
memory image:

PASEPSWR_DI_0002001_C_PASEPSWR1_0003001_2007_337T09332
0.sun043

 

 

 2.3    Check memory dump command stack loaded 

 

   

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

For PACS SPU OBS v.13.96:  

seg_rth

Start Address = 00.0100 hex
End Address   = 00.01FF hex
Length        = 100 hex
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seg_init

Start Address = 00.0300 hex
End Address   = 00.0523 hex
Length        = 224 hex

 

seg_pmco

Start Address = 00.0A00 hex
End Address   = 00.859E hex
Length        = 7B9F hex

 

IMPORTANT:
# of TCs, Address and Length values in the following 
sub-steps are applicable to PACS SPU OBS v.13.96

 

Note:
The ' Length' parameter of the memory dump command is a 
16-bit long parameter. A memory dump TC can cover a  
number of 65535 dec ( FFFF hex) SAUs.

 

 

 2.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   3 TCs PC028380

 

 

 2.3.2  Check memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the PC028380 commands is 
set to 43 hex:

Memory ID = 43 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

43xx hex  
 <hex> (Def)
 <hex> (Def)

TC  

 

 2.3.3  Check start address and length of first com mand in 
the stack
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e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first PC028380 command:

Start Address = 00.0100 hex
Length        = 100 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

4300 <hex> 
0100 <hex> 
100 <hex> 

TC  

 

 2.3.4  Check start address and length of second co mmand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the second PC028380 command:

Start Address = 00.0300 hex
Length        = 224 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

4300 <hex> 
0300 <hex> 
224 <hex> 

TC  

 

 2.3.5  Check start address and length of third com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the third PC028380 command:

Start Address = 00.0A00 hex
Length        = 7B9F hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

4300 <hex> 
0A00 <hex> 
7B9F <hex> 

TC  

 

 3      Dump PACS SPU current OBS image from SWL EE PROM

 

 Next Step:
  4

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

 

 3.1    MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 3.1.1  Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 3.1.2  Select image to be updated
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3.1.2.1

 IF
PACS Nominal

 

   

Select the image to be updated for the memory devic e 
PASPEPSW.

The 'Image UPDATE' window opens.

 

 

 
3.1.2.2

 ELSE
PACS Redundant

 

   

Select the image to be updated for the memory devic e 
PASEPSWR.

The 'Image UPDATE' window opens.

 

 

 3.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 3.2    Upload commands to dump the PACS SPU curren t OBS 
image

 

   

Uplink the PC028380 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 3.3    Verify reception of TM(6,6)

 

   

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 3.3.1  IF
PACS Nominal

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1152
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
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 3.3.2  ELSE
PACS Redundant

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1153
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 3.4    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 3.5    Save merged image

 

   

Save merged image with new ID.  

 

 4      Manual Stack manipulation
Load command stack file for PACS SPU current OBS du mp 
from LWL EEPROM on Manual Stack

 

 Next Step:
  5

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 4.1    IF
PACS Nominal

 

   

Select file

PASPEPLW_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPEPLW

as indicated by the OBSM engineer
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IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASPEPLW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPEPLW1, ID 0003, Version 001 associated to the 
memory image:

PASPEPLW_DI_0002001_C_PASPEPLW1_0003001_2007_337T09332
0.sun043

 

 

 4.2    ELSE
PACS Redundant

 

   

Select file

PASEPLWR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASEPLWR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASEPLWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASEPLWR1, ID 0003, Version 001 associated to the 
memory image:

PASEPLWR_DI_0002001_C_PASEPLWR1_0003001_2007_337T09332
0.sun043

 

 

 4.3    Check memory dump command stack loaded 

 

   

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

For PACS SPU OBS v.13.96:  
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seg_rth

Start Address = 00.0100 hex
End Address   = 00.01FF hex
Length        = 100 hex

 

seg_init

Start Address = 00.0300 hex
End Address   = 00.0523 hex
Length        = 224 hex

 

seg_pmco

Start Address = 00.0A00 hex
End Address   = 00.859E hex
Length        = 7B9F hex

 

IMPORTANT:
# of TCs, Address and Length values in the following 
sub-steps are applicable to PACS SPU OBS v.13.96

 

Note:
The ' Length' parameter of the memory dump command is a 
16-bit long parameter. A memory dump TC can cover a  
number of 65535 dec ( FFFF hex) SAUs.

 

 

 4.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   3 TCs PC028380

 

 

 4.3.2  Check memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the PC028380 commands is 
set to 63 hex:

Memory ID = 63 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

63xx hex  
 <hex> (Def)
 <hex> (Def)

TC  

 

 4.3.3  Check start address and length of first com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first PC028380 command:

Start Address = 00.0100 hex
Length        = 100 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

6300 <hex> 
0100 <hex> 
100 <hex> 

TC  

 

 4.3.4  Check start address and length of second co mmand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the second PC028380 command:

Start Address = 00.0300 hex
Length        = 224 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

6300 <hex> 
0300 <hex> 
224 <hex> 

TC  

 

 4.3.5  Check start address and length of third com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the third PC028380 command:

Start Address = 00.0A00 hex
Length        = 7B9F hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

6300 <hex> 
0A00 <hex> 
7B9F <hex> 

TC  

 

 5      Dump PACS SPU current OBS image from LWL EE PROM

 

 Next Step:
  6

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

 

 5.1    MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1.1  Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 5.1.2  Select image to be updated
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5.1.2.1

 IF
PACS Nominal

 

   

Select the image to be updated for the memory devic e 
PASPEPLW.

The 'Image UPDATE' window opens.

 

 

 
5.1.2.2

 ELSE
PACS Redundant

 

   

Select the image to be updated for the memory devic e 
PASEPLWR.

The 'Image UPDATE' window opens.

 

 

 5.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 5.2    Upload commands to dump the PACS SPU curren t OBS 
image

 

   

Uplink the PC028380 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 5.3    Verify reception of TM(6,6)

 

   

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 5.3.1  IF
PACS Nominal

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1152
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
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 5.3.2  ELSE
PACS Redundant

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1153
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 5.4    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 5.5    Save merged image

 

   

Save merged image with new ID.  

 

 6      Manual Stack manipulation
Load command stack files for OBS load on Manual Sta ck

 

 Next Step:
  7

 

 6.1    Load memory load command stack

 

   

IMPORTANT:
The OBS image is delivered in three separate image 
files, one for each of the segments seg_rth, seg_init 
and seg_pmco.
The current procedure assumes that the three images  
have been merged and saved in a single PACS SPU EEPROM 
image, and a single memory load command stack was 
generated for the SPU OBS upload.

 

Note:
PACS SPU EEPROM SWL and LWL memories are loaded 
simultaneously using the EEPROM S&L MID.

 

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window
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 6.2    IF
PACS Nominal

 

   

Select file

PASPEPSL_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPEPSL

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

PASPEPSL_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 6.3    ELSE
PACS Redundant

 

   

Select file

PASEPSLR_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASEPSLR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

PASEPSLR_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 6.4    Check memory load command stack loaded 
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For PACS SPU OBSW v.13.96:

- the start address of the PASPEPSL seg_rth segment 
memory image is 00.0100 hex, and the last address in 
the image is 00.01FF hex
- the start address of the PASPEPSL seg_init segment 
memory image is 00.0300 hex, and the last address in 
the image is 00.0523 hex
- the start address of the PASPEPSL seg_pmco segment 
memory image is 00.0A00 hex, and the last address in 
the image is 00.859E hex

NO offset is applied to the memory image for OBS 
upload in PM.

Consequently, the first address to be loaded is 
00.0100 hex, and the last address is 00.859E hex.

 

 

 6.4.1  Check number of memory load commands in the  stack

 

   

Check that loaded stack contains 855 TCs XC001998  

 

 6.4.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the XC001998 commands is 
set to 83 hex:

Memory ID = 83 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  PACS Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load PACS Memory Using Absolute 
Addresses

      XC001998

83xx hex  
 <hex> (Def)
 <dec> (Def)
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export

 

 6.4.3  Check start address and length of first com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first XC001998 command:

Start Address = 00.0100 hex
Length        = 38 dec

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  PACS Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load PACS Memory Using Absolute 
Addresses

      XC001998

8300 <hex> 
0100 <hex> 
38 <dec> 
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export

 

 6.4.4  Check start address and length of last command in the 
stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last XC001998 command:

Start Address = 8580 hex
Length        = 31 dec

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  PACS Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load PACS Memory Using Absolute 
Addresses

      XC001998

8300 <hex> 
8580 <hex> 
31 <dec> 
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export

 

 7      Upload PACS SPU-SWL and SPU-LWL OBS image i n EEPROM

 

 Next Step:
  8

Uplink the XC001998 memory load commands with ARM-GO  
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For each TC XC001998 successfuly executed on-board, 
the DPU HK counter DP_COM_REC_DPU should be 
incremented by one.
After all XC001998 TCs have been sent, the value of  
the counter should be: incremented by 855

 

Verify Telemetry
                DP_COM_REC_DPU            PM056380    = incremented 

by 855 dec 
AND=PA000380

Each TC XC001998 is converted inside the DPU into t wo 
memory load commands, one for SPU-SWL and one for S PU-
LWL.
Therefore, for each TC XC001998 successfuly executed 
on-board, two TM(1,1) and two TM(1,7) packets shall be 
received on ground.

 

 

 7.1    IF
PACS Prime

 

   

Verify Packet Reception

PACS_TC_ACP_OK
Packet Mnemonic :        TC_ACP_OK
APID :                   1152
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

PACS_TC_EXE_COMPL
Packet Mnemonic :        TC_EXE_COMPL
APID :                   1152
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 7.2    IF
PACS Redundant

 

   

Verify Packet Reception

PACS_TC_ACP_OK
Packet Mnemonic :        TC_ACP_OK
APID :                   1153
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

PACS_TC_EXE_COMPL
Packet Mnemonic :        TC_EXE_COMPL
APID :                   1153
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 8      Manual Stack manipulation
Load memory check command stack

 

 Next Step:
  9
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Note:
PACS SPU EEPROM SWL and LWL memories are checked 
simultaneously using the EEPROM S&L MID.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 8.1    IF
PACS Nominal

 

   

Select file

PASPEPSL_CI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPEPSL

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

PASPEPSL_CI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 8.2    ELSE
PACS Redundant

 

   

Select file

PASEPSLR_CI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASEPSLR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

PASEPSLR_CI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043
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 8.3    Check memory check command stack loaded 

 

   

Note:
The seg_pmco area is checked in successive 2048 dec  
SAU pages.

The start address, length and corresponding checksu m 
for each segment and each page of se_pmco are 
summarised in Attachment1.

All values correspond to PACS SPU OBS v. 13.8.

 

Check that 18 PC029380 memory check commands have been 
loaded on the Manual Stack.

 

Display the Manual Stack in 'Full mode' and check t he 
following addresses and lengths are covered by the 
PC029380 commands:

 

See tables in Attachment1 for start address, length 
and checksum values.

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

 

 9      Check OBS image in EEPROM

 

 Next Step:
  10

Uplink the PC029380 memory check commands one by one 
with ARM-GO and verify the received checksums against 
the corresponding expected values in Attachment1.

 

IMPORTANT:
For each TC(6,9), two TM(6,10) packets shall be 
received on ground.

 

 

 9.1    Verify reception and contents of TM(6,10)

 

   

Verify the TM(6,10) packet contents for each memory 
check command uplinked, using the tables in 
Attachment1.

 

 

 9.1.1  IF
PACS Prime

 

   

Verify Packet Reception

PACS_MEMORY_CRC
Packet Mnemonic :        MEMORY_CRC
APID :                   1152
Type :                   6
Subtype :                10
PI1 :                    
PI2 :                    
Verify Telemetry
                     MEMORY_ID            PM129380   AND=PA029380
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Verify Telemetry
                 START_ADDRESS            PM130380   AND=PA029380

Verify Telemetry
                        LENGTH            PM131380   AND=PA029380

Verify Telemetry
                      CHECKSUM            PM132380   AND=PA029380

 

 9.1.2  ELSE
PACS Redundant

 

   

Verify Packet Reception

PACS_MEMORY_CRC
Packet Mnemonic :        MEMORY_CRC
APID :                   1153
Type :                   6
Subtype :                10
PI1 :                    
PI2 :                    
Verify Telemetry
                     MEMORY_ID            PM129380   AND=PA029380

Verify Telemetry
                 START_ADDRESS            PM130380   AND=PA029380

Verify Telemetry
                        LENGTH            PM131380   AND=PA029380

Verify Telemetry
                      CHECKSUM            PM132380   AND=PA029380

 

 10     Manual Stack manipulation
Load command stack file for PACS SPU new OBS dump f rom 
SWL EEPROM on Manual Stack

 

 Next Step:
  11

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 10.1   IF
PACS Nominal

 

   

Select file

PASPEPSW_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPEPSW

as indicated by the OBSM engineer
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  File: H_FCP_OBS_4210.xls

  Author: lstefanov-hp

Step 
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e

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASPEPSW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPEPSW1, ID 0003, Version 001 associated to the 
memory image:

PASPEPSW_DI_0002001_C_PASPEPSW1_0003001_2007_337T09332
0.sun043

 

 

 10.2   ELSE
PACS Redundant

 

   

Select file

PASEPSWR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASEPSWR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASEPSWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASEPSWR1, ID 0003, Version 001 associated to the 
memory image:

PASEPSWR_DI_0002001_C_PASEPSWR1_0003001_2007_337T09332
0.sun043

 

 

 10.3   Check memory dump command stack loaded 

 

   

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

For PACS SPU OBS v.13.96:  
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seg_rth

Start Address = 00.0100 hex
End Address   = 00.01FF hex
Length        = 100 hex

 

seg_init

Start Address = 00.0300 hex
End Address   = 00.0523 hex
Length        = 224 hex

 

seg_pmco

Start Address = 00.0A00 hex
End Address   = 00.859E hex
Length        = 7B9F hex

 

IMPORTANT:
# of TCs, Address and Length values in the following 
sub-steps are applicable to PACS SPU OBS v.13.96

 

Note:
The ' Length' parameter of the memory dump command is a 
16-bit long parameter. A memory dump TC can cover a  
number of 65535 dec ( FFFF hex) SAUs.

 

 

 10.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   3 TCs PC028380

 

 

 10.3.2  Check memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the PC028380 commands is 
set to 43 hex:

Memory ID = 43 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

43xx hex  
 <hex> (Def)
 <hex> (Def)

TC  

 

 10.3.3  Check start address and length of first com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first PC028380 command:

Start Address = 00.0100 hex
Length        = 100 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

4300 <hex> 
0100 <hex> 
100 <hex> 

TC  

 

 10.3.4  Check start address and length of second co mmand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the second PC028380 command:

Start Address = 00.0300 hex
Length        = 224 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

4300 <hex> 
0300 <hex> 
224 <hex> 

TC  

 

 10.3.5  Check start address and length of third com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the third PC028380 command:

Start Address = 00.0A00 hex
Length        = 7B9F hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

4300 <hex> 
0A00 <hex> 
7B9F <hex> 

TC  

 

 11     Dump PACS SPU new OBS image from SWL EEPROM

 

 Next Step:
  12

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

 

 11.1   MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 11.1.1  Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 11.1.2  Select image to be updated
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11.1.2.
1

 IF
PACS Nominal

 

   

Select the image to be updated for the memory devic e 
PASPEPSW.

The 'Image UPDATE' window opens.

 

 

 
11.1.2.
2

 ELSE
PACS Redundant

 

   

Select the image to be updated for the memory devic e 
PASEPSWR.

The 'Image UPDATE' window opens.

 

 

 11.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 11.2   Upload commands to dump the PACS SPU curren t OBS 
image

 

   

Uplink the PC028380 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 11.3   Verify reception of TM(6,6)

 

   

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 11.3.1  IF
PACS Nominal

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1152
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
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 11.3.2  ELSE
PACS Redundant

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1153
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 11.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 11.5   Save merged image

 

   

Save merged image with new ID.  

 

 12     Manual Stack manipulation
Load command stack file for PACS SPU new OBS dump f rom 
LWL EEPROM on Manual Stack

 

 Next Step:
  13

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 12.1   IF
PACS Nominal

 

   

Select file

PASPEPLW_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASPEPLW

as indicated by the OBSM engineer
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IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASPEPLW_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASPEPLW1, ID 0003, Version 001 associated to the 
memory image:

PASPEPLW_DI_0002001_C_PASPEPLW1_0003001_2007_337T09332
0.sun043

 

 

 12.2   ELSE
PACS Redundant

 

   

Select file

PASEPLWR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/PASEPLWR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

PASEPLWR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT PASEPLWR1, ID 0003, Version 001 associated to the 
memory image:

PASEPLWR_DI_0002001_C_PASEPLWR1_0003001_2007_337T09332
0.sun043

 

 

 12.3   Check memory dump command stack loaded 

 

   

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

For PACS SPU OBS v.13.96:  
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seg_rth

Start Address = 00.0100 hex
End Address   = 00.01FF hex
Length        = 100 hex

 

seg_init

Start Address = 00.0300 hex
End Address   = 00.0523 hex
Length        = 224 hex

 

seg_pmco

Start Address = 00.0A00 hex
End Address   = 00.859E hex
Length        = 7B9F hex

 

IMPORTANT:
# of TCs, Address and Length values in the following 
sub-steps are applicable to PACS SPU OBS v.13.96

 

Note:
The ' Length' parameter of the memory dump command is a 
16-bit long parameter. A memory dump TC can cover a  
number of 65535 dec ( FFFF hex) SAUs.

 

 

 12.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   3 TCs PC028380

 

 

 12.3.2  Check memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the PC028380 commands is 
set to 63 hex:

Memory ID = 63 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

63xx hex  
 <hex> (Def)
 <hex> (Def)

TC  

 

 12.3.3  Check start address and length of first com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first PC028380 command:

Start Address = 00.0100 hex
Length        = 100 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

6300 <hex> 
0100 <hex> 
100 <hex> 

TC  

 

 12.3.4  Check start address and length of second co mmand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the second PC028380 command:

Start Address = 00.0300 hex
Length        = 224 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

6300 <hex> 
0300 <hex> 
224 <hex> 

TC  

 

 12.3.5  Check start address and length of third com mand in 
the stack
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With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the third PC028380 command:

Start Address = 00.0A00 hex
Length        = 7B9F hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                   DPU_MEMORY_DUMP

Command Parameter(s) :
           DPU_MEMORY_BLOCK_ID            PP009380
               DPU_MEMORY_ADDR            PP003380
               DPU_DATA_LENGTH            PP008380

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 90      
Det. descr. : DUMP OF A DPU MEMORY AREA
This Telecommand will not be included in the export

      PC028380

6300 <hex> 
0A00 <hex> 
7B9F <hex> 

TC  

 

 13     Dump PACS SPU new OBS image from LWL EEPROM

 

 Next Step:
  14

Note:
Following steps assume all 3 segments of the PACS S PU 
OBS image ( seg_rth, seg_init and seg_pmco) are dumped.

 

 

 13.1   MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 13.1.1  Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 13.1.2  Select image to be updated
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13.1.2.
1

 IF
PACS Nominal

 

   

Select the image to be updated for the memory devic e 
PASPEPLW.

The 'Image UPDATE' window opens.

 

 

 
13.1.2.
2

 ELSE
PACS Redundant

 

   

Select the image to be updated for the memory devic e 
PASEPLWR.

The 'Image UPDATE' window opens.

 

 

 13.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 13.2   Upload commands to dump the PACS SPU curren t OBS 
image

 

   

Uplink the PC028380 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 13.3   Verify reception of TM(6,6)

 

   

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 13.3.1  IF
PACS Nominal

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1152
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
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 13.3.2  ELSE
PACS Redundant

 

   

Verify Packet Reception

PACS_MEMORY_DUMP
Packet Mnemonic :        MEMORY_DUMP
APID :                   1153
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 13.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 13.5   Save merged image

 

   

Save merged image with new ID.  

 

 14     RETURN
to calling proc.
H_FCP_PAC_NLSM/H_FCP_PAC_RLSM

 

 Next Step:
  END

Return to calling procedure H_FCP_PAC_NLSM or 
H_FCP_PAC_RLSM

 

 

End of Sequence 

End of Procedure

Page 35 of 37
Status      : Version 2 - Unchanged
Last Checkin: 18/06/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

Attachment1

Checksums for step 4

PACS SPU OBS v.13.96
Start address [hex] Length [dec / hex] Checsum [hex]

00.0100 256 / 100 FEB0 seg_rth
00.0300 548 / 224 DDCD seg_init
00.0A00 2048 / 800 F921 seg_pmco
00.1200 2048 / 800 6B58
00.1A00 2048 / 800 19D7
00.2200 2048 / 800 A26B
00.2A00 2048 / 800 21F8
00.3200 2048 / 800 3FF2
00.3A00 2048 / 800 4118
00.4200 2048 / 800 6FB8
00.4A00 2048 / 800 092F
00.5200 2048 / 800 5D08
00.5A00 2048 / 800 CACF
00.6200 2048 / 800 CBFD
00.6A00 2048 / 800 FDEE
00.7200 2048 / 800 3B4F
00.7A00 2048 / 800 EC6B
00.8200 927 / 39F 2AB0
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