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This Herschel OBSM nominal procedure is used to pat ch  HIFI LCU 
memory areas. It can be used to patch the LCU memor y, as an 
alternative to the HIFI FOP procedures that use HPS DB commands 
with patch data hardcoded in TC parameters.

The patches are loaded using TC(6,2) and the verifi cation of the 
patched areas is done by memory dump. The memory du mp is 
commanded using TC(6,5) and the memory locations co ntent is 
received on ground in TM(6,6) packets.

This procedure assumes that the memory load and mem ory dump 
command stacks have already been generated using th e OBSM system 
and are ready for loading on the Manual Stack. The command stack 
generation activity is not covered by this procedur e.

CDMU in Operational Mode
- HIFI in Stand-by I mode
- HIFI LCU in Stand-by (waiting for Nominal Mode) o r Nominal Mode

Memory areas are patched via TC(6,2) and dumped thr ough TC(6,5); 
this TCs will be delayed when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- HIFI in Stand-by I mode
- HIFI LCU in Stand-by (waiting for Nominal Mode) o r Nominal Mode

End of Procedure

Same as start except:
-HIFI LCU memory patch and dump executed

Input Command Sequences

Output Command Sequences

OFCP3220        

ANDs GRDs SLDs

Procedure Summary

Objectives

Summary of Constraints

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 14/03/2011   3.1 1 Created  lstefanov-hp    

Configuration Control Information
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP3220
TC Seq. Name :OFCP3220 ( HIFI LCU Patch&Dmp )
Patch and dump HIFI LCU memory

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check:
- HIFI in Stand-by I mode
- HIFI LCU in Stand-by (waiting for Nominal Mode) o r 
Nominal Mode

 

Instrument SOE to confirm HIFI instrument mode  

 

 2      Manual Stack manipulation
Load command stack file for HIFI LCU memory dump on  
Manual Stack

 

 Next Step:
  3

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 2.1    IF
HIFI Prime

 

   

Select file

HILCUMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

e
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e

File name examples

- No model associated to the memory image:

HILCUMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMEM1, ID 0003, Version 001 associated to the 
memory image:

HILCUMEM_DI_0002001_C_HILCUMEM1_0003001_2007_337T09 332
0.sun043

 

 

 2.2    ELSE
HIFI Redundant

 

   

Select file

HILCUMER_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMER

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMER_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMER1, ID 0003, Version 001 associated to the 
memory image:

HILCUMER_DI_0002001_C_HILCUMER1_0003001_2007_337T09 332
0.sun043

 

 

 2.3    Check command stack loaded 

 

   

Note:
The current procedure assumes that 10 words are 
patched and dumped in the HIFI LCU patch area memory 
buffer:

MemID         = 04 hex
Start Address = 00.6C20 hex
End Address   = 00.6C2A hex

Length        = 0A hex

 

Check that loaded stack contains one TC XC005998  
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e

Display the Manual Stack in 'Full mode' and check t he 
XC005998 command loaded:

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

0400 <dec> 
6C20 <hex> 
000A <hex> 

TC  

 

 3      Dump initial values in HIFI LCU memory

 

 Next Step:
  4

 

 3.1    MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 3.1.1  Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 3.1.2  Select image to be updated

 

   

 

 
3.1.2.1

 IF
HIFI Prime

 

   

Select the image to be updated for the memory devic e 
HILCUMEM.

The 'Image UPDATE' window opens.
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e

 
3.1.2.2

 ELSE
HIFI Redundant

 

   

Select the image to be updated for the memory devic e 
HILCUMER.

The 'Image UPDATE' window opens.

 

 

 3.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 3.2    Command memory dump

 

   

Uplink the XC005998 memory dump command with ARM-GO  

For the uplinked command, a TM(6,6) packet shall be  
received on ground.

 

 

 3.3    Verify reception of TM(6,6)

 

   

Note:
A TM(6,6) packet will be received for the memory du mp 
command uplinked.

 

 

 3.3.1  IF
HIFI Prime

 

   

Verify Packet Reception

HIFI_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1024
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 3.3.2  ELSE
HIFI Redundant

 

   

Verify Packet Reception

HIFI_R_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1025
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
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No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 3.3.3  Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 3.4    Save merged image

 

   

Save merged image with new ID.  

 

 4      Manual Stack manipulation
Load command stack file for HIFI LCU memory patch o n 
Manual Stack

 

 Next Step:
  5

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 4.1    IF
HIFI Prime

 

   

Select file

HILCUMEM_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMEM_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMEM1, ID 0003, Version 001 associated to the 
memory image:

HILCUMEM_PI_0002001_C_HILCUMEM1_0003001_2007_337T09 332
0.sun043
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e

 

 4.1.1  ELSE
HIFI Redundant

 

   

Select file

HILCUMER_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMER

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMER_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMER1, ID 0003, Version 001 associated to the 
memory image:

HILCUMER_PI_0002001_C_HILCUMER1_0003001_2007_337T09 332
0.sun043

 

 

 4.2    Check memory load command stack loaded 

 

   

Note:
The current procedure assumes that 10 words are 
patched and dumped in the HIFI LCU patch area memory 
buffer:

MemID         = 04 hex
Start Address = 00.6C20 hex
End Address   = 00.6C2A hex

Length        = 0A hex

 

Memory Patch details:

 Memory ID:     04 hex
 Start address: 00.6C20 hex
 Length:        0A hex
 Patch data:    AABB AABB AABB AABB AABB
 [hex]          AABB AABB AABB AABB AABB

 

Check that loaded stack contains one TC XC000998.  

Page 9 of 22
Status      : Version 1 - Updated
Last Checkin: 14/03/2011 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.1
Issue Date:                    05/09/11

  Patch and dump HIFI LCU memory

  File: H_FCP_OBS_3220.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Display the Manual Stack in 'Full mode' and check t he 
XC000998 command loaded:

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load HIFI Memory Using Absolute 
Addresses

      XC000998

0400 <hex> 
6C20 <hex> 
10 <dec> 
AABBAABBAABBAABBAA
BBAABBAABBAABBAABB
AABB <hex> 
calculated by OBSM  

TC  

This Telecommand will not be included in the export

 

 5      Upload command to patch the HIFI LCU memory

 

 Next Step:
  6

Uplink the XC000998 memory load command with ARM-GO  

For a TC XC000998 successfuly executed on-board, a 
TM(1,1) and TM(1,7) packet shall be received on 
ground.

 

 

 5.1    IF
HIFI Prime

 

   

Verify Packet Reception

HIFI_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1024
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1024
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 5.2    ELSE
HIFI Redundant
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e

Verify Packet Reception

HIFI_R_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1025
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_R_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1025
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 6      Manual Stack manipulation
Load command stack file for HIFI LCU memory dump on  
Manual Stack

 

 Next Step:
  7

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 6.1    IF
HIFI Prime

 

   

Select file

HILCUMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMEM1, ID 0003, Version 001 associated to the 
memory image:

HILCUMEM_DI_0002001_C_HILCUMEM1_0003001_2007_337T09 332
0.sun043
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e

 6.2    ELSE
HIFI Redundant

 

   

Select file

HILCUMER_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMER

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMER_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMER1, ID 0003, Version 001 associated to the 
memory image:

HILCUMER_DI_0002001_C_HILCUMER1_0003001_2007_337T09 332
0.sun043

 

 

 6.3    Check command stack loaded 

 

   

Note:
The current procedure assumes that 10 words are 
patched and dumped in the HIFI LCU patch area memory 
buffer:

MemID         = 04 hex
Start Address = 00.6C20 hex
End Address   = 00.6C2A hex

Length        = 0A hex

 

Check that loaded stack contains one TC XC005998  

Display the Manual Stack in 'Full mode' and check t he 
XC005998 command loaded:

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.
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e

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

0400 <dec> 
6C20 <hex> 
000A <hex> 

TC  

 

 7      Verify patched areas via memory dump

 

 Next Step:
  8

 

 7.1    MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 7.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 7.1.2  Select image to be monitored

 

   

 

 
7.1.2.1

 IF
HIFI Prime

 

   

Select the image to be monitored for the memory dev ice 
HILCUMEM.

The 'Image MONITOR' window opens.

 

 

 
7.1.2.2

 ELSE
HIFI Redundant
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e

Select the image to be monitored for the memory dev ice 
HILCUMER.

The 'Image MONITOR' window opens.

 

 

 7.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 7.2    Command memory dump

 

   

Uplink the XC005998 memory dump command with ARM-GO  

For the uplinked command, a TM(6,6) packet shall be  
received on ground.

 

Expected dump values:

 Memory ID:     04 hex
 Start address: 00.6C20 hex
 Length:        0A hex
 Patch data:    AABB AABB AABB AABB AABB
 [hex]          AABB AABB AABB AABB AABB

 

 

 7.3    Verify reception of TM(6,6)

 

   

Note:
A TM(6,6) packet will be received for the memory du mp 
command uplinked.

 

 

 7.3.1  IF
HIFI Prime

 

   

Verify Packet Reception

HIFI_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1024
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 7.3.2  ELSE
HIFI Redundant
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e

Verify Packet Reception

HIFI_R_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1025
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 7.3.3  Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 7.4    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

Note:
The ground memory image used for dump monitoring is  
the same image used for patch command stack 
generation.

 

 

 7.4.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.
Conduct off-line analysis of the reported mismatche s.

 

 

 8      Manual Stack manipulation
Load command stack file for HIFI LCU memory patch o n 
Manual Stack

 

 Next Step:
  9

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Note:
The memory load command stack file will be 
generated in real time, based on the image saved 
in step 3 of current procedure, after dump of the 
initial values.

 

 

 8.1    IF
HIFI Prime
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e

Select file

HILCUMEM_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMEM_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMEM1, ID 0003, Version 001 associated to the 
memory image:

HILCUMEM_PI_0002001_C_HILCUMEM1_0003001_2007_337T09 332
0.sun043

 

 

 8.1.1  ELSE
HIFI Redundant

 

   

Select file

HILCUMER_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMER

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMER_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMER1, ID 0003, Version 001 associated to the 
memory image:

HILCUMER_PI_0002001_C_HILCUMER1_0003001_2007_337T09 332
0.sun043
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e

 

 8.2    Check memory load command stack loaded 

 

   

Note:
The current procedure assumes that 10 words are 
patched and dumped in the HIFI LCU patch area memory 
buffer:

MemID         = 04 hex
Start Address = 00.6C20 hex
End Address   = 00.6C2A hex

Length        = 0A hex

 

Memory Patch details:

 Memory ID:     04 hex
 Start address: 00.6C20 hex
 Length:        0A hex
 Patch data:    values dumped in step 3
 [hex]          

 

Check that loaded stack contains a TC XC000998.  

Display the Manual Stack in 'Full mode' and check t he 
XC000998 command loaded:

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load HIFI Memory Using Absolute 
Addresses

      XC000998

0400 <hex> 
6C20 <hex> 
10 <dec> 
initial values  
calculated by OBSM  

TC  

This Telecommand will not be included in the export

 

 9      Upload command to restore original values in HIFI LCU 
memory 

 

 Next Step:
  10

Uplink the XC000998 memory load command with ARM-GO  

For a TC XC000998 successfuly executed on-board, a 
TM(1,1) and TM(1,7) packet shall be received on 
ground.

 

 

 9.1    IF
HIFI Prime
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Verify Packet Reception

HIFI_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1024
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1024
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 9.2    ELSE
HIFI Redundant

 

   

Verify Packet Reception

HIFI_R_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1025
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_R_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1025
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 10     Manual Stack manipulation
Load command stack file for HIFI LCU memory dump on  
Manual Stack

 

 Next Step:
  11

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 10.1   IF
HIFI Prime
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Select file

HILCUMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMEM1, ID 0003, Version 001 associated to the 
memory image:

HILCUMEM_DI_0002001_C_HILCUMEM1_0003001_2007_337T09 332
0.sun043

 

 

 10.2   ELSE
HIFI Redundant

 

   

Select file

HILCUMER_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HILCUMER

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HILCUMER_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HILCUMER1, ID 0003, Version 001 associated to the 
memory image:

HILCUMER_DI_0002001_C_HILCUMER1_0003001_2007_337T09 332
0.sun043
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 10.3   Check command stack loaded 

 

   

Note:
The current procedure assumes that 10 words are 
patched and dumped in the HIFI LCU patch area memory 
buffer:

MemID         = 04 hex
Start Address = 00.6C20 hex
End Address   = 00.6C2A hex

Length        = 0A hex

 

Check that loaded stack contains one TC XC005998  

Display the Manual Stack in 'Full mode' and check t he 
XC005998 command loaded:

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

0400 <dec> 
6C20 <hex> 
000A <hex> 

TC  

 

 11     Dump final values in HIFI LCU memory

 

 Next Step:
  END

 

 11.1   MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 11.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.
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 11.1.2  Select image to be monitored

 

   

 

 
11.1.2.
1

 IF
HIFI Prime

 

   

Select the image to be monitored for the memory dev ice 
HILCUMEM.

The 'Image MONITOR' window opens.

 

 

 
11.1.2.
2

 ELSE
HIFI Redundant

 

   

Select the image to be monitored for the memory dev ice 
HILCUMER.

The 'Image MONITOR' window opens.

 

 

 11.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 11.2   Command memory dump

 

   

Uplink the XC005998 memory dump command with ARM-GO  

For the uplinked command, a TM(6,6) packet shall be  
received on ground.

 

 

 11.3   Verify reception of TM(6,6)

 

   

Note:
A TM(6,6) packet will be received for the memory du mp 
command uplinked.

 

 

 11.3.1  IF
HIFI Prime
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Verify Packet Reception

HIFI_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1024
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 11.3.2  ELSE
HIFI Redundant

 

   

Verify Packet Reception

HIFI_R_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1025
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 11.3.3  Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 11.4   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

Note:
The ground memory image used for dump monitoring is  
the same image used for patch command stack 
generation.

 

 

 11.4.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.
Conduct off-line analysis of the reported mismatche s.

 

 

End of Sequence 

End of Procedure

Page 22 of 22
Status      : Version 1 - Updated
Last Checkin: 14/03/2011 


