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This Herschel OBSM nominal procedure is used to per form a HIFI 
DPU PRAM ground image update from memory dump of on e or several 
HIFI DPU PRAM memory areas. The memory dump is comm anded using 
TC(6,5) and the memory locations content is receive d on ground in 
TM(6,6) packets.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

CDMU in Operational Mode
- HIFI in Intermediate mode (ASW running)

Memory areas are dumped through TC(6,5); this TC wi ll be delayed 
when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- HIFI in Intermediate mode (ASW running)

End of Procedure

Same as start except:
- HIFI DPU PRAM dump executed

Input Command Sequences

Output Command Sequences

OFCP3143        

ANDs GRDs SLDs

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 30/01/2008     1 Created  lstefanov-hp    

 30/01/2008   1 2 corrected typo in TC Sequence Name  lstefanov-hp    

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

 27/08/2008     3

1. added current steps 3.1 and 3.2 to separate dump stack load for HIFI Nom and Red�
2. current step 3.3 updated: TC HC004289 replaced by ESOC HIFI mem. dump TC 
XC005998�
3. added steps 4.2.1 and 4.2.2 to separate image selection for HIFI Nom and Red�
4. added steps 8.2.1 and 8.2.2 to separate image selection for HIFI Nom and Red  lstefanov-hp    

 27/08/2008     4

1. steps 3.1 and 3.2 updated: corrected typos in file name examples in 3rd comment - PI 
replaced by DI�
2. step 3.3 updated: changed 2nd comment to reflect the 16 bit length of the Mem ID 
param. of TC XC005998  lstefanov-hp    

 04/09/2008   2 5
1. steps 4.2.1, 4.2.2, 8.2.1 and 8.2.2 changed: "monitored" replaced by "updated" in 
comment statement  lstefanov-hp    

 13/04/2009   2.3 6
1. corrected typo in steps 3.1, 3.2: 'pmcsops' replaced by 'hmcsops'�
2. step 3.3 updated: added comment to indicate the size of the whole memory area  lstefanov-hp    

 10/06/2009     7
1. step 3.3 updated: added comments indicating start and end address for OBS image 
dump from PM-Low and PM-High  lstefanov-hp    

 16/06/2009     8
1. corrected typo in 2nd comment in step 3.3: 8000 hex replaced by 1852C hex, in line 
with Luc Dubbeldam's comment, e-mail 11/06/2009  lstefanov-hp    

 08/09/2009   2.5 9

1. step 3.3 updated to instruct the operator to exclude the runtime header memory area 
from OBSM Monitor/Comparison (for OBS image dumps), as advised by Luc Dubbeldam 
in e-mail from 23/06/2009  lstefanov-hp    

 11/02/2010     10 Updated step 3.3 with details of OBS 3.4.3 length  m.baker-hp    

 11/02/2010   3 11 Updated typo in memory end address in step 3.3.  m.baker-hp    

 22/04/2010     12 Updated to include software length for version 6.4.1.  m.baker-hp    

 27/01/2011     13 Updated to include software length for version 6.5.2.  n.krusenstiern-hp    

 14/04/2011   3.1 14 Updated for HIFI OBS 6.5.3  n.krusenstiern-hp    
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Procedure Flowchart Overview

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP3143
TC Seq. Name :OFCP3143 (  )
HIFI DPU PRAM image update in Live mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check HIFI instrument in Intermediate mode (ASW 
running)

 

Instrument SOE to confirm HIFI instrument mode  

 

 2      IF
Image update in LIVE mode

type: [If]

 Next Step:
 THEN 3
 ELSE 8

 

 3      Manual Stack manipulation
Load command stack file for HIFI DPU PRAM dump on 
Manual Stack

 

 Next Step:
  4

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 3.1    IF
HIFI Nominal

 

   

Select file

HIDPRMPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

HIDPRMPG_DI_0004001_N_NoModel_NoModel_2011_101T1722 57.
ws044

- CT HIDPRMPG1, ID 0003, Version 001 associated to the 
memory image:

HIDPRMPG_DI_0002001_C_HIDPRMPG1_0003001_2007_337T09 332
0.sun043

 

 

 3.2    ELSE
HIFI Redundant

 

   

Select file

HIDPRMPR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HIDPRMPR_DI_0004001_N_NoModel_NoModel_2011_101T1722 57.
ws044

- CT HIDPRMPR1, ID 0003, Version 001 associated to the 
memory image:

HIDPRMPR_DI_0002001_C_HIDPRMPR1_0003001_2007_337T09 332
0.sun043

 

 

 3.3    Check memory dump command stack loaded 

 

   

Note:
for the whole HIFI DPU PRAM dump:

MemID         = 00 hex
Start Address = 00.0000 hex
End Address   = 07.FFFF hex

Length        = 0 8.0000 hex
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
for the HIFI OBS v.6.5.3 image dump from PM-Low :

MemID         = 00 hex
Start Address = 00.0000 hex
End Address   = 01.8E1E hex

Length        = 0 1.8E1F hex

 

Note:
The HIFI OBS image delivered in ICD-14 format consi sts 
of one block.
The block contains three segments (PM-Low addresses 
following):

- the runtime header starts at 0x00, length= 0x100
- the init-segemnt starts at 0x4000
- the PM-code segment.

The regions between segments are filled with 0x00.

 

IMPORTANT:
The runtime header in PM-Low changes continuously.

A memory model (CT) shall be used to exclude this 
memory area from OBSM Image Monitor or Image Compar e 
against an OBSM Base Image.

 

Check that loaded stack contains one or several TCs  
XC005998

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the XC005998 command(s) is 
set to 00 hex:

Memory ID = 00 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

00xx <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 4      MCS OBSM preparation for Image update in LI VE mode

 

 Next Step:
  5

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 4.1    Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 4.2    Select image to be updated

 

   

 

 4.2.1  IF
HIFI Nominal

 

   

Select the image to be updated for the memory devic e 
HIDPRMPG.

The 'Image UPDATE' window opens.

 

 

 4.2.2  ELSE
HIFI Redundant

 

   

Select the image to be updated for the memory devic e 
HIDPRMPR.

The 'Image UPDATE' window opens.

 

 

 4.3    Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 5      Upload command(s) to dump the HIFI DPU PRAM

 

 Next Step:
  6

Uplink the XC005998 memory dump command(s) with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.

 

 

 6      Verify reception of TM(6,6)

 

 Next Step:
  7

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.
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e

 

 6.1    IF
HIFI Prime

 

   

Verify Packet Reception

HIFI_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1024
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 6.2    ELSE
HIFI Redundant

 

   

Verify Packet Reception

HIFI_R_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1025
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 6.3    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 7      Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP314B
TC Seq. Name :OFCP314B (  )
HIFI DPU PRAM image update in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 8      MCS OBSM preparation for Image update in RE TRIEVAL 
mode

 

 Next Step:
  9

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 8.1    Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 8.2    Select image to be updated

 

   

 

 8.2.1  IF
HIFI Nominal

 

   

Select the image to be updated for the memory devic e 
HIDPRMPG.

The 'Image UPDATE' window opens.

 

 

 8.2.2  ELSE
HIFI Redundant

 

   

Select the image to be updated for the memory devic e 
HIDPRMPR.

The 'Image UPDATE' window opens.

 

 

 8.3    Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 9      Retrieve and process TM(6,6) packets

 

 Next Step:
  10

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.
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 10     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

End of Procedure
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