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This Herschel OBSM nominal procedure is used to pat ch  HIFI DPU 
PRAM memory areas. It can be used for small patches  to be applied 
to the OBS, as an alternative to procedure H_FCP_OB S_3111.
Note: The OBS image has to be copied from PM-Low to  PM-High prior 
to loading the patches into DPU PM-High. This can b e done using 
procedure H_FCP_HIF_CPOM.

The patches are loaded into the HIFI DPU PM-High me mory and the 
verification of the patched areas is done by memory  dump.

The copying of the OBS image from PM-High to PM-Low  and OBS 
restart can be executed using procedure H_FCP_HIF_C POM. This also 
includes the PM-High OBS image checksum verificatio n and the 
updated OBS patch number verification.

This procedure assumes that the memory load and mem ory dump 
command stacks have already been generated using th e OBSM system 
and are ready for loading on the Manual Stack. The command stack 
generation activity is not covered by this procedur e.

CDMU in Operational Mode
- HIFI in Intermediate mode (ASW running)

Memory areas are Loaded through TC(6,2) and Dumped through 
TC(6,5); this TC will be delayed when there is an o ngoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- HIFI in Intermediate mode (ASW running)

End of Procedure

Same as start except:
- New HIFI OBS image loaded in DPU PM-High memory

Input Command Sequences

Output Command Sequences

OFCP3122        

ANDs GRDs SLDs

Procedure Summary

Objectives

Summary of Constraints

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 30/01/08   1 1 Created  lstefanov-hp    

 26/08/08     2

1. added steps 2.1.1 and 2.1.2 to separate patch stack load for HIFI Nom and Red�
2. added steps 2.3.1 and 2.3.2 to separate dump stack load for HIFI Nom and Red�
3. step 2.4 updated: TC HC004289 replaced by ESOC HIFI mem. dump TC XC005998�
4. added steps 4.2.1 and 4.2.2 to separate image selection for HIFI Nom and Red�
5. added step 5.2.1: save merged image if mismatches reported by OBSM  lstefanov-hp    

 26/08/08     3

1. step 2.4 updated: corrected typo in 1st and 2nd comments - HC005998 replaced by 
XC005998�
2. step 4.2 updated: removed comment, which appears now in step 4.2.1  lstefanov-hp    

 27/08/08   2 4

1. steps 2.3.1 and 2.3.2 updated: corrected typos in file name examples in 3rd comment - 
PI replaced by DI�
2. step 2.4 updated: changed 2nd comment to reflect the 16 bit length of the Mem ID 
param. of TC XC005998�
3. added step 5.1 for mem. dump command(s) upload  lstefanov-hp    

Configuration Control Information
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP3122
TC Seq. Name :OFCP3122 (  )
Patch and dump HIFI DPU PRAM memory

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check HIFI instrument in Intermediate mode (ASW 
running)

 

Instrument SOE to confirm HIFI instrument mode  

Note:
Initial conditions are verified in calling procedur e 
H_FCP_HIF_CLOM.

 

 

 2      Manual Stack manipulation
Load command stack files for HIFI DPU PRAM patch an d 
dump on Manual Stack

 

 Next Step:
  3

 

 2.1    Load memory load command stack

 

   

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 2.1.1  IF
HIFI Nominal

 

   

Select file

HIDPRMPG_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

e
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File name examples

- No model associated to the memory image:

HIDPRMPG_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HIDPRMPG1, ID 0003, Version 001 associated to the 
memory image:

HIDPRMPG_PI_0002001_C_HIDPRMPG1_0003001_2007_337T09 332
0.sun043

 

 

 2.1.2  ELSE
HIFI Redundant

 

   

Select file

HIDPRMPR_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HIDPRMPR_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HIDPRMPR1, ID 0003, Version 001 associated to the 
memory image:

HIDPRMPR_PI_0002001_C_HIDPRMPR1_0003001_2007_337T09 332
0.sun043

 

 

 2.2    Check memory load command stack loaded 

 

   

Check that loaded stack contains one or more TCs 
XC000998.

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the XC000998 command(s) is 
set to 00 hex:

Memory ID = 00 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.
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Execute Telecommand
                                  HIFI Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load HIFI Memory Using Absolute 
Addresses

      XC000998

00xx <hex>  
 <hex> (Def)
 <dec> (Def)
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export

 

 2.3    Load memory dump command stack

 

   

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 2.3.1  IF
HIFI Nominal

 

   

Select file

HIDPRMPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HIDPRMPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HIDPRMPG1, ID 0003, Version 001 associated to the 
memory image:

HIDPRMPG_DI_0002001_C_HIDPRMPG1_0003001_2007_337T09 332
0.sun043

 

 

 2.3.2  ELSE
HIFI Redundant
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e

Select file

HIDPRMPR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/pmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

HIDPRMPR_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT HIDPRMPR1, ID 0003, Version 001 associated to the 
memory image:

HIDPRMPR_DI_0002001_C_HIDPRMPR1_0003001_2007_337T09 332
0.sun043

 

 

 2.4    Check memory dump command stack loaded 

 

   

Check that loaded stack contains one or several TCs  
XC005998

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the XC005998 command(s) is 
set to 00 hex:

Memory ID = 00 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

00xx <hex>  
 <hex> (Def)
 <hex> (Def)

TC  
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 3      Upload command(s) to patch the HIFI DPU PRA M

 

 Next Step:
  4

Uplink the XC000998 memory load command(s) with ARM-GO  

For each TC XC000998 successfuly executed on-board,  a 
TM(1,1) and TM(1,7) packet shall be received on 
ground.

 

 

 3.1    IF
HIFI Prime

 

   

Verify Packet Reception

HIFI_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1024
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1024
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 3.2    ELSE
HIFI Redundant

 

   

Verify Packet Reception

HIFI_R_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1025
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_R_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1025
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 4      MCS OBSM preparation for Image monitor in L IVE mode

 

 Next Step:
  5

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.
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 4.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 4.2    Select image to be monitored

 

   

 

 4.2.1  IF
HIFI Nominal

 

   

Select the image to be monitored for the memory dev ice 
HIDPRMPG.

The 'Image MONITOR' window opens.

 

 

 4.2.2  ELSE
HIFI Redundant

 

   

Select the image to be monitored for the memory dev ice 
HIDPRMPR.

The 'Image MONITOR' window opens.

 

 

 4.3    Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 5      Verify patched areas via memory dump

 

 Next Step:
  END

 

 5.1    Upload command(s) to dump the HIFI DPU PRAM

 

   

Uplink the XC005998 memory dump command(s) with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.
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 5.2    Verify reception of TM(6,6)

 

   

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

 

 5.2.1  IF
HIFI Prime

 

   

Verify Packet Reception

HIFI_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1024
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 5.2.2  ELSE
HIFI Redundant

 

   

Verify Packet Reception

HIFI_R_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1025
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 5.3    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

Note:
The ground memory image used for dump monitoring is  
the same image used for patch command stack 
generation.

 

 

 5.3.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.
Conduct off-line analysis of the reported mismatche s.

 

 

End of Sequence 

End of Procedure
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