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This Herschel OBSM nominal procedure is used to exe cute the HIFI 
OBS full image upload in instrument Intermediate mo de (OBS upload 
from Application SW). It is called by the FOP HIFI procedure 
H_FCP_HIF_CLOM.
The OBS image is loaded into the HIFI DPU PM-High m emory and the 
image integrity after upload is checked via checksu m calculation 
and verification.

The copying of the OBS image from PM-High to PM-Low  and OBS 
restart is executed in the calling procedure H_FCP_ HIF_CLOM.
The calling procedure also includes the PM-High OBS  image 
checksum verification and updated OBS release numbe rs 
verification.

This procedure assumes that the memory load and mem ory check 
command stacks have already been generated using th e OBSM system 
and are ready for loading on the Manual Stack. The command stack 
generation activity is not covered by this procedur e.

Note: Patching (as alternative to full image upload ) of the HIFI 
DPU OBS in instrument Intermediate mode can be cond ucted via 
procedure H_FCP_OBS_3111.

CDMU in Operational Mode
- HIFI in Intermediate mode (ASW running)

Memory areas are Loaded through TC(6,2) and Checked  through 
TC(6,9); this TCs will be delayed when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- HIFI in Intermediate mode (ASW running)

End of Procedure

Same as start except:
- New HIFI OBS image loaded in DPU PM-High memory

Input Command Sequences

Output Command Sequences

OFCP3110        

Procedure Summary

Objectives

Summary of Constraints

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

ANDs GRDs SLDs

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 30/01/2008   1 1 Created  lstefanov-hp    

 06/01/2009   2 2

1. added current steps 2 and 3 and sub-steps for OBS image dump before new image 
load�
2. current step 4 and sub-steps updated to cover only OBS upload command stack load 
(separated manipulation of patch and check command stacks)�
3. current step 4.1 updated: created current sub-steps 4.1 and 4.2 to separate patch 
stack load for Prime and Redundant �
�

units�
4. added current step 6 and sub-steps for OBS image check command stack load 
(separated manipulation of patch and check command stacks)  lstefanov-hp    

 10/06/2009     3

1. steps 2.3, 4.3, 6.3, 7.1, 7.2 and sub-steps updated for address and length values 
compatible with HIFI OBS v.6.2.1�
2. step 8 updated: call to proc. H_FCP_OBS_3142 replaced by call to 
H_FCP_OBS_3142 (image monitor replaced by image update)  lstefanov-hp    

 16/06/2009     4
1. steps 6 and 7 and sub-steps updated for verification via checksums of the whole OBS 
image in PM-High, as advised by Luc Dubbeldam in e-mail from 11/06/2009  lstefanov-hp    

 08/09/2009   2.5 5 1. step 3.5 updated for "Image UPDATE" instead of "Image MONITOR"  lstefanov-hp    

 03/12/2009     6 Updated for sw version 6.3.1  m.baker-hp    

 10/02/2010     7 Updated in line with OBSW 6.4.1  m.baker-hp    

 10/02/2010     8 Corrected typo in OBS ID from 6.4.1 to 6.3.4  m.baker-hp    

 23/03/2010   3 9 Updated for ICU software 6.4  m.baker-hp    

 20/04/2010     10
Update for Version 6.4.1�
For Upload to S/C on 21/04/2010  n.krusenstiern-hp    

 20/04/2010     11 Updated minor typos steps 2.2, 4.2, 7.1  m.baker-hp    

 26/10/2010     12
Update for Version 6.4.2�
For Upload to S/C on 03/11/2010  n.krusenstiern-hp    

 27/01/2011     13 Updated for OBSW 6.5.2  n.krusenstiern-hp    

 27/01/2011     14 Check Memory ID changed from 0x0000 to 0x0003 in 4.2.2 and to 0x004 in 6.2.2.  n.krusenstiern-hp    

 13/04/2011   3.1 15

Update for Version 6.5.3�
Removed unused FCT CRC checks (Old Steps 5 & 6)�
For Upload to S/C on 14/04/2011  n.krusenstiern-hp    

Configuration Control Information
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP3110
TC Seq. Name :OFCP3110 ( HIFI OBS load ASW )
Load HIFI OBS from ASW and check image

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check HIFI instrument in Intermediate mode (ASW 
running)

 

Instrument SOE to confirm HIFI instrument mode  

Note:
Initial conditions are verified in calling procedur e 
H_FCP_HIF_CLOM.

 

 

 2      Manual Stack manipulation
Load command stack file for HIFI DPU current OBS du mp 
on Manual Stack

 

 Next Step:
  3

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 2.1    HIFI Redundant

 

   

Select file

HIDPRMPR_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

HIDPRMPR_DI_0014001_N_NoModel_NoModel_2011_101T1722 57.
ws044

 

e
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File name HIFI OBS v.6.5.3:

HIDPRMPR_DI_0014001_N_NoModel_NoModel_2011_101T1722 57.
ws044

 

 

 2.2    Check memory dump command stack loaded 

 

   

Note:
The HIFI DPU OBS image is dumped from the PM-LOW area

 

For HIFI OBS v.6.5.3:

Start Address = 00.0000 hex
End Address   = 01.8E1E hex
Length        = 01.8E1E hex

 

IMPORTANT:
# of TCs, Address and Length values in the following 
sub-steps are applicable to HIFI OBS v.6.5.3

 

Note:
The ' Length' parameter of the memory dump command is a 
16-bit long parameter. A memory dump TC can cover a  
number of 65535 dec ( FFFF hex) SAUs.

 

 

 2.2.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   2 TCs XC005998

 

 

 2.2.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the XC005998 commands is 
set to 00 hex:

Memory ID = 00 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

00xx <hex>  
 <hex> (Def)
 <hex> (Def)

TC  
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e

 2.2.3  Check start address and length of first com mand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first XC005998 command:

Start Address = 00.0000 hex
Length        = FFFF hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

0000 <hex> 
0000 <hex> 
FFFF <hex> 

TC  

 

 2.2.4  Check start address and length of second co mmand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the second XC005998 command:

Start Address = FFFF hex
Length        = 8E20 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Dump

Command Parameter(s) :
                     Memory ID            XH008998
                 Start Address            XH009998
                        Length            XH010998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 70      
Det. descr. : Dump HIFI Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      XC005998

0000 <hex> 
FFFF <hex> 
8E17 <hex> 

TC  

 

 3      Dump HIFI DPU current OBS image

 

 Next Step:
  4
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e

Note:
The HIFI DPU OBS image is dumped from the PM-Low area

 

 

 3.1    MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 3.1.1  Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 3.1.2  Select image to be updated HIFI Redundant

 

   

Select the image to be updated for the memory devic e 
HIDPRMPR.

The 'Image UPDATE' window opens.

 

 

 3.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 3.2    Upload commands to dump the HIFI DPU curren t OBS 
image

 

   

Uplink the XC005998 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 3.3    Verify reception of TM(6,6)

 

   

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

APID = 1025 for HIFI redundant.
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Verify Packet Reception

HIFI_R_memory_dump
Packet Mnemonic :        H_mem_dump
APID :                   1025
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 3.4    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 3.5    Save merged image

 

   

Save merged image with new ID.  

 

 4      Manual Stack manipulation
Load command stack file for OBS load on Manual Stac k

 

 Next Step:
  5

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 4.1    HIFI Redundant

 

   

Select file

HIDPRMPR_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/HIDPRMPR

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name HIFI OBS v.6.5.3:

HIDPRMPR_PI_0014001_N_NoModel_NoModel_2011_101T1722 37.
ws044
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e

 4.2    Check memory load command stack loaded 

 

   

For HIFI OBS v.6.5.3:

The start address of the HIDPRMPR memory image used  
for memory load command stack generation is 00.000 
hex, and the last address in the image is 01.8E15 hex.

The offset applied to the memory image for OBS upload 
in PM-High is 03.FFFF hex.

Consequently, the first address to be loaded is 
03.FFFF hex, and the last address is 05.8E14 hex:

Start Address = 03.FFFF hex
End Address   = 05.8E1D hex
Length        = 01.8E1E hex

 

IMPORTANT:
# of TCs, Address and Length values in the following 
sub-steps are applicable to HIFI OBS v.6.5.3

 

 

 4.2.1  Check number of memory load commands in the  stack

 

   

Check that loaded stack contains:
   2683 TCs XC000998 for OBS v.6.5.3

 

 

 4.2.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the XC000998 commands is 
set to 03 hex:

Memory ID = 03 hex

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load HIFI Memory Using Absolute 
Addresses

      XC000998

03xx hex  
 <hex> (Def)
 <dec> (Def)
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export
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 4.2.3  Check start address and length of first com mand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first XC000998 command:

Start Address = 03.FFFF hex
Length        = 38 dec

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load HIFI Memory Using Absolute 
Addresses

      XC000998

0003 <hex> 
FFFF <hex> 
38 <dec> 
 <hex> (Def)
792 <hex> 

TC  

This Telecommand will not be included in the export

 

 4.2.4  Check start address and length of last command in the 
stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last XC000998 command:

Start Address = 05.8E1B hex
Length        = 03 dec

Note:
The Memory ID of the target memory device is stored  in 
the MSB of the 16-bit long Mem ID TC parameter.
The LSB of the same parameter carries the most 
significant 8 bits of the Start Address.

 

Execute Telecommand
                                  HIFI Memory Load

Command Parameter(s) :
                     Memory ID            XH000998
                 Start Address            XH001998
               Length of Block            XH003998
       Var length octet string            XH004998
                      Checksum            XH005998

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 30      
Det. descr. : Load HIFI Memory Using Absolute 
Addresses

      XC000998

0005 <hex> 
8DF5 <hex> 
32 <dec> 
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export
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 5      Upload HIFI OBS image in PM-High

 

 Next Step:
  6

Uplink the XC000998 memory load commands with ARM-GO  

For each TC XC000998 successfuly executed on-board,  a 
TM(1,1) and TM(1,7) packet shall be received on 
ground.

 

Verify Packet Reception

HIFI_R_TC_acceptance_OK
Packet Mnemonic :        H_Accepted
APID :                   1025
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

HIFI_R_TC_execution_OK
Packet Mnemonic :        H_Completed
APID :                   1025
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 6      RETURN
to proc. H_FCP_HIF_CLOM

 

 Next Step:
  END

IMPORTANT:
After OBS image copy from PM-High to PM-Low execute d 
in H_FCP_HIF_CLOM, you may dump the HFI DPU new OBS 
image from PM-Low using FOP procedure H_FCP_OBS_3143

 

 

End of Sequence 

End of Procedure
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