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This Herschel OBSM nominal procedure is used to per form an STR1 
or STR2 EEPROM dump monitoring against the ground i mage. The 
procedure assumes the following STR EEPROM areas ar e dumped:
  EAPPL_SW (including the Star Catalogues)
  Bad Pixel Table

The ACMS ASW provides a dedicated function for exec uting STR 
memory dumps. This function manages both the collec tion of data 
from the STR and the transmission to the ground thr ough standard 
service 6 memory dump packets.
The memory dump is commanded using TC(8,4,130,125) and the memory 
locations content is received on ground in TM(6,6) packets.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

This procedure is called by the Herschel ACMS proce dures 
H_FCP_AOC_4S51 and H_FCP_AOC_4S52.

CDMU in Operational Mode
- ACC in Operational Mode
- STR NOT in INI Mode

- A maximum of 1536 32-bit words can be dumped with  a single STR 
memory dump command
- The value of the 'STRSw Nr Words' parameter in th e STR memory 
dump TC has to be a multiple of 12
- The STR memory is addressed in 32-bit words, whil e the address 
propagation is done at byte level. The start addres s of any 
service 6 TC shall to be a multiple of 4
- STR Main telemetry is part of the essential and m ode telemetry 
packets. If the STR selected for dump is not config ured as MAIN, 
a diagnostic telemetry packet has to be enablen in order to 
verify the status of the physical unit.

Note: The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The star t address of 
any service 6 TC shall to be a multiple of 4.

Start of Procedure

CDMU in Operational Mode
- ACC in Operational Mode
- STR NOT in INI Mode

End of Procedure

Same as start except:
- STR1 and/or STR2 EEPROM dump executed

Input Command Sequences

Procedure Summary

Objectives

Summary of Constraints

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

Output Command Sequences

OFCP284I        
OFCP284K        

ANDs GRDs SLDs
AA01X109    

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF
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Configuration Control Information
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Procedure Flowchart Overview
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP2842
TC Seq. Name :OFCP2842 ( STR EEPROM Dmp Mon )
STR EEPROM dump monitoring

TimeTag Type:  
Sub Schedule ID: 

 �

 1      SWITCH
Select STR

type: [Switch]

 Next Step:
 STR1 2
 STR2 12

 

End of Sequence 

OFCP284I
TC Seq. Name :OFCP284I ( STR1 EEPROM DmpMon I )
STR1 EEPROM dump monitoring in LIVE mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 2      IF
Image monitor in LIVE mode

type: [If]

 Next Step:
 THEN 3
 ELSE 9

 

 3      Verify initial conditions

 

 Next Step:
  4

Check:
- CDMU in Operational Mode
- ACC in Operational Mode
- STR1 NOT in INI Mode

 

Note:
In ACMS mode in which the STR data are used for 
attitude determination, the STR cannot be in INI mo de 
without triggering FDIR. The procedure can, however  be 
executed also in SAM, in which there is no constrai nt 
on the STR mode so that explicit check is necessary  to 
make sure that the download commands will not be 
rejecteded by the STR.

 

CDMU SOE to confirm CDMU mode  

AOCS SOE to confirm ACC and STR mode  

Note:
STR Main telemetry is part of the essential and mode 
telemetry packets. If not configured as MAIN, a 
diagnostic telemetry packet has to be enabled in or der 
to verify the status of the physical unit.
This is executed in calling procedure H_SVT_AOC_4S5 1 
or H_SVT_AOC_4S52.

 

Verify Telemetry
                     STRM Mode            AEX04001 <> Initialisation AND=AA01X109

OR  

Verify Telemetry
                Operating Mode            AMX12074 <> Initialisation AND=AA01X109

 

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 4      Manual Stack manipulation
Load command stack file for STR1 EEPROM dump on Man ual 
Stack

 

 Next Step:
  5

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR1EEPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR1EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

STR1EEPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT STR1EEPG1, ID 0003, Version 001 associated to the 
memory image:

STR1EEPG_DI_0002001_C_STR1EEPG1_0003001_2007_337T09 332
0.sun043

 

 

 4.1    Check memory dump command stack loaded 

 

   

For a full STR EEPROM dump:

Start Address = 0400.0000 hex
End Address   = 0407.FFDF hex
Length        = 1FFF8 hex (32-bit words)

IMPORTANT:
The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The start 
address of any service 6 TC shall to be a multiple of 
4.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
Following steps assume a complete dump of the STR1 
EEPROM, including following memory areas: 
  EAPPL_SW (including Star Catalogues)
  Bad Pixel Table

IF one or several other partial dumps of the STR1 
EEPROM are commanded, the number of dump TCs, start  
address and length will be different.

 

 

 4.1.1  Check number of memory dump commands in the  stack

 

   

IMPORTANT:
A maximum of 1536 32-bit words can be dumped with a 
single STR memory dump command.

 

IMPORTANT:
The value of the ' STRSw Nr Words' parameter in TC 
ACXD1001 has to be always a multiple of 12.

 

Note:
For full STR1 EEPROM dump, the stack contains:
   86 TCs ACXD1001

 

 

 4.1.2  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXD1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 1536 dec (32-bit words)

IMPORTANT:
The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The start 
address of any service 6 TC shall to be a multiple of 
4.

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
04000000 <hex> 
1536 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 4.1.3  Check start address and length of the last dump 
command in the stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXD1001 command:

STRSw STR Mem  = 0407.FE00 hex
STRSw Nr Words = 120 dec (32-bit words)

IMPORTANT:
The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The start 
address of any service 6 TC shall to be a multiple of 
4.

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
0407FE00 <hex> 
120 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 5      MCS OBSM preparation for Image monitor in L IVE mode

 

 Next Step:
  6

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 5.2    Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR1EEPG.

The 'Image MONITOR' window opens.

 

 

 5.3    Start dump TM processing
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 6      Upload commands to dump the STR1 EEPROM

 

 Next Step:
  7

Uplink the ACXD1001 memory dump commands with ARM-GO  

After successful execution of each command, 2 TM(6, 6) 
packets shall be received on ground.

 

 

 7      Verify reception of TM(6,6)

 

 Next Step:
  8

Note:
2 TM(6,6) packets will be received for each memory 
dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 7.1    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 7.2    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 8      Save merged image

 

 Next Step:
  END

WAIT for execution completion of the last dump 
command.

 

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

OFCP284J
TC Seq. Name :OFCP284J ( STR1 EEPORM DmpMon J )
STR1 EEPROM dump monitoring in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 9      MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  10

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 9.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 9.2    Select image to be monitord

 

   

Select the image to be monitored for the memory dev ice 
STR1EEPG.

The 'Image MONITOR' window opens.

 

 

 9.3    Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 10     Retrieve and process TM(6,6) packets

 

 Next Step:
  11

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 11     Save merged image

 

 Next Step:
  END

WAIT for retrieval completion of the last dump pack et.  

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP284K
TC Seq. Name :OFCP284K ( STR2 EEPROM DmpMon K )
STR2 EEPROM dump monitoring in LIVE mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 12     IF
Image monitor in LIVE mode

type: [If]

 Next Step:
 THEN 13
 ELSE 19

 

 13     Verify initial conditions

 

 Next Step:
  14

Check:
- CDMU in Operational Mode
- ACC in Operational Mode
- STR1 NOT in INI Mode

 

Note:
In ACMS mode in which the STR data are used for 
attitude determination, the STR cannot be in INI mo de 
without triggering FDIR. The procedure can, however  be 
executed also in SAM, in which there is no constrai nt 
on the STR mode so that explicit check is necessary  to 
make sure that the download commands will not be 
rejecteded by the STR.

 

CDMU SOE to confirm CDMU mode  

AOCS SOE to confirm ACC and STR mode  

Note:
STR Main telemetry is part of the essential and mode 
telemetry packets. If not configured as MAIN, a 
diagnostic telemetry packet has to be enabled in or der 
to verify the status of the physical unit.
This is executed in calling procedure H_SVT_AOC_4S5 1 
or H_SVT_AOC_4S52.

 

Verify Telemetry
                     STRM Mode            AEX04001 <> Initialisation AND=AA01X109

OR  

Verify Telemetry
                Operating Mode            AMX12074 <> Initialisation AND=AA01X109
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 14     Manual Stack manipulation
Load command stack file for STR2 RAM dump on Manual  
Stack

 

 Next Step:
  15

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR2EEPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR2EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

STR2EEPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT STR2EEPG1, ID 0003, Version 001 associated to the 
memory image:

STR2EEPG_DI_0002001_C_STR2EEPG1_0003001_2007_337T09 332
0.sun043

 

 

 14.1   Check memory dump command stack loaded 

 

   

For a full STR EEPROM dump:

Start Address = 0400.0000 hex
End Address   = 0407.FFDF hex
Length        = 1FFF8 hex (32-bit words)

IMPORTANT:
The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The start 
address of any service 6 TC shall to be a multiple of 
4.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
Following steps assume a complete dump of the STR1 
EEPROM, including following memory areas: 
  EAPPL_SW (including Star Catalogues)
  Bad Pixel Table

IF one or several other partial dumps of the STR1 
EEPROM are commanded, the number of dump TCs, start  
address and length will be different.

 

 

 14.1.1  Check number of memory dump commands in the  stack

 

   

Note:
A maximum of 1536 32-bit words can be dumped with a 
single STR memory dump command.

 

IMPORTANT:
The value of the ' STRSw Nr Words' parameter in TC 
ACXD1001 has to be always a multiple of 12.

 

Note:
For full STR EEPROM dump, the stack contains:
   86 TCs ACXD1001

 

 

 14.1.2  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXD1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 1536 dec (32-bit words)

IMPORTANT:
The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The start 
address of any service 6 TC shall to be a multiple of 
4.

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
04000000 <hex> 
1536 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 14.1.3  Check start address and length of the last dump 
command in the stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXD1001 command:

STRSw STR Mem  = 0407.FE00 hex
STRSw Nr Words = 120 dec (32-bit words)

IMPORTANT:
The STR memory is addressed in 32-bit words, while the 
address propagation is done at byte level. The start 
address of any service 6 TC shall to be a multiple of 
4.

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
0407FE00 <hex> 
120 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 15     MCS OBSM preparation for Image monitor in L IVE mode

 

 Next Step:
  16

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 15.1   Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 15.2   Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR2RMPG.

The 'Image MONITOR' window opens.

 

 

 15.3   Start dump TM processing
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 16     Upload commands to dump the STR2 EEPROM

 

 Next Step:
  17

Uplink the ACXD1001 memory dump commands with ARM-GO  

After successful execution of each command, 2 TM(6, 6) 
packets shall be received on ground.

 

 

 17     Verify reception of TM(6,6)

 

 Next Step:
  18

Note:
2 TM(6,6) packets will be received for each memory 
dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 17.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 17.2   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 18     Save merged image

 

 Next Step:
  END

WAIT for execution completion of the last dump 
command.

 

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

OFCP284L
TC Seq. Name :OFCP284L ( STR2 EEPROM DmpMon L )
STR2 EEPROM dump monitoring in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 19     MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  20

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 19.1   Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 19.2   Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR2EEPG.

The 'Image MONITOR' window opens.

 

 

 19.3   Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 20     Retrieve and process TM(6,6) packets

 

 Next Step:
  21

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.
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  Update STR EEPROM ground image from memory dump

  File: H_FCP_OBS_2842.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 21     Save merged image

 

 Next Step:
  END

WAIT for retrieval completion of the last dump pack et.  

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

End of Procedure
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