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This Herschel OBSM nominal procedure is used to exe cute the STR1 
or STR2 OBS full image upload in STR EEPROM. This p rocedure 
assumes that the OBS image covers both EAPPL and St ar Catalogue 
EEPROM areas.

The loading of STR memory is carried out using a de dicated TC 
provided by the ACC ASW.
The ACMS ASW provides a dedicated function for exec uting STR 
memory dumps. This function manages both the collec tion of data 
from the STR and the transmission to the ground thr ough standard 
service 6 memory dump packets.

The memory load is commanded using TC(8,4,130,130).  The memory 
dump is commanded using TC(8,4,130,125) and the mem ory locations 
content is received on ground in TM(6,6) packets.

This procedure is called by the Herschel ACMS proce dures 
H_FCP_AOC_4S61 and H_FCP_AOC_4S62.

CDMU in Operational Mode
- ACC in Operational Mode
- STR in SW Maintenance Mode (SWM)

- STR memory load commands may be uplinked only in STR SW 
Maintenance Mode (SWM)
- A maximum of 14 32-bit words can be uploaded with  a single STR 
memory load command (TBC)
- The maximum rate with which data can be sent to t he STR by the 
ACC is 56 32-bit words in a single ACMS cycle, equi valent to 224 
words/second.
- STR Main telemetry is part of the essential and m ode telemetry 
packets. If the STR selected for patch and dump is not configured 
as MAIN, a diagnostic telemetry packet has to be en ablen in order 
to verify the status of the physical unit.

Start of Procedure

CDMU in Operational Mode
- ACC in Operational Mode
- STR in SW Maintenance Mode (SWM)

End of Procedure

Same as start except:
- New STR OBS image loaded in STR1 or STR2 EEPROM

Input Command Sequences

Output Command Sequences

OFCP281A        
OFCP281B        

Procedure Summary

Objectives

Summary of Constraints

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

ANDs GRDs SLDs
AA01X109    

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 13/01/09   2 1 Created  lstefanov-hp    

 13/04/09   2.3 2 1. corrected typo in steps 3, 5, 7, 11, 13 and 15: 'pmcsops' replaced by 'hmcsops'  lstefanov-hp    

Configuration Control Information

Referenced Displays
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Procedure Flowchart Overview

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP2810
TC Seq. Name :OFCP2810 ( LOAD STR OBS EEPROM )
Load STR OBS in EEPROM

TimeTag Type:  
Sub Schedule ID: 

 �

 1      SWITCH
Select STR

type: [Switch]

 Next Step:
 STR1 2
 STR2 10

 

End of Sequence 

OFCP281A
TC Seq. Name :OFCP281A ( LOAD STR1 OBS EEPROM )
Load STR1 OBS in EEPROM and check image

TimeTag Type:  B
Sub Schedule ID: 

 �

 2      Verify initial conditions

 

 Next Step:
  3

Check:
- CDMU in Operational Mode
- ACC in Operational Mode
- STR1 in SWM

 

CDMU SOE to confirm CDMU mode  

AOCS SOE to confirm ACC and STR mode  

Note:
STR transition to SW Maintenance Mode and all 
associated TM checks are executed in calling proced ure 
H_SVT_AOC_4S61 or H_SVT_AOC_4S62.

 

Note:
STR Main telemetry is part of the essential and mode 
telemetry packets. If not configured as MAIN, a 
diagnostic telemetry packet has to be enabled in or der 
to verify the status of the physical unit.
This is executed in calling procedure H_SVT_AOC_4S5 1 
or H_SVT_AOC_4S52.

 

Verify Telemetry
                     STRM Mode            AEX04001  = SW Maintenance AND=AA01X109

OR  

Verify Telemetry
                Operating Mode            AMX12074  = SW Maintenance AND=AA01X109

 

 3      Manual Stack manipulation
Load command stack file for STR1 current OBS dump f rom 
EEPROM on Manual Stack

 

 Next Step:
  4

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR1EEPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR1EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

STR1EEPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 3.1    Check memory dump command stack loaded 

 

   

For STR OBS v.x.y:

Start Address = 0400.0000 hex
End Address   = 0403.0A13 hex (TBC)
Length        = 30A14 hex (TBC) 32-bit words

 

Note:
This procedure assumes that the OBS image covers bo th 
EAPPL and Star Catalogue EEPROM areas.

 

 

 3.1.1  Check number of memory dump commands in the  stack

 

   

Note:
A maximum of 1536 32-bit words can be dumped with a 
single STR memory dump command.

 

Check that loaded stack contains:
  130 (TBC) TCs ACXD1001

 

 

 3.1.2  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXD1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 1536 dec
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
04000000 <hex> 
1536 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 3.1.3  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXD1001 command:

STRSw STR Mem  = 040x.xxxx hex
STRSw Nr Words = TBC dec

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
 <hex> (Def)
 <dec> (Def)

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 4      Dump STR1 current OBS image from EEPROM

 

 Next Step:
  5

Note:
The dump of the current OBS image should be execute d 
in a DTCP preceding the DTCP selected for the new O BS 
image load.

 

 

 4.1    MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 4.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 4.1.2  Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR1EEPG.

The 'Image MONITOR' window opens.

 

 

 4.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 4.2    Upload commands to dump the STR1 current OB S image 
from EEPROM

 

   

Uplink the ACXD1001 memory dump commands with ARM-GO  

After successful execution of each command, 2 TM(6, 6) 
packets shall be received on ground.

 

 

 4.3    Verify reception of TM(6,6)

 

   

Note:
2 TM(6,6) packets will be received for each memory 
dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 4.4    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 4.5    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 4.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

 5      Manual Stack manipulation
Load command stack file for OBS load on Manual Stac k

 

 Next Step:
  6

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR1EEPG_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR1EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

STR1EEPG_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 5.1    Check memory load command stack loaded 

 

   

For STR OBS v.x.y:

Start Address = 0400.0000 hex
End Address   = 0403.0A13 hex (TBC)
Length        = 30A14 hex (TBC) 32-bit words

 

Note:
This procedure assumes that the OBS image covers bo th 
EAPPL and Star Catalogue EEPROM areas.

 

 

 5.1.1  Check number of memory load commands in the  stack

 

   

Note:
A maximum of 14 ( TBC)  32-bit words can be loaded with 
a single STR memory load command.

 

Check that loaded stack contains:
   TBC TCs ACXL1001

 

 

 5.1.2  Check start address and length of the first  load 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXL1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 14 dec

 

Execute Telecommand
                                 Load STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Checksum            AHFXK001
                STRSw Nr Words            AHFXN001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001

      ACXL1001

STRSwHandling  
(Def)
Loading  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
04000000 <hex> 
calculated by OBSM  
14 <dec> 
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)

TC  

               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)

Page 9 of 25
Status      : Version 2 - Unchanged
Last Checkin: 13/04/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Load STR OBS in EEPROM

  File: H_FCP_OBS_2810.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Subsch. ID : 20      
Det. descr. : TC_LOAD_STR_SOFTWARE
This Telecommand will not be included in the export

 

 5.1.3  Check start address and length of the last load 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXL1001 command:

STRSw STR Mem  = 040x.xxxx hex
STRSw Nr Words = TBC hex

 

Execute Telecommand
                                 Load STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Checksum            AHFXK001
                STRSw Nr Words            AHFXN001
               STRSw Data Word            AHFXD001

TC Control Flags :

      ACXL1001

STRSwHandling  
(Def)
Loading  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
 <hex> (Def)
calculated by OBSM  
1 <dec> (Def)
 <dec> (Def)

TC  

                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC_LOAD_STR_SOFTWARE
This Telecommand will not be included in the export

 

 6      Upload STR1 OBS image in EEPROM

 

 Next Step:
  7

Uplink the ACXL1001 memory load commands with ARM-GO  

For each TC ACXL1001 successfuly executed on-board,  a 
TM(1,1) and TM(1,7) packet shall be received on 
ground.

 

Verify Packet Reception

Telecommand Acceptance Report - Success
Packet Mnemonic :        A_TcAccSucc
APID :                   512
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

Telecommand Execution Report - Completed
Packet Mnemonic :        A_TcExeComp
APID :                   512
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 7      Manual Stack manipulation
Load command stack file for STR1 new OBS dump from 
EEPROM on Manual Stack

 

 Next Step:
  8

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR1EEPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR1EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

STR1EEPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 7.1    Check memory dump command stack loaded 

 

   

For STR OBS v.x.y:

Start Address = 0400.0000 hex
End Address   = 0403.0A13 hex (TBC)
Length        = 30A14 hex (TBC) 32-bit words

 

Note:
This procedure assumes that the OBS image covers bo th 
EAPPL and Star Catalogue EEPROM areas.

 

 

 7.1.1  Check number of memory dump commands in the  stack

 

   

Note:
A maximum of 1536 32-bit words can be dumped with a 
single STR memory dump command.

 

Check that loaded stack contains:
  130 (TBC) TCs ACXD1001
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 7.1.2  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXD1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 1536 dec

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
04000000 <hex> 
1536 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 7.1.3  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXD1001 command:

STRSw STR Mem  = 040x.xxxx hex
STRSw Nr Words = TBC dec

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
 <hex> (Def)
 <dec> (Def)

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 8      Dump STR1 new OBS image from EEPROM

 

 Next Step:
  9
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
The dump of the current OBS image should be execute d 
in a DTCP preceding the DTCP selected for the new O BS 
image load.

 

 

 8.1    MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 8.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 8.1.2  Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR1EEPG.

The 'Image MONITOR' window opens.

 

 

 8.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 8.2    Upload commands to dump the STR1 new OBS im age from 
EEPROM

 

   

Uplink the ACXD1001 memory dump commands with ARM-GO  

After successful execution of each command, 2 TM(6, 6) 
packets shall be received on ground.

 

 

 8.3    Verify reception of TM(6,6)

 

   

Note:
2 TM(6,6) packets will be received for each memory 
dump command uplinked.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 8.4    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 8.5    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 8.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

 9      RETURN
to proc. H_FCP_AOC_4S61 or H_FCP_AOC_4S62

 

 Next Step:
  END

 

End of Sequence 

OFCP281B
TC Seq. Name :OFCP281B ( LOAD STR2 OBS EEPROM )
Load STR2 OBS in EEPROM and check image

TimeTag Type:  B
Sub Schedule ID: 

 �

 10     Verify initial conditions

 

 Next Step:
  11

Check:
- CDMU in Operational Mode
- ACC in Operational Mode
- STR2 in SWM

 

CDMU SOE to confirm CDMU mode  

AOCS SOE to confirm ACC and STR mode  
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
STR transition to SW Maintenance Mode and all 
associated TM checks are executed in calling proced ure 
H_SVT_AOC_4S61 or H_SVT_AOC_4S62.

 

Note:
STR Main telemetry is part of the essential and mode 
telemetry packets. If not configured as MAIN, a 
diagnostic telemetry packet has to be enabled in or der 
to verify the status of the physical unit.
This is executed in calling procedure H_SVT_AOC_4S5 1 
or H_SVT_AOC_4S52.

 

Verify Telemetry
                     STRM Mode            AEX04001  = SW Maintenance AND=AA01X109

OR  

Verify Telemetry
                     STR2 Mode            AMX12075 <> Initialisation AND=AA01X109

 

 11     Manual Stack manipulation
Load command stack file for STR2 current OBS dump f rom 
EEPROM on Manual Stack

 

 Next Step:
  12

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR2EEPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR2EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

STR2EEPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 11.1   Check memory dump command stack loaded 
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  Load STR OBS in EEPROM

  File: H_FCP_OBS_2810.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

For STR OBS v.x.y:

Start Address = 0400.0000 hex
End Address   = 0403.0A13 hex (TBC)
Length        = 30A14 hex (TBC) 32-bit words

 

Note:
This procedure assumes that the OBS image covers bo th 
EAPPL and Star Catalogue EEPROM areas.

 

 

 11.1.1  Check number of memory dump commands in the  stack

 

   

Note:
A maximum of 1536 32-bit words can be dumped with a 
single STR memory dump command.

 

Check that loaded stack contains:
   130 (TBC) TCs ACXD1001

 

 

 11.1.2  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXD1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 1536 dec

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
04000000 <hex> 
1536 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 11.1.3  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXD1001 command:

STRSw STR Mem  = 040x.xxxx hex
STRSw Nr Words = TBC dec
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  File: H_FCP_OBS_2810.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
 <hex> (Def)
 <dec> (Def)

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 12     Dump STR2 current OBS image from EEPROM

 

 Next Step:
  13

Note:
The dump of the current OBS image should be execute d 
in a DTCP preceding the DTCP selected for the new O BS 
image load.

 

 

 12.1   MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 12.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 12.1.2  Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR2EEPG.

The 'Image MONITOR' window opens.

 

 

 12.1.3  Start dump TM processing
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In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 12.2   Upload commands to dump the STR2 current OB S image 
from EEPROM

 

   

Uplink the ACXD1001 memory dump commands with ARM-GO  

After successful execution of each command, 2 TM(6, 6) 
packets shall be received on ground.

 

 

 12.3   Verify reception of TM(6,6)

 

   

Note:
2 TM(6,6) packets will be received for each memory 
dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 12.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 12.5   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 12.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  
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  File: H_FCP_OBS_2810.xls
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 13     Manual Stack manipulation
Load command stack file for OBS load on Manual Stac k

 

 Next Step:
  14

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

STR2EEPG_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR2EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

STR2EEPG_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 13.1   Check memory load command stack loaded 

 

   

For STR OBS v.x.y:

Start Address = 0400.0000 hex
End Address   = 0403.0A13 hex (TBC)
Length        = 30A14 hex (TBC) 32-bit words

 

Note:
This procedure assumes that the OBS image covers bo th 
EAPPL and Star Catalogue EEPROM areas.

 

 

 13.1.1  Check number of memory load commands in the  stack

 

   

Note:
A maximum of 14 ( TBC)  32-bit words can be loaded with 
a single STR memory load command.

 

Check that loaded stack contains:
   TBC TCs ACXL1001
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Step 
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 13.1.2  Check start address and length of the first  load 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXL1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 14 dec

 

Execute Telecommand
                                 Load STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Checksum            AHFXK001
                STRSw Nr Words            AHFXN001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001

      ACXL1001

STRSwHandling  
(Def)
Loading  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
04000000 <dec> 
calculated by OBSM  
14 <dec> 
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)

TC  

               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001
               STRSw Data Word            AHFXD001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)
 <dec> (Def)

Subsch. ID : 20      
Det. descr. : TC_LOAD_STR_SOFTWARE
This Telecommand will not be included in the export

 

 13.1.3  Check start address and length of the last load 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXL1001 command:

STRSw STR Mem  = 040x.xxxx hex
STRSw Nr Words = TBC hex
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Execute Telecommand
                                 Load STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Checksum            AHFXK001
                STRSw Nr Words            AHFXN001
               STRSw Data Word            AHFXD001

TC Control Flags :

      ACXL1001

STRSwHandling  
(Def)
Loading  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-1  
 <hex> (Def)
calculated by OBSM  
1 <dec> (Def)
 <dec> (Def)

TC  

                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC_LOAD_STR_SOFTWARE
This Telecommand will not be included in the export

 

 14     Upload STR2 OBS image in EEPROM

 

 Next Step:
  15

Uplink the ACXL1001 memory load commands with ARM-GO  

For each TC ACXL1001 successfuly executed on-board,  a 
TM(1,1) and TM(1,7) packet shall be received on 
ground.

 

Verify Packet Reception

Telecommand Acceptance Report - Success
Packet Mnemonic :        A_TcAccSucc
APID :                   512
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

Telecommand Execution Report - Completed
Packet Mnemonic :        A_TcExeComp
APID :                   512
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 15     Manual Stack manipulation
Load command stack file for STR2 new OBS dump from 
EEPROM on Manual Stack

 

 Next Step:
  16

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window
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Select file

STR2EEPG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/STR2EEPG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

STR2EEPG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 15.1   Check memory dump command stack loaded 

 

   

For STR OBS v.x.y:

Start Address = 0400.0000 hex
End Address   = 0403.0A13 hex (TBC)
Length        = 30A14 hex (TBC) 32-bit words

 

Note:
This procedure assumes that the OBS image covers bo th 
EAPPL and Star Catalogue EEPROM areas.

 

 

 15.1.1  Check number of memory dump commands in the  stack

 

   

Note:
A maximum of 1536 32-bit words can be dumped with a 
single STR memory dump command.

 

Check that loaded stack contains:
   130 (TBC) TCs ACXD1001

 

 

 15.1.2  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the first ACXD1001 command:

STRSw STR Mem  = 0400.0000 hex
STRSw Nr Words = 1536 dec

 

Page 22 of 25
Status      : Version 2 - Unchanged
Last Checkin: 13/04/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Load STR OBS in EEPROM

  File: H_FCP_OBS_2810.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
04000000 <hex> 
1536 <dec> 

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 15.1.3  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address ( STRSw STR Mem parameter) and Length ( STRSw Nr 
Words parameter) in the last ACXD1001 command:

STRSw STR Mem  = 040x.xxxx hex
STRSw Nr Words = TBC dec

 

Execute Telecommand
                                 Dump STR software

Command Parameter(s) :
               ASW Function ID            AHFUN001
                 STRSw AID Cmd            AHFXB001
                STRSw DF86 Cmd            AH8U1001
                STRSw DD86 Cmd            AH8U2001
                  STRSw STR ID            AHFXU001
                 STRSw STR Mem            AHFXM001
                STRSw Nr Words            AHFXN001

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---

      ACXD1001

STRSwHandling  
(Def)
Dumping  (Def)
Disable 86  (Def)
Disable 86  (Def)
STR-2  
 <hex> (Def)
 <dec> (Def)

TC  

Subsch. ID : 20      
Det. descr. : TC_DUMP_STR_SOFTWARE
This Telecommand will not be included in the export

 

 16     Dump STR2 new OBS image from EEPROM

 

 Next Step:
  17

Note:
The dump of the current OBS image should be execute d 
in a DTCP preceding the DTCP selected for the new O BS 
image load.

 

 

 16.1   MCS OBSM preparation for Image update in LI VE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.
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 16.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 16.1.2  Select image to be monitored

 

   

Select the image to be monitored for the memory dev ice 
STR2EEPG.

The 'Image MONITOR' window opens.

 

 

 16.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 16.2   Upload commands to dump the STR2 new OBS im age from 
EEPROM

 

   

Uplink the ACXD1001 memory dump commands with ARM-GO  

After successful execution of each command, 2 TM(6, 6) 
packets shall be received on ground.

 

 

 16.3   Verify reception of TM(6,6)

 

   

Note:
2 TM(6,6) packets will be received for each memory 
dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 16.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.
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 16.5   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 16.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

 17     RETURN
to proc. H_FCP_AOC_4S61 or H_FCP_AOC_4S62

 

 Next Step:
  END

 

End of Sequence 

End of Procedure
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