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  Update ACC SGM ground image from memory dump

  File: H_FCP_OBS_2449.xls
  Author: lstefanov-hpLiviu Stefanov

This Herschel OBSM nominal procedure is used to per form the dump 
of the ACC SGM memory areas and the update of the c orresponding 
ground image. The memory dump is commanded using TC (6,5) and the 
memory locations content is received on ground in T M(6,6) 
packets.
The procedures covers both ACC SGM A and SGM B.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

ACC in Operational Mode

Memory areas are dumped through TC(6,5); this TC wi ll be delayed 
when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

ACC in Operational Mode

End of Procedure

Same as start except:
- ACC SGM A or/and SGM B memory dump executed

Input Command Sequences

Output Command Sequences

OFCP244A        
OFCP244C        

ANDs GRDs SLDs

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 18/02/08   1 1 Created  lstefanov-hp    

 30/12/08   2 2

1. updated TC Seq. names and descriptions�
2. current steps 4 and 14 updated: separate sub-steps created for BSW WP, ASW WP, 
BSW NP and ASW NP dump command stacks manipulation  lstefanov-hp    

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

 13/04/09   2.3 3
1. corrected typo in steps 4.1, 4.3, 4.5, 4.7, 14.1, 14.3, 14.5 and 14.7: 'pmcsops' replaced 
by 'hmcsops'  lstefanov-hp    
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Procedure Flowchart Overview

e

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP2449
TC Seq. Name :OFCP2449 ( ACC SGM GI update )
ACC SGM A or B Gnd image update

TimeTag Type:  
Sub Schedule ID: 

 �

 1      SWITCH
Mem.device

type: [Switch]

 Next Step:
 SGM A 2
 SGM B 12

 

End of Sequence 

OFCP244A
TC Seq. Name :OFCP244A ( ACC SGM A Dmp A )
ACC SGM A Gnd image update in Live mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 2      IF
Image monitor in LIVE mode

type: [If]

 Next Step:
 THEN 3
 ELSE 9

 

 3      Verify initial conditions

 

 Next Step:
  4

Check:
- ACC in Operational Mode

 

ACMS SOE to confirm ACC mode  

 

 4      Manual Stack manipulation

 

 Next Step:
  5

IMPORTANT:
- On each SGM A and B, the memory area is split in two 
parts where the first part is write protected and 
second part is unprotected.
- Each protected and unprotected area is divided into 
one part allocated to the ASW and one part allocated 
to the BSW

 

The allocation of the 4 SGM memory areas
- BSW Write Protected
- ASW Write Protected
- BSW Not Protected
- ASW Not Protected
is defined through HPSDB parameters:

SGM_ASW_BEG_P_ADDR Start address of the protected part 
of the ASW SGM, byte offset within SGM

SGM_BSW_BEG_ADDR Start address of the non protected 
BSW part of the SGM, byte offset within SGM

SGM_ASW_BEG_ADDR_VALUE Start address of the non 
protected part of the ASW SGM, byte offset within S GM

 

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

For ACMS ASW v.4.0 and BSW v.2.0:

SGM_ASW_BEG_P_ADDR     = 80 hex
SGM_BSW_BEG_ADDR       = 40000 hex
SGM_ASW_BEG_ADDR_VALUE = 86100 hex

 

For ACMS ASW v.4.0 and BSW v.2.0,the definitions of 
the 4 SGM memory areas are:

SGM BSW WP
Start Address = 0.0000 hex
Length        = 80 hex

SGM ASW WP
Start Address = 0.0080 hex
Length        = 3FF80 hex

 

SGM BSW NP
Start Address = 4.0000 hex
Length        = 46100 hex

SGM ASW NP
Start Address = 8.6100 hex
Length        = 39F00 hex

 

IMPORTANT:
All accesses to SGM memory must be 32-bit transfers, 
aligned to 32-bit
boundaries.

 

 

 4.1    Load command stack file for SGM A BSW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

ASGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

ASGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMAMEM_DI_0002001_C_ASGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.2    Check memory dump command stack loaded 

 

   

For a full ACC SGM BSW WP area dump:

Start Address = 0.0000 hex
End Address   = 0.007F hex
Length        = 80 hex

 

Check that loaded stack contains:
   1 TC AC063109

 

Display the Manual Stack in 'Full mode' and check t he 
Memory ID, Start Address and Length parameters in the 
AC063109 command:

Memory ID     = 00B hex
Start Address = 0.0000 hex
Length        = 80 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00B0 <hex> 
0000 <hex> (Def)
80 <hex> 

TC  

 

 4.3    Load command stack file for SGM A ASW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

ASGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

ASGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMAMEM_DI_0002001_C_ASGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.4    Check memory dump command stack loaded 

 

   

For a full ACC SGM ASW WP area dump:

Start Address = 0.0080 hex
End Address   = 3.FFFF hex
Length        = 3FF80 hex

 

 

 4.4.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs AC063109

 

 

 4.4.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 00B hex:

Memory ID = 00B hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00Bx <hex>  
0 <hex> (Def)
0 <hex> (Def)

TC  

 

 4.4.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first AC063109 command:

Start Address = 0.0080 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00B0 <hex> 
0080 <hex> 
FFFC <hex> 

TC  

 

 4.4.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last AC063109 command:

Start Address = 3.0074 hex
Length        = FF8C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00B3 <hex> 
0074 <hex> 
FF8C <hex> 

TC  

 

 4.5    Load command stack file for SGM A BSW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

ASGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

ASGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMAMEM_DI_0002001_C_ASGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.6    Check memory dump command stack loaded 

 

   

For a full ACC SGM BSW NP area dump:

Start Address = 4.0000 hex
End Address   = 8.60FF hex
Length        = 46100 hex

 

Page 9 of 29
Status      : Version 3 - Unchanged
Last Checkin: 13/04/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Update ACC SGM ground image from memory dump

  File: H_FCP_OBS_2449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 4.6.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   5 TCs AC063109

 

 

 4.6.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 00B hex:

Memory ID = 00B hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00Bx <hex>  
0 <hex> (Def)
0 <hex> (Def)

TC  

 

 4.6.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first AC063109 command:

Start Address = 4.0000 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00B4 <hex> 
0000 <hex> (Def)
FFFC <hex> 

TC  

 

 4.6.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last AC063109 command:

Start Address = 7.FFF0 hex
Length        = 6110 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00B7 <hex> 
FFF0 <hex> 
6110 <hex> 

TC  

 

 4.7    Load command stack file for SGM A ASW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

ASGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

ASGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMAMEM_DI_0002001_C_ASGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.8    Check memory dump command stack loaded 

 

   

For a full ACC SGM ASW NP area dump:

Start Address = 8.6100 hex
End Address   = B.FFFF hex
Length        = 39F00 hex

 

 

 4.8.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs AC063109

 

 

 4.8.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 00B hex:

Memory ID = 00B hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00Bx <hex>  
0 <hex> (Def)
0 <hex> (Def)

TC  

 

 4.8.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first AC063109 command:

Start Address = 8.6100 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00B8 <hex> 
6100 <hex> 
FFFC <hex> 

TC  

 

 4.8.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last AC063109 command:

Start Address = B.60F4 hex
Length        = 9F0C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00BB <hex> 
60F4 <hex> 
9F0C <hex> 

TC  

 

 5      MCS OBSM preparation for Image Update in LI VE mode

 

 Next Step:
  6

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1    Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 5.2    Select image to be updated

 

   

Select the image to be updated for the memory devic e 
ASGMAMEM.

The 'Image UPDATE' window opens.

 

 

 5.3    Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 6      Command memory dump

 

 Next Step:
  7

Uplink the AC063109 memory dump commands with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 7      Verify reception of TM(6,6)

 

 Next Step:
  8

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 7.1    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 8      Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP244B
TC Seq. Name :OFCP244B ( ACC SGM A Dmp B )
ACC SGM A Gnd image update in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 9      MCS OBSM preparation for Image update in RE TRIEVAL 
mode

 

 Next Step:
  10

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 9.1    Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.
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  File: H_FCP_OBS_2449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 9.2    Select image to be updated

 

   

Select the image to be updated for the memory devic e 
ASGMAMEM.

The 'Image UPDATE' window opens.

 

 

 9.3    Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 10     Retrieve and process TM(6,6) packets

 

 Next Step:
  11

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 10.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the retrieved mem ory 
dump packets.

 

 

 11     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP244C
TC Seq. Name :OFCP244C ( ACC SGM B Dmp C )
ACC SGM B Gnd image update in Live mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 12     IF
Image monitor in LIVE mode

type: [If]

 Next Step:
 ELSE 19
 THEN 13
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  Update ACC SGM ground image from memory dump

  File: H_FCP_OBS_2449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 13     Verify initial conditions

 

 Next Step:
  14

Check:
- ACC in Operational Mode

 

ACMS SOE to confirm ACC mode  

 

 14     Manual Stack manipulation

 

 Next Step:
  15

IMPORTANT:
- On each SGM A and B, the memory area is split in two 
parts where the first part is write protected and 
second part is unprotected.
- Each protected and unprotected area is divided into 
one part allocated to the ASW and one part allocated 
to the BSW

 

The allocation of the 4 SGM memory areas
- BSW Write Protected
- ASW Write Protected
- BSW Not Protected
- ASW Not Protected
is defined through HPSDB parameters:

SGM_ASW_BEG_P_ADDR Start address of the protected part 
of the ASW SGM, byte offset within SGM

SGM_BSW_BEG_ADDR Start address of the non protected 
BSW part of the SGM, byte offset within SGM

SGM_ASW_BEG_ADDR_VALUE Start address of the non 
protected part of the ASW SGM, byte offset within S GM

 

For ACMS ASW v.4.0 and BSW v.2.0:

SGM_ASW_BEG_P_ADDR     = 80 hex
SGM_BSW_BEG_ADDR       = 40000 hex
SGM_ASW_BEG_ADDR_VALUE = 86100 hex

 

For ACMS ASW v.4.0 and BSW v.2.0,the definitions of 
the 4 SGM memory areas are:

SGM BSW WP
Start Address = 0.0000 hex
Length        = 80 hex

SGM ASW WP
Start Address = 0.0080 hex
Length        = 3FF80 hex

 

SGM BSW NP
Start Address = 4.0000 hex
Length        = 46100 hex

SGM ASW NP
Start Address = 8.6100 hex
Length        = 39F00 hex

 

IMPORTANT:
All accesses to SGM memory must be 32-bit transfers, 
aligned to 32-bit
boundaries.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 14.1   Load command stack file for SGM B BSW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

ASGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

ASGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMBMEM_DI_0002001_C_ASGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.2   Check memory dump command stack loaded 

 

   

For a full ACC SGM BSW WP area dump:

Start Address = 0.0000 hex
End Address   = 0.007F hex
Length        = 80 hex

 

Check that loaded stack contains:
   1 TC AC063109
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Display the Manual Stack in 'Full mode' and check t he 
Memory ID, Start Address and Length parameters in the 
AC063109 command:

Memory ID     = 00E hex
Start Address = 0.0000 hex
Length        = 80 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00E0 <hex> 
0000 <hex> (Def)
80 <hex> 

TC  

 

 14.3   Load command stack file for SGM B ASW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

ASGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

ASGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMBMEM_DI_0002001_C_ASGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.4   Check memory dump command stack loaded 

 

   

For a full ACC SGM ASW WP area dump:

Start Address = 0.0080 hex
End Address   = 3.FFFF hex
Length        = 3FF80 hex

 

 

 14.4.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs AC063109

 

 

 14.4.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 00E hex:

Memory ID = 00E hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00Ex <hex>  
0 <hex> (Def)
0 <hex> (Def)

TC  

 

 14.4.3  Check start address and length of the first  dump 
command in the stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first AC063109 command:

Start Address = 0.0080 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00E0 <hex> 
0080 <hex> 
FFFC <hex> 

TC  

 

 14.4.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last AC063109 command:

Start Address = 3.0074 hex
Length        = FF8C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00E3 <hex> 
0074 <hex> 
FF8C <hex> 

TC  

 

 14.5   Load command stack file for SGM B BSW Not P rotected 
part on top of Manual Stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

ASGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

ASGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMBMEM_DI_0002001_C_ASGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.6   Check memory dump command stack loaded 

 

   

For a full ACC SGM BSW NP area dump:

Start Address = 4.0000 hex
End Address   = 8.60FF hex
Length        = 46100 hex

 

 

 14.6.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   5 TCs AC063109

 

 

 14.6.2  Check Memory ID
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 00E hex:

Memory ID = 00E hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00Ex <hex>  
0 <hex> (Def)
0 <hex> (Def)

TC  

 

 14.6.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first AC063109 command:

Start Address = 4.0000 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00E4 <hex> 
0000 <hex> (Def)
FFFC <hex> 

TC  

 

 14.6.4  Check start address and length of the last dump 
command in the stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last AC063109 command:

Start Address = 7.FFF0 hex
Length        = 6110 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00E7 <hex> 
FFF0 <hex> 
6110 <hex> 

TC  

 

 14.7   Load command stack file for SGM B ASW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

ASGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ASGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

ASGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT ASGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

ASGMBMEM_DI_0002001_C_ASGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.8   Check memory dump command stack loaded 

 

   

For a full ACC SGM ASW NP area dump:

Start Address = 8.6100 hex
End Address   = B.FFFF hex
Length        = 39F00 hex

 

 

 14.8.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs AC063109

 

 

 14.8.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 00E hex:

Memory ID = 00E hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00Ex <hex>  
0 <hex> (Def)
0 <hex> (Def)

TC  

 

 14.8.3  Check start address and length of the first  dump 
command in the stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first AC063109 command:

Start Address = 8.6100 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00E8 <hex> 
6100 <hex> 
FFFC <hex> 

TC  

 

 14.8.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last AC063109 command:

Start Address = B.60F4 hex
Length        = 9F0C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

00EB <hex> 
60F4 <hex> 
9F0C <hex> 

TC  

 

 15     MCS OBSM preparation for Image Update in LI VE mode

 

 Next Step:
  16
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 15.1   Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 15.2   Select image to be updated

 

   

Select the image to be updated for the memory devic e 
ASGMBMEM.

The 'Image UPDATE' window opens.

 

 

 15.3   Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 16     Command memory dump

 

 Next Step:
  17

Uplink the AC063109 memory dump commands with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.

 

 

 17     Verify reception of TM(6,6)

 

 Next Step:
  18

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 17.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 18     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP244D
TC Seq. Name :OFCP244D ( ACC SGM A Dmp D )
ACC SGM B Gnd image update in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 19     MCS OBSM preparation for Image update in RE TRIEVAL 
mode

 

 Next Step:
  20

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 19.1   Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 19.2   Select image to be updated

 

   

Select the image to be updated for the memory devic e 
ASGMBMEM.

The 'Image UPDATE' window opens.

 

 

 19.3   Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 20     Retrieve and process TM(6,6) packets

 

 Next Step:
  21

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 20.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the retrieved mem ory 
dump packets.

 

 

 21     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

End of Procedure
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