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  Monitor dump of ACC PM EEPROM memory area

  File: H_FCP_OBS_2242.xls

  Author: lstefanov-hp

This Herschel OBSM nominal procedure is used to per form an ACC PM 
EEPROM dump monitoring against the ground image. Th e procedure 
covers both ACC PM EEPROM1 and EEPROM2. The memory dump is 
commanded using TC(6,5) and the memory locations co ntent is 
received on ground in TM(6,6) packets.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

CDMU in Operational Mode
- ACC in Operational Mode

Execution of service 6 TCs will be delayed when the re is an 
ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode
- ACC in Operational Mode

End of Procedure

Same as start except:
- ACC PM EEPROM1 and/or EEPROM2 memory dump execute d

Input Command Sequences

Output Command Sequences

OFCP224C        
OFCP224E        

ANDs GRDs SLDs

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 04/08/08   1 1 Created  dsalt-hp    

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

 11/03/09     2

1. current step 4.1 updated: sub-steps 4.1.1 and 4.1.2 created to separate command 
stack load for ACC PM A and B�
2. current step 5.1.2 updated: sub-steps 5.1.2.1 and 5.1.2.2 created to separate OBSM 
image selection for ACC PM A and B�
3. current step 8.2 updated: sub-steps 8.2.1 and 8.2.2 created to separate OBSM image 
selection for ACC PM A and B�
4. current step 12.1 updated: sub-steps 12.1.1 and 12.1.2 created to separate command 
stack load for ACC PM A and B�
5. current step 13.1.2 updated: sub-steps 13.1.2.1 and 13.1.2.2 created to separate 
OBSM image selection for ACC PM A and B�
6. current step 17.2 updated: sub-steps 17.2.1 and 17.2.2 created to separate OBSM 
image selection for ACC PM A and B  lstefanov-hp    

 11/03/09   2.2 3 1. updated TC Seq. names  lstefanov-hp    

 30/03/09     4
1. Procedure Title updated�
2. TC Seq. descriptions updated  lstefanov-hp    

 21/04/09   2.3 5 1. corrected error in TC Sequence name: OFCP124F replaced by OFCP224F  lstefanov-hp    
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Procedure Flowchart Overview

e

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP2242
TC Seq. Name :OFCP2242 ( ACC EEPROM dump )
ACC PM EEPROM dump monitor

TimeTag Type:  
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check:
- CDMU in Operational Mode
- ACC in Operational Mode

 

CDMS SOE to confirm CDMU mode  

ACMS SOE to confirm ACC mode  

 

 2      SWITCH
Mem.device

type: [Switch]

 Next Step:
 EEPROM1 3
 EEPROM2 11

 

 3      IF
Monitor in LIVE
mode

type: [If]

 Next Step:
 THEN 4
 ELSE 8

 

End of Sequence 

OFCP224C
TC Seq. Name :OFCP224C ( ACC EEPROM1 dump L )
ACC PM EEPROM1 dump monitor in LIVE mode

TimeTag Type:  
Sub Schedule ID: 

 �

 4      Manual Stack manipulation
Load command stack files for memory dump on Manual 
Stack

 

 Next Step:
  5

 

 4.1    Load memory dump command stack

 

   

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 4.1.1  IF
ACC PM A

 

   

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

ACCEE1PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ACCEE1PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

ACCEE1PG_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT ACCEE1PG1, ID 0003, Version 001 associated to the 
memory image:

ACCEE1PG_DI_0002001_C_ACCEE1PG1_0003001_2008_148T09 332
0.sun045

 

 

 4.1.2  ELSE
ACC PM B

 

   

Select file

ACCEE1PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ACCEE1PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

ACCEE1PB_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT ACCEE1PB1, ID 0003, Version 001 associated to the 
memory image:

ACCEE1PB_DI_0002001_C_ACCEE1PB1_0003001_2008_148T09 332
0.sun045

 

 

 4.2    Check memory dump command stack loaded 

 

   

Check that loaded stack contains one or several TCs  
AC063109.

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 008 hex:

Memory ID = 008 hex

Note:
The Memory ID of the target memory device is stored  in 
the most significant 12 bits of the 16-bit long Mem  ID 
TC parameter.
The least significant 4 bits of the same parameter 
carry the most significant 4 bits of the Start 
Address.

 

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

008x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

Note:
For a full dump of ACC EEPROM1, the stack will cont ain 
17 TCs AC063109, covering the address range 0080.0000 
hex to 008F.FFFF hex

 

Note:
The start and end address of the EEPROM 'Image 1' a re 
(Memory ID included):

Start Address = 0080.0000 hex
End Address   = 008F.FFFF hex
Length        = 100000 hex
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 5      Dump the EEPROM1 memory area

 

 Next Step:
  6

 

 5.1    MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 5.1.2  Select image to be monitored

 

   

 

 
5.1.2.1

 IF
ACC PM A

 

   

Select the image to be monitored for the memory dev ice 
ACCEE1PG.

The 'Image MONITOR' window opens.

 

 

 
5.1.2.2

 ELSE
ACC PM B

 

   

Select the image to be monitored for the memory dev ice 
ACCEE1PB.

The 'Image MONITOR' window opens.

 

 

 5.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 5.2    Command memory dump

 

   

Uplink TCs AC063109 with ARM-GO  

For each command, one or several TM(6,6) packets wi ll 
be received on ground.

 

 

 6      Verify reception and contents of TM(6,6)

 

 Next Step:
  7

Note:
One or several TM(6,6) packets will be received for  
each memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 6.1    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 6.2    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 7      Save merged image

 

 Next Step:
  END

WAIT for execution completion of the last dump 
command.

 

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

OFCP224D
TC Seq. Name :OFCP224D ( ACC EEPROM1 dump R )
ACC PM EEPROM1 dump monitor in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 8      MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  9

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 8.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 8.2    Select image to be monitored

 

   

 

 8.2.1  IF
ACC PM A

 

   

Select the image to be monitored for the memory dev ice 
ACCEE1PG.

The 'Image MONITOR' window opens.

 

 

 
8.2.1.1

 ELSE
ACC PM B

 

   

Select the image to be monitored for the memory dev ice 
ACCEE1PB.

The 'Image MONITOR' window opens.

 

 

 8.3    Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 9      Retrieve and process TM(6,6) packets

 

 Next Step:
  10

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 9.1    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 10     Save merged image

 

 Next Step:
  END

WAIT for retrieval completion of the last dump pack et.  

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP224E
TC Seq. Name :OFCP224E ( ACC EEPROM2 dump L )
ACC PM EEPROM2 dump monitor in LIVE mode

TimeTag Type:  
Sub Schedule ID: 

 �

 11     IF
Monitor in LIVE
mode

type: [If]

 Next Step:
 THEN 12
 ELSE 16

 

 12     Manual Stack manipulation
Load command stack files for memory dump on Manual 
Stack

 

 Next Step:
  13
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 12.1   Load memory dump command stack

 

   

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 12.1.1  IF
ACC PM A

 

   

Select file

ACCEE2PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ACCEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

ACCEE2PG_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT ACCEE2PG1, ID 0003, Version 001 associated to the 
memory image:

ACCEE2PG_DI_0002001_C_ACCEE2PG1_0003001_2008_148T09 332
0.sun045

 

 

 12.1.2  ELSE
ACC PM B
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

ACCEE2PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/ACCEE2PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

ACCEE2PB_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT ACCEE2PB1, ID 0003, Version 001 associated to the 
memory image:

ACCEE2PB_DI_0002001_C_ACCEE2PB1_0003001_2008_148T09 332
0.sun045

 

 

 12.2   Check memory dump command stack loaded 

 

   

Check that loaded stack contains one or several TCs  
AC063109.

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the AC063109 command(s) is 
set to 009 hex:

Memory ID = 009 hex

Note:
The Memory ID of the target memory device is stored  in 
the most significant 12 bits of the 16-bit long Mem  ID 
TM parameter.
The least significant 4 bits of the same parameter 
carry the most significant 4 bits of the Start 
Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                       Dump Memory

Command Parameter(s) :
                     Memory ID            AH6M0109
                 Start Address            AH6M1109
                    Length SAU            AH6M3109

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 20      
Det. descr. : TC(6,5) Dump Memory Using Absolute 
Addresses
This Telecommand will not be included in the export

      AC063109

009x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

Note:
For a full dump of ACC EEPROM2, the stack will cont ain 
17 TCs AC063109, covering the address range 0090.0000 
hex to 009F.FFFF hex

 

Note:
The start and end address of the EEPROM 'Image 2' a re 
(Memory ID included):

Start Address = 0090.0000 hex
End Address   = 009F.FFFF hex
Length        = 100000 hex

 

 

 13     Dump the EEPROM2 memory area

 

 Next Step:
  14

 

 13.1   MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 13.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 13.1.2  Select image to be monitored

 

   

 

 
13.1.2.
1

 IF
ACC PM A
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the image to be monitored for the memory dev ice 
ACCEE2PG.

The 'Image MONITOR' window opens.

 

 

 
13.1.2.
2

 ELSE
ACC PM B

 

   

Select the image to be monitored for the memory dev ice 
ACCEE2PB.

The 'Image MONITOR' window opens.

 

 

 13.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 13.2   Command memory dump

 

   

Uplink TCs AC063109 with ARM-GO  

For each command, one or several TM(6,6) packets wi ll 
be received on ground.

 

 

 14     Verify reception and contents of TM(6,6)

 

 Next Step:
  15

Note:
One or several TM(6,6) packets will be received for  
each memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   512
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 14.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 14.2   Check contents of memory dump packets
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 15     Save merged image

 

 Next Step:
  END

WAIT for execution completion of the last dump 
command.

 

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP224F
TC Seq. Name :OFCP224F ( ACC EEPROM2 dump R )
ACC PM EEPROM2 dump monitor in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 16     MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  17

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 16.1   Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 16.2   Select image to be monitored

 

   

 

 16.2.1  IF
ACC PM A
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the image to be monitored for the memory dev ice 
ACCEE2PG.

The 'Image MONITOR' window opens.

 

 

 
16.2.1.
1

 ELSE
ACC PM B

 

   

Select the image to be monitored for the memory dev ice 
ACCEE2PB.

The 'Image MONITOR' window opens.

 

 

 16.3   Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 17     Retrieve and process TM(6,6) packets

 

 Next Step:
  18

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 17.1   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 18     Save merged image

 

 Next Step:
  END

WAIT for retrieval completion of the last dump pack et.  

IF there are mismatches reported by OBSM, save merged 
image with new ID.
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Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
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  Monitor dump of ACC PM EEPROM memory area

  File: H_FCP_OBS_2242.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

End of Procedure
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