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  Update CDMU SGM ground image from memory dump

  File: H_FCP_OBS_1449.xls
  Author: lstefanov-hpLiviu Stefanov

This Herschel OBSM nominal procedure is used to per form the dump 
of the CDMU SGM memory areas and the update of the corresponding 
ground image. The memory dump is commanded using TC (6,5) and the 
memory locations content is received on ground in T M(6,6) 
packets.
The procedures covers both CDMU SGM A and SGM B.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

CDMU in Operational Mode

Memory areas are dumped through TC(6,5); this TC wi ll be delayed 
when there is an ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode

End of Procedure

Same as start

Input Command Sequences

Output Command Sequences

OFCP144A        
OFCP144C        

ANDs GRDs SLDs

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 18/02/08   1 1 Created  lstefanov-hp    

 30/12/08     2

1. updated TC Seq. names and descriptions�
2. current steps 4 and 14 updated: separate sub-steps created for BSW WP, ASW WP, 
BSW NP and ASW NP dump command stacks manipulation  lstefanov-hp    

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Summary

e

 29/01/09   2 3
1. step 4 and sub-steps updated: addresses updated to include the SGMA Memory ID�
2. step 14 and sub-steps updated: addresses updated to include the SGMB Memory ID  lstefanov-hp    
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP1449
TC Seq. Name :OFCP1449 ( CDMU SGM GI update )
CDMU SGM A or B Gnd image update

TimeTag Type:  
Sub Schedule ID: 

 �

 1      SWITCH
Mem.device

type: [Switch]

 Next Step:
 SGM B 12
 SGM A 2

 

End of Sequence 

OFCP144A
TC Seq. Name :OFCP144A ( CDMU SGM A Dmp A )
CDMU SGM A Gnd image update in Live mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 2      IF
Image monitor in LIVE mode

type: [If]

 Next Step:
 THEN 3
 ELSE 9

 

 3      Verify initial conditions

 

 Next Step:
  4

Check:
- CDMU in Operational Mode

 

CDMS SOE to confirm CDMU mode  

 

 4      Manual Stack manipulation

 

 Next Step:
  5

IMPORTANT:
- On each SGM A and B, the memory area is split in two 
parts where the first part is write protected and 
second part is unprotected.
- Each protected and unprotected area is divided into 
one part allocated to the ASW and one part allocated 
to the BSW

 

The allocation of the 4 SGM memory areas
- BSW Write Protected
- ASW Write Protected
- BSW Not Protected
- ASW Not Protected
is defined through HPSDB parameters:

SGM_ASW_BEG_P_ADDR Start address of the protected part 
of the ASW SGM, byte offset within SGM

SGM_BSW_BEG_ADDR Start address of the non protected 
BSW part of the SGM, byte offset within SGM

SGM_ASW_BEG_ADDR_VALUE Start address of the non 
protected part of the ASW SGM, byte offset within S GM

 

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

For CDMU ASW v.3.8.0 and BSW v.2.2:

SGM_ASW_BEG_P_ADDR     = 80 hex
SGM_BSW_BEG_ADDR       = 40000 hex
SGM_ASW_BEG_ADDR_VALUE = 86100 hex

 

For CDMU ASW v.3.8.0 and BSW v.2.2,the definitions of 
the 4 SGM A memory areas are ( Memory ID = 00B hex 
included):

SGM BSW WP
Start Address = 00B0.0000 hex
Length        = 80 hex

SGM ASW WP
Start Address = 00B0.0080 hex
Length        = 3FF80 hex

 

SGM BSW NP
Start Address = 00B4.0000 hex
Length        = 46100 hex

SGM ASW NP
Start Address = 00B8.6100 hex
Length        = 39F00 hex

 

IMPORTANT:
All accesses to SGM memory must be 32-bit transfers, 
aligned to 32-bit
boundaries.

 

Note:
Following steps assume that separate OBSM 
Configuration Tables are used for the 4 SGM memory 
areas, thus obtaining 4 separate OBSM generated 
command stacks.
If the command stack is generated using the "Dump 
Regions" functionality, a single stack is produced by 
OBSM for the whole SGM.

 

 

 4.1    Load command stack file for SGM A BSW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

CSGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMAMEM_DI_0002001_C_CSGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.2    Check memory dump command stack loaded 

 

   

For a full CDMU SGM BSW WP area dump ( Memory ID = 00B 
hex included):

Start Address = 00B0.0000 hex
End Address   = 00B0.007F hex
Length        = 80 hex

 

Check that loaded stack contains:
   1 TC DC602180

 

Display the Manual Stack in 'Full mode' and check t he 
Memory ID, Start Address and Length parameters in the 
DC602180 command:

Memory ID     = 00B hex
Start Address = 0.0000 hex
Length        = 80 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00B0 <hex> 
0000 <hex> 
80 <hex> 

TC  

 

 4.3    Load command stack file for SGM A ASW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

CSGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

CSGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMAMEM_DI_0002001_C_CSGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.4    Check memory dump command stack loaded 

 

   

For a full CDMU SGM ASW WP area dump( Memory ID = 00B 
hex included):

Start Address = 00B0.0080 hex
End Address   = 00B3.FFFF hex
Length        = 3FF80 hex

 

 

 4.4.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs DC602180

 

 

 4.4.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 00B hex:

Memory ID = 00B hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00Bx <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 4.4.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first DC602180 command 
( Memory ID = 00B hex included):

Start Address = 00B0.0080 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00B0 <hex> 
0080 <hex> 
FFFC <hex> 

TC  

 

 4.4.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last DC602180 command 
( Memory ID = 00B hex included):

Start Address = 00B3.0074 hex
Length        = FF8C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00B3 <hex> 
0074 <hex> 
FF8C <hex> 

TC  

 

 4.5    Load command stack file for SGM A BSW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMAMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

CSGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMAMEM_DI_0002001_C_CSGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.6    Check memory dump command stack loaded 

 

   

For a full CDMU SGM BSW NP area dump ( Memory ID = 00B 
hex included):

Start Address = 00B4.0000 hex
End Address   = 00B8.60FF hex
Length        = 46100 hex
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No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 4.6.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   5 TCs DC602180

 

 

 4.6.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 00B hex:

Memory ID = 00B hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00Bx <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 4.6.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first DC602180 command 
( Memory ID = 00B hex included):

Start Address = 00B4.0000 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Page 10 of 29
Status      : Version 3 - Unchanged
Last Checkin: 29/01/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Update CDMU SGM ground image from memory dump

  File: H_FCP_OBS_1449.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00B4 <hex> 
0000 <hex> 
FFFC <hex> 

TC  

 

 4.6.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last DC602180 command 
( Memory ID = 00B hex included):

Start Address = 00B7.FFF0 hex
Length        = 6110 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00B7 <hex> 
FFF0 <hex> 
6110 <hex> 

TC  

 

 4.7    Load command stack file for SGM A ASW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMAMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMAMEM

as indicated by the OBSM engineer
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

CSGMAMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMAMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMAMEM_DI_0002001_C_CSGMAMEM1_0003001_2007_337T09332
0.sun043

 

 

 4.8    Check memory dump command stack loaded 

 

   

For a full CDMU SGM ASW NP area dump ( Memory ID = 00B 
hex included):

Start Address = 00B8.6100 hex
End Address   = 00BB.FFFF hex
Length        = 39F00 hex

 

 

 4.8.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs DC602180

 

 

 4.8.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 00B hex:

Memory ID = 00B hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00Bx <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 4.8.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first DC602180 command 
( Memory ID = 00B hex included):

Start Address = 00B8.6100 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00B8 <hex> 
6100 <hex> 
FFFC <hex> 

TC  

 

 4.8.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last DC602180 command 
( Memory ID = 00B hex included):

Start Address = 00BB.60F4 hex
Length        = 9F0C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00BB <hex> 
60F4 <hex> 
9F0C <hex> 

TC  

 

 5      MCS OBSM preparation for Image Update in LI VE mode

 

 Next Step:
  6

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1    Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 5.2    Select image to be updated

 

   

Select the image to be updated for the memory devic e 
CSGMAMEM.

The 'Image UPDATE' window opens.

 

 

 5.3    Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 6      Command memory dump

 

 Next Step:
  7

Uplink the DC602180 memory dump commands with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 7      Verify reception of TM(6,6)

 

 Next Step:
  8

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 7.1    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 8      Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP144B
TC Seq. Name :OFCP144B ( CDMU SGM A Dmp B )
CDMU SGM A Gnd image update in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 9      MCS OBSM preparation for Image update in RE TRIEVAL 
mode

 

 Next Step:
  10

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 9.1    Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.
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  Update CDMU SGM ground image from memory dump
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 9.2    Select image to be updated

 

   

Select the image to be updated for the memory devic e 
CSGMAMEM.

The 'Image UPDATE' window opens.

 

 

 9.3    Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 10     Retrieve and process TM(6,6) packets

 

 Next Step:
  11

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 10.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the retrieved mem ory 
dump packets.

 

 

 11     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP144C
TC Seq. Name :OFCP144C ( CDMU SGM B Dmp C )
CDMU SGM B Gnd image update in Live mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 12     IF
Image monitor in LIVE mode

type: [If]

 Next Step:
 ELSE 19
 THEN 13
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  Update CDMU SGM ground image from memory dump

  File: H_FCP_OBS_1449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 13     Verify initial conditions

 

 Next Step:
  14

Check:
- CDMU in Operational Mode

 

CDMS SOE to confirm CDMU mode  

 

 14     Manual Stack manipulation

 

 Next Step:
  15

IMPORTANT:
- On each SGM A and B, the memory area is split in two 
parts where the first part is write protected and 
second part is unprotected.
- Each protected and unprotected area is divided into 
one part allocated to the ASW and one part allocated 
to the BSW

 

The allocation of the 4 SGM memory areas
- BSW Write Protected
- ASW Write Protected
- BSW Not Protected
- ASW Not Protected
is defined through HPSDB parameters:

SGM_ASW_BEG_P_ADDR Start address of the protected part 
of the ASW SGM, byte offset within SGM

SGM_BSW_BEG_ADDR Start address of the non protected 
BSW part of the SGM, byte offset within SGM

SGM_ASW_BEG_ADDR_VALUE Start address of the non 
protected part of the ASW SGM, byte offset within S GM

 

For CDMU ASW v.3.8.0 and BSW v.2.2:

SGM_ASW_BEG_P_ADDR     = 80 hex
SGM_BSW_BEG_ADDR       = 40000 hex
SGM_ASW_BEG_ADDR_VALUE = 86100 hex

 

For CDMU ASW v.3.8.0 and BSW v.2.2,the definitions of 
the 4 SGM B memory areas are ( Memory ID = 00E hex 
included):

SGM BSW WP
Start Address = 00E0.0000 hex
Length        = 80 hex

SGM ASW WP
Start Address = 00E0.0080 hex
Length        = 3FF80 hex

 

SGM BSW NP
Start Address = 00E4.0000 hex
Length        = 46100 hex

SGM ASW NP
Start Address = 00E8.6100 hex
Length        = 39F00 hex

 

IMPORTANT:
All accesses to SGM memory must be 32-bit transfers, 
aligned to 32-bit
boundaries.

 

 

Page 17 of 29
Status      : Version 3 - Unchanged
Last Checkin: 29/01/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10
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  File: H_FCP_OBS_1449.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 14.1   Load command stack file for SGM B BSW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

CSGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMBMEM_DI_0002001_C_CSGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.2   Check memory dump command stack loaded 

 

   

For a full CDMU SGM BSW WP area dump ( Memory ID = 00E 
hex included):

Start Address = 00E0.0000 hex
End Address   = 00E0.007F hex
Length        = 80 hex

 

Check that loaded stack contains:
   1 TC DC602180

 

Page 18 of 29
Status      : Version 3 - Unchanged
Last Checkin: 29/01/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Update CDMU SGM ground image from memory dump

  File: H_FCP_OBS_1449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Display the Manual Stack in 'Full mode' and check t he 
Memory ID, Start Address and Length parameters in the 
DC602180 command:

Memory ID     = 00E hex
Start Address = 0.0000 hex
Length        = 80 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00E0 <hex> 
0000 <hex> 
80 <hex> 

TC  

 

 14.3   Load command stack file for SGM B ASW Write Protec ted 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name examples

- No model associated to the memory image:

CSGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMBMEM_DI_0002001_C_CSGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.4   Check memory dump command stack loaded 

 

   

For a full CDMU SGM ASW WP area dump ( Memory ID = 00E 
hex included):

Start Address = 00E0.0080 hex
End Address   = 00E3.FFFF hex
Length        = 3FF80 hex

 

 

 14.4.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs DC602180

 

 

 14.4.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 00E hex:

Memory ID = 00E hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00Ex <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 14.4.3  Check start address and length of the first  dump 
command in the stack
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  File: H_FCP_OBS_1449.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first DC602180 command 
( Memory ID = 00E hex included):

Start Address = 00E0.0080 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00E0 <hex> 
0080 <hex> 
FFFC <hex> 

TC  

 

 14.4.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last DC602180 command 
( Memory ID = 00E hex included):

Start Address = 00E0.0074 hex
Length        = FF8C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00E3 <hex> 
0074 <hex> 
FF8C <hex> 

TC  

 

 14.5   Load command stack file for SGM B BSW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

CSGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMBMEM_DI_0002001_C_CSGMBMEM1_0003001_2007_337T09332
0.sun043

 

 

 14.6   Check memory dump command stack loaded 

 

   

For a full CDMU SGM BSW NP area dump ( Memory ID = 00E 
hex included):

Start Address = 00E4.0000 hex
End Address   = 00E8.60FF hex
Length        = 46100 hex

 

 

 14.6.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   5 TCs DC602180

 

 

 14.6.2  Check Memory ID
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  Update CDMU SGM ground image from memory dump

  File: H_FCP_OBS_1449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 00E hex:

Memory ID = 00E hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00Ex <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 14.6.3  Check start address and length of the first  dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first DC602180 command 
( Memory ID = 00E hex included):

Start Address = 00E4.0000 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00E4 <hex> 
0000 <hex> 
FFFC <hex> 

TC  

 

 14.6.4  Check start address and length of the last dump 
command in the stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last DC602180 command 
( Memory ID = 00E hex included):

Start Address = 00E7.FFF0 hex
Length        = 6110 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00E7 <hex> 
FFF0 <hex> 
6110 <hex> 

TC  

 

 14.7   Load command stack file for SGM B ASW Not P rotected 
part on top of Manual Stack

 

   

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

Select file

CSGMBMEM_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CSGMBMEM

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name examples

- No model associated to the memory image:

CSGMBMEM_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

- CT CSGMBMEM1, ID 0003, Version 001 associated to the 
memory image:

CSGMBMEM_DI_0002001_C_CSGMBMEM1_0003001_2007_337T09332
0.sun043
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 

 14.8   Check memory dump command stack loaded 

 

   

For a full CDMU SGM ASW NP area dump ( Memory ID = 00E 
hex included):

Start Address = 00E8.6100 hex
End Address   = 00EB.FFFF hex
Length        = 39F00 hex

 

 

 14.8.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   4 TCs DC602180

 

 

 14.8.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 00E hex:

Memory ID = 00E hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00Ex <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 14.8.3  Check start address and length of the first  dump 
command in the stack
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  File: H_FCP_OBS_1449.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first DC602180 command 
( Memory ID = 00E hex included):

Start Address = 00E8.6100 hex
Length        = FFFC hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00E8 <hex> 
6100 <hex> 
FFFC <hex> 

TC  

 

 14.8.4  Check start address and length of the last dump 
command in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last DC602180 command 
( Memory ID = 00E hex included):

Start Address = 00EB.60F4 hex
Length        = 9F0C hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TM paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

00EB <hex> 
60F4 <hex> 
9F0C <hex> 

TC  

 

 15     MCS OBSM preparation for Image Update in LI VE mode

 

 Next Step:
  16

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.
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e

 

 15.1   Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 15.2   Select image to be updated

 

   

Select the image to be updated for the memory devic e 
CSGMBMEM.

The 'Image UPDATE' window opens.

 

 

 15.3   Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 16     Command memory dump

 

 Next Step:
  17

Uplink the DC602180 memory dump commands with ARM-GO  

For each command, one or more TM(6,6) packets must be 
received on ground.

 

 

 17     Verify reception of TM(6,6)

 

 Next Step:
  18

Note:
One or more TM(6,6) packets will be received for ea ch 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 17.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.
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Step 
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 18     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

OFCP144D
TC Seq. Name :OFCP144D ( CDMU SGM A Dmp D )
CDMU SGM B Gnd image update in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 19     MCS OBSM preparation for Image update in RE TRIEVAL 
mode

 

 Next Step:
  20

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 19.1   Select 'Image UPDATE' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Update. 

The 'Image Catalog' window opens.

 

 

 19.2   Select image to be updated

 

   

Select the image to be updated for the memory devic e 
CSGMBMEM.

The 'Image UPDATE' window opens.

 

 

 19.3   Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 20     Retrieve and process TM(6,6) packets

 

 Next Step:
  21

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Page 28 of 29
Status      : Version 3 - Unchanged
Last Checkin: 29/01/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Update CDMU SGM ground image from memory dump

  File: H_FCP_OBS_1449.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 20.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the retrieved mem ory 
dump packets.

 

 

 21     Save merged image

 

 Next Step:
  END

Save merged image with new ID.  

 

End of Sequence 

End of Procedure
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