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This Herschel OBSM nominal procedure is used to per form a CDMU PM 
EEPROM dump monitoring against the ground image. Th e procedure 
covers both CDMU PM EEPROM1 and EEPROM2. The memory  dump is 
commanded using TC(6,5) and the memory locations co ntent is 
received on ground in TM(6,6) packets.

The procedure assumes that the command stack has al ready been 
generated using the OBSM system and is ready for lo ading on the 
Manual Stack. The command stack generation activity  is not 
covered by this procedure.

CDMU in Operational Mode

Execution of service 6 TCs will be delayed when the re is an 
ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in Operational Mode

End of Procedure

Same as start except:
- CDMU PM EEPROM1 and/or EEPROM2 memory dump execut ed

Input Command Sequences

Output Command Sequences

OFCP124C        
OFCP124E        

ANDs GRDs SLDs

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 21/04/09   2.3 1 Created  lstefanov-hp    

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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Procedure Flowchart Overview

e

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP1242
TC Seq. Name :OFCP1242 ( CDMU EEPROM dump )
CDMU PM EEPROM dump monitor

TimeTag Type:  
Sub Schedule ID: 

 �

 1      SWITCH
Mem.device

type: [Switch]

 Next Step:
 EEPROM1 2
 EEPROM2 11

 

 2      IF
Monitor in LIVE
mode

type: [If]

 Next Step:
 THEN 3
 ELSE 8

 

End of Sequence 

OFCP124C
TC Seq. Name :OFCP124C ( CDMU EEPROM1 dump L )
CDMU PM EEPROM1 dump monitor in LIVE mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 3      Verify initial conditions

 

 Next Step:
  4

Check:
- CDMU in Operational Mode

 

CDMS SOE to confirm CDMU mode  

 

 4      Manual Stack manipulation
Load command stack files for memory dump on Manual 
Stack

 

 Next Step:
  5

 

 4.1    Load memory dump command stack

 

   

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 4.1.1  IF
CDMU PM A

 

   

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select file

CDMEE1PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

CDMEE1PG_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT CDMEE1PG1, ID 0003, Version 001 associated to the 
memory image:

CDMEE1PG_DI_0002001_C_CDMEE1PG1_0003001_2008_148T09332
0.sun045

 

 

 4.1.2  ELSE
CDMU PM B

 

   

Select file

CDMEE1PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

CDMEE1PB_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT CDMEE1PB1, ID 0003, Version 001 associated to the 
memory image:

CDMEE1PB_DI_0002001_C_CDMEE1PB1_0003001_2008_148T09332
0.sun045

 

 

 4.2    Check memory dump command stack loaded 

 

   

For a full CDMU PM EEPROM1 ('Image1') dump
( Memory ID = 008 included in the address):

Start Address = 0080.0000 hex
End Address   = 008F.FFFF hex
Length        = 100000 hex

 

Note:
For a full dump of CDMU EEPROM1, the stack will 
contain 17 TCs DC602180, covering the address range  
0080.0000 hex to 008F.FFFF hex

 

Check that loaded stack contains one or several TCs  
DC602180.

 

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180  command(s) is 
set to 008 hex:

Memory ID = 008 hex

Note:
The Memory ID of the target memory device is stored  in 
the most significant 12 bits of the 16-bit long Mem  ID 
TC parameter.
The least significant 4 bits of the same parameter 
carry the most significant 4 bits of the Start 
Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

008x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 5      Dump the EEPROM1 memory area

 

 Next Step:
  6

 

 5.1    MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 5.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 5.1.2  Select image to be monitored

 

   

 

 
5.1.2.1

 IF
CDMU PM A

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PG.

The 'Image MONITOR' window opens.

 

 

 
5.1.2.2

 ELSE
CDMU PM B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PB.

The 'Image MONITOR' window opens.

 

 

 5.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 5.2    Command memory dump

 

   

Uplink TCs DC602180 with ARM-GO  

For each command, one or several TM(6,6) packets wi ll 
be received on ground.

 

 

 6      Verify reception and contents of TM(6,6)

 

 Next Step:
  7

Note:
One or several TM(6,6) packets will be received for  
each memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 6.1    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 6.2    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 7      Save merged image

 

 Next Step:
  END

WAIT for execution completion of the last dump 
command.

 

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

OFCP124D
TC Seq. Name :OFCP124D ( CDMU EEPROM1 dump R )
CDMU PM EEPROM1 dump monitor in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 8      MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  9

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 8.1    Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 8.2    Select image to be monitored

 

   

 

 8.2.1  IF
CDMU PM A

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PG.

The 'Image MONITOR' window opens.

 

 

 
8.2.1.1

 ELSE
ACC PM B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PB.

The 'Image MONITOR' window opens.

 

 

 8.3    Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 9      Retrieve and process TM(6,6) packets

 

 Next Step:
  10

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 9.1    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 10     Save merged image

 

 Next Step:
  END

WAIT for retrieval completion of the last dump pack et.  

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP124E
TC Seq. Name :OFCP124E ( CDMU EEPROM2 dump L )
CDMU PM EEPROM2 dump monitor in LIVE mode

TimeTag Type:  B
Sub Schedule ID: 

 �

 11     IF
Monitor in LIVE
mode

type: [If]

 Next Step:
 THEN 12
 ELSE 17

 

 12     Verify initial conditions

 

 Next Step:
  13
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Check:
- CDMU in Operational Mode

 

CDMS SOE to confirm CDMU mode  

 

 13     Manual Stack manipulation
Load command stack files for memory dump on Manual 
Stack

 

 Next Step:
  14

 

 13.1   Load memory dump command stack

 

   

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 13.1.1  IF
CDMU PM A

 

   

Select file

CDMEE2PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

CDMEE2PG_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT CDMEE2PG1, ID 0003, Version 001 associated to the 
memory image:

CDMEE2PG_DI_0002001_C_CDMEE2PG1_0003001_2008_148T09332
0.sun045
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 13.1.2  ELSE
CDMU PM B

 

   

Select file

CDMEE2PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

Note:
The file name pattern above assumes that NO model w as 
associated with the image used for command stack 
generation.

If the memory image used has a model associated, th an 
the fields N_NoModel_NoModel  will change to reflect 
the CT name, ID and Version of the used Configurati on 
Table.

 

File name example:

- No model associated to the memory image:

CDMEE2PB_DI_0002001_N_NoModel_NoModel_2008_133T1233 00.
sun045

- CT CDMEE2PB1, ID 0003, Version 001 associated to the 
memory image:

CDMEE2PB_DI_0002001_C_CDMEE2PB1_0003001_2008_148T09332
0.sun045

 

 

 13.2   Check memory dump command stack loaded 

 

   

For a full CDMU PM EEPROM2 ('Image2') dump
( Memory ID = 009 included in the address):

Start Address = 0090.0000 hex
End Address   = 009F.FFFF hex
Length        = 100000 hex

 

Note:
For a full dump of CDMU EEPROM2, the stack will 
contain 17 TCs DC602180, covering the address range  
0090.0000 hex to 009F.FFFF hex

 

Check that loaded stack contains one or several TCs  
DC602180.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 command(s) is 
set to 009 hex:

Memory ID = 009 hex

Note:
The Memory ID of the target memory device is stored  in 
the most significant 12 bits of the 16-bit long Mem  ID 
TM parameter.
The least significant 4 bits of the same parameter 
carry the most significant 4 bits of the Start 
Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

009x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 14     Dump the EEPROM2 memory area

 

 Next Step:
  15

 

 14.1   MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 14.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 14.1.2  Select image to be monitored

 

   

 

 
14.1.2.
1

 IF
CDMU PM A
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the image to be monitored for the memory dev ice 
CDMEE2PG.

The 'Image MONITOR' window opens.

 

 

 
14.1.2.
2

 ELSE
CDMU PM B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE2PB.

The 'Image MONITOR' window opens.

 

 

 14.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 14.2   Command memory dump

 

   

Uplink TCs DC602180 with ARM-GO  

For each command, one or several TM(6,6) packets wi ll 
be received on ground.

 

 

 15     Verify reception and contents of TM(6,6)

 

 Next Step:
  16

Note:
One or several TM(6,6) packets will be received for  
each memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 15.1   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 15.2   Check contents of memory dump packets
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 16     Save merged image

 

 Next Step:
  END

WAIT for execution completion of the last dump 
command.

 

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP124F
TC Seq. Name :OFCP124F ( CDMU EEPROM2 dump R )
CDMU PM EEPROM2 dump monitor in Retrieval mode

TimeTag Type:  
Sub Schedule ID: 

 �

 17     MCS OBSM preparation for Image monitor in R ETRIEVAL 
mode

 

 Next Step:
  18

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 17.1   Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 17.2   Select image to be monitored

 

   

 

 17.2.1  IF
CDMU PM A
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the image to be monitored for the memory dev ice 
CDMEE2PG.

The 'Image MONITOR' window opens.

 

 

 
17.2.1.
1

 ELSE
ACC PM B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE2PB.

The 'Image MONITOR' window opens.

 

 

 17.3   Start dump TM packets processing

 

   

Set retrieval start and stop time and start retrieval 
of TM packets using the PLAY buttons.

 

 

 18     Retrieve and process TM(6,6) packets

 

 Next Step:
  19

Use the STEP button to retrieve and process the 
TM(6,6) packets, packet by packet and starting from  
the time shown in the packet time field.

 

OR  

Use the PLAY button to retrieve and process the 
TM(6,6) packets in automated mode.

Pressing the PLAY button, the display will start to  
retrieve and process packets, starting from the tim e 
shown in the packet time field. This processing wil l 
stop automatically when a packet is received which 
creation time is greater than the one contained in the 
end time field.

 

 

 18.1   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 19     Save merged image

 

 Next Step:
  END

WAIT for retrieval completion of the last dump pack et.  

IF there are mismatches reported by OBSM, save merged 
image with new ID.
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

End of Procedure
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