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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls
  Author: lstefanov-hpLiviu Stefanov

This Herschel OBSM procedure is used to conduct a C DMU On-Board 
SW upload in PM EEPROM.

The whole OBS image is loaded into either 'Image 1'  or 'Image 2' 
memory area. Image integrity after load is verified  by on-board 
memory checksum calculation and full image dump.

This procedure assumes that the memory load and mem ory check 
command stacks have already been generated using th e OBSM system 
and are ready for loading on the Manual Stack. The command stack 
generation activity is not covered by this procedur e.

The procedure is called by system procedures H_CRP_ SYS_PATC and 
H_CRP_SYS_PATCS.

CDMU in Operational Mode

Execution of service 6 TCs will be delayed when the re is an 
ongoing:
- TC(6,2) Load Memory Using Absolute Addresses
- TC(6,5) Dump Memory Using Absolute Addresses
- TC(6,9) Check Memory Using Absolute Addresses
- TC(8,4,1,1) Copy Memory

Start of Procedure

CDMU in operational mode

End of Procedure

Same as start except:
- New OBS image loaded in 'Image 1' or 'Image 2'

Input Command Sequences

Output Command Sequences

OFCP121A        
OFCP121B        

ANDs GRDs SLDs
ZAD51999    (None)          

Procedure Summary

Objectives

Summary of Constraints

Configuration Control Information

Referenced Displays

Reference File(s)

Spacecraft Configuration

e
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls
  Author: lstefanov-hpLiviu Stefanov

Procedure Summary

e

DATE FOP ISSUE VERSION MODIFICATION DESCRIPTION AUTHOR SPR REF

 25/02/08   1 1 Created  lstefanov-hp    

 16/01/09   2 2

1. added current steps 3 and 4 and sub-steps for OBS image dump before new image 
load�
2. current step 6 updated: sub-steps 6.1 and 6.2 created to separate command stack load 
for CDMU A and B�
3. current step 8 updated: sub-steps 8.1 and 8.2 created to separate command stack load 
for CDMU A and B�
4. steps 8.3 and 9.2 updated: tables with start addresses and length for mem.checksum 
commands updated�
5. added current steps 12 and 13 and sub-steps for OBS image dump before new image 
load�
6. current step 15 updated: sub-steps 15.1 and 15.2 created to separate command stack 
load for CDMU A and B�
7. current step 17 updated: sub-steps 17.1 and 17.2 created to separate command stack 
load for CDMU A and B�
8. steps 17.3 and 18.2 updated: tables with start addresses and length for 
mem.checksum commands updated  lstefanov-hp    

 16/04/09   2.3 3

Updated checksums for Herschel OBS 3.10.0.0.�
Removed checksum values from procedure body.�
Added attachment with the expected checksum values at the end of procedure.  t.loureiro-hp    

 17/07/09   2.5 4 1. updated checksum values for CDMS OBS v.4.0B1114  lstefanov-hp    

Page 2 of 41
Status      : Version 4 - Unchanged
Last Checkin: 17/07/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Procedure Flowchart Overview

e

e
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

Beginning of Procedure

OFCP1210
TC Seq. Name :OFCP1210 ( CDMU OBS LOAD EEPROM )
Load CDMU OBS in EEPROM

TimeTag Type:  B
Sub Schedule ID: 

 �

 1      Verify initial conditions

 

 Next Step:
  2

Check:
- CDMU in Operational Mode

 

Data Handling SOE to confirm CDMU mode  

 

 2      SWITCH
Select EEPROM

type: [Switch]

 Next Step:
 EEPROM1 3
 EEPROM2 12

 

End of Sequence 

OFCP121A
TC Seq. Name :OFCP121A ( CDMU OBS LD EEPROM1 )
Load CDMU OBS 'Image 1' in EEPROM1

TimeTag Type:  N
Sub Schedule ID: 

 �

 3      Manual Stack manipulation
Load command stack file for CDMS current OBS dump f rom 
CDMU EEPROM1 on Manual Stack

 

 Next Step:
  4

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 3.1    IF
CDMU A

 

   

Select file

CDMEE1PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PG

as indicated by the OBSM engineer

 

e
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE1PG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 3.2    ELSE
CDMU B

 

   

Select file

CDMEE1PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE1PB_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 3.3    Check memory dump command stack loaded 

 

   

Note:
The start and end address of the EEPROM 'Image 1' a re 
(Memory ID included):

Start Address = 0080.0000 hex
End Address   = 008F.FFFF hex
Length        = 100000 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

 

 3.3.1  Check number of memory dump commands in the  stack
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Check that loaded stack contains:
   17 TCs DC602180

 

 

 3.3.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 commands is 
set to 008 hex:

Memory ID = 008 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

008x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 3.3.3  Check start address and length of first com mand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address in the first DC602180 command (Memory ID 
included):

Start Address = 0080.0000 hex
Length        = FFFF hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

0080 <hex> 
0000 <hex> 
FFFF <hex> 

TC  
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No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 3.3.4  Check start address and length of last command in the 
stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address in the last DC602180 command (Memory ID 
included):

Start Address = 008F.FFF0 hex
Length        = 10 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

008F <hex> 
FFF0 <hex> 
10 <hex> 

TC  

 

 4      Dump CDMS current OBS image from CDMU EEPRO M1

 

 Next Step:
  5

 

 4.1    MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 4.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 4.1.2  Select image to be monitored
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 
4.1.2.1

 IF
CDMU A

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PG.

The 'Image MONITOR' window opens.

 

 

 
4.1.2.2

 ELSE
CDMU B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PB.

The 'Image MONITOR' window opens.

 

 

 4.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 4.2    Upload commands to dump the CDMS current OB S image 
from CDMU EEPROM1

 

   

Uplink the DC602180 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 4.3    Verify reception of TM(6,6)

 

   

Note:
Several TM(6,6) packets will be received for each 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 4.4    Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.
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No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 4.5    Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 4.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

 5      Manual Stack manipulation
Load command sequence OFCP121A on Manual Stack

 

 Next Step:
  6

 

 5.1    Sequence data

FP:   N/A
TT:   N/A

 

   

 

 6      Manual Stack manipulation
Load command stack file for CDMS OBS load in CDMU 
EEPROM1 on Manual Stack

 

 Next Step:
  7

Load command stack file at line 2 of Manual Stack.  

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 6.1    IF
CDMU A
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e

Select file

CDMEE1PG_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE1PG_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 6.2    ELSE
CDMU B

 

   

Select file

CDMEE1PB_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE1PB_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 6.3    Check memory load command stack loaded 
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Step 
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e

Note:
The start and end address address of the EEPROM 'Im age 
1' are (Memory ID included):

Start Address = 0080.0000 hex
End Address   = 008F.FFFF hex
Length        = 100000 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

 

 6.3.1  Check number of memory load commands in the  stack

 

   

Check that loaded stack contains:
   4600 TCs XC000999

 

 

 6.3.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 commands is 
set to 008 hex:

Memory ID = 008 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                     Patch APID 16

Command Parameter(s) :
      Memory Id (------------)            XH000999
      Start Address (--------)            XH001999
      Length of Block (8 bits)            XH003999
       Variable len. octet str            XH004999
      Checksum (-------------)            XH005999

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 1      
Det. descr. : Patch APID 16

      XC000999

008x <hex>  
 <hex> (Def)
 <dec> (Def)
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export

 

 6.3.3  Check start address and length of the first  command 
in the stack
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e

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first XC000999 command 
(Memory ID included):

Start Address = 0080.0000 hex
Length        = 228 dec

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                     Patch APID 16

Command Parameter(s) :
      Memory Id (------------)            XH000999
      Start Address (--------)            XH001999
      Length of Block (8 bits)            XH003999
       Variable len. octet str            XH004999
      Checksum (-------------)            XH005999

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 1      
Det. descr. : Patch APID 16

      XC000999

0080 <hex> 
0000 <hex> 
228 <dec> 
patch data  
calculated by OBSM  

TC  

This Telecommand will not be included in the export

 

 6.3.4  Check start address and length of the last command  in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last XC000999 command 
(Memory ID included):

Start Address = 008F.FFFC hex
Length        = 4 dec

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                     Patch APID 16

Command Parameter(s) :
      Memory Id (------------)            XH000999
      Start Address (--------)            XH001999
      Length of Block (8 bits)            XH003999
       Variable len. octet str            XH004999
      Checksum (-------------)            XH005999

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 1      
Det. descr. : Patch APID 16

      XC000999

008F <hex> 
FFFC <hex> 
4 <dec> 
patch data  
calculated by OBSM  

TC  

This Telecommand will not be included in the export

 

 7      Load CDMU OBS 'Image 1' in CDMU EEPROM1

 

 Next Step:
  8

 

Page 12 of 41
Status      : Version 4 - Unchanged
Last Checkin: 17/07/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 7.1    Disable CDMU EEPROM write protection

 

   

Verify Telemetry
               EEPromWriteProt            DEL0J160  = ENABLED AND=ZAD51999

Uplink TC with ARM GO  

Execute Telecommand
                                     EnableEEWrite

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Enable write to EEPROM

      DC806180  
TC  

Verify Telemetry
               EEPromWriteProt            DEL0J160  = DISABLED AND=ZAD51999

 

 7.2    Uplink the memory load commands

 

   

Memory load details:

 Start address: 0080.0000 hex
 End address  : 008F.FFFF hex
 # of TCs     : 4600 dec

 

Uplink TCs XC000999 with ARM-GO  

For each TC XC000999 successfuly executed on-board,  a 
TM(1,1) and a TM(1,7) packet shall be received on 
ground.

 

Verify Packet Reception

Telecommand Acceptance Report - Success
Packet Mnemonic :        D_TcAccSucc
APID :                   16
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Verify Packet Reception

Telecommand Execution Report - Completed
Packet Mnemonic :        D_TcExeComp
APID :                   16
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 7.3    Enable CDMU EEPROM write protection

 

   

Verify Telemetry
               EEPromWriteProt            DEL0J160  = DISABLED AND=ZAD51999

Uplink TC with ARM GO  
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e

Execute Telecommand
                                    DisableEEWrite

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Disable write to EEPROM

      DC805180  
TC  

Verify Telemetry
               EEPromWriteProt            DEL0J160  = ENABLED AND=ZAD51999

 

 8      Manual Stack manipulation
Load command stack file for CDMS OBS 'Image 1' chec k 
on the Manual Stack

 

 Next Step:
  9

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 8.1    IF
CDMU A

 

   

Select file

CDMEE1PG_CI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE1PG_CI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 8.2    ELSE
CDMU B
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e

Select file

CDMEE2PG_CI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE2PG_CI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 8.3    Check command stack loaded 

 

   

With the Manual Stack in 'Full mode', check the 17 TCs 
DC603180 in loaded stack.

TC #    Memory_ID    Start_Address    N
  1      0080          0000          FFFF
  2      0080          FFFF          FFFF
  3      0081          FFFE          FFFF
  4      0082          FFFD          FFFF
  5      0083          FFFC          FFFF
  6      0084          FFFB          FFFF
  7      0085          FFFA          FFFF
  8      0086          FFF9          FFFF
  9      0087          FFF8          FFFF

 

 10      0088          FFF7          FFFF
 11      0089          FFF6          FFFF
 12      008A          FFF5          FFFF
 13      008B          FFF4          FFFF
 14      008C          FFF3          FFFF
 15      008D          FFF2          FFFF
 16      008E          FFF1          FFFF
 17      008F          FFF0          0010

 

Note:
Only the first TC DC603180 is included below, as 
example.

 

Execute Telecommand
                                     ChkMem_AbsAdd

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Check Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC603180

0080 <hex> 
0000 <hex> 
FFFF <hex> 

TC  
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 9      Check 'Image 1' loaded in CDMU EEPROM1 memo ry area

 

 Next Step:
  10

 

 9.1    Command memory checksum calculation

 

   

Uplink the 17 DC603180 memory check commands (one by 
one) with ARM-GO

 

For each TC DC603180 uplinked, a TM(6,10) packet sh all 
be received on ground.

 

 

 9.2    Verify reception and contents of TM(6,10)

 

   

Verify Packet Reception

Memory Check Report - Absolute Addresses
Packet Mnemonic :        MemChkRepAbs
APID :                   16
Type :                   6
Subtype :                10
PI1 :                    
PI2 :                    
Verify Telemetry
                     Memory_ID            DE060180  =  <hex>

Verify Telemetry
                 Start_Address            DE061180  =  <hex> (None)

Verify Telemetry
                             N            DE062180  =  <hex> (None)

Verify Telemetry
                      CheckSum            DE064180  =  <hex> (None)

 

 9.2.1  Verify checksum values

 

   

Check the received checksums against the expected 
values listed in Attachment 1 (worksheet " CRC 
checksums").

IMPORTANT:
Checksum values depend on the OBS version.

 

Verify Telemetry
                      CheckSum            DE064180    = expected 

value 
(None)

 

 10     Manual Stack manipulation
Load command stack file for CDMS new OBS dump from 
CDMU EEPROM1 on Manual Stack

 

 Next Step:
  11

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 10.1   IF
CDMU A

 

   

Select file

CDMEE1PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE1PG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 10.2   ELSE
CDMU B

 

   

Select file

CDMEE1PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE1PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE1PB_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 10.3   Check memory dump command stack loaded 
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
The start and end address of the EEPROM 'Image 1' a re 
(Memory ID included):

Start Address = 0080.0000 hex
End Address   = 008F.FFFF hex
Length        = 100000 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

 

 10.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   17 TCs DC602180

 

 

 10.3.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 commands is 
set to 008 hex:

Memory ID = 008 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

008x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 10.3.3  Check start address and length of first com mand in 
the stack
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  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address in the first DC602180 command (Memory ID 
included):

Start Address = 0080.0000 hex
Length        = FFFF hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

0080 <hex> 
0000 <hex> 
FFFF <hex> 

TC  

 

 10.3.4  Check start address and length of last command in the 
stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address in the last DC602180 command (Memory ID 
included):

Start Address = 008F.FFF0 hex
Length        = 10 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

008F <hex> 
FFF0 <hex> 
10 <hex> 

TC  

 

 11     Dump CDMS new OBS image from CDMU EEPROM1

 

 Next Step:
  END

 

 11.1   MCS OBSM preparation for Image monitor in L IVE mode
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 11.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 11.1.2  Select image to be monitored

 

   

 

 
11.1.2.
1

 IF
CDMU A

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PG.

The 'Image MONITOR' window opens.

 

 

 
11.1.2.
2

 ELSE
CDMU B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE1PB.

The 'Image MONITOR' window opens.

 

 

 11.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 11.2   Upload commands to dump the CDMS current OB S image 
from CDMU EEPROM1

 

   

Uplink the DC602180 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 11.3   Verify reception of TM(6,6)

 

   

Note:
Several TM(6,6) packets will be received for each 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 11.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 11.5   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 11.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

OFCP121B
TC Seq. Name :OFCP121B ( CDMU OBS LD EEPROM2 )
Load CDMU OBS 'Image 2' in EEPROM2

TimeTag Type:  N
Sub Schedule ID: 

 �

 12     Manual Stack manipulation
Load command stack file for CDMS current OBS dump f rom 
CDMU EEPROM2 on Manual Stack

 

 Next Step:
  13

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 12.1   IF
CDMU A

 

   

Select file

CDMEE2PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE2PG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 12.2   ELSE
CDMU B

 

   

Select file

CDMEE2PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE2PB_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 12.3   Check memory dump command stack loaded 
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
The start and end address of the EEPROM 'Image 2' a re 
(Memory ID included):

Start Address = 0090.0000 hex
End Address   = 009F.FFFF hex
Length        = 100000 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

 

 12.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   17 TCs DC602180

 

 

 12.3.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 commands is 
set to 009 hex:

Memory ID = 009 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

009x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 12.3.3  Check start address and length of first com mand in 
the stack
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

With the Manual Stack in 'Full mode', check  the Start 
Address in the first DC602180 command (Memory ID 
included):

Start Address = 0090.0000 hex
Length        = FFFF hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

0090 <hex> 
0000 <hex> 
FFFF <hex> 

TC  

 

 12.3.4  Check start address and length of last command in the 
stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address in the last DC602180 command (Memory ID 
included):

Start Address = 009F.FFF0 hex
Length        = 10 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

009F <hex> 
FFF0 <hex> 
10 <hex> 

TC  

 

 13     Dump CDMS current OBS image from CDMU EEPRO M2

 

 Next Step:
  14

 

 13.1   MCS OBSM preparation for Image monitor in L IVE mode
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 13.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 13.1.2  Select image to be monitored

 

   

 

 
13.1.2.
1

 IF
CDMU A

 

   

Select the image to be monitored for the memory dev ice 
CDMEE2PG.

The 'Image MONITOR' window opens.

 

 

 
13.1.2.
2

 ELSE
CDMU B

 

   

Select the image to be monitored for the memory dev ice 
CDMEE2PB.

The 'Image MONITOR' window opens.

 

 

 13.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 13.2   Upload commands to dump the CDMS current OB S image 
from CDMU EEPROM2

 

   

Uplink the DC602180 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.
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  File: H_FCP_OBS_1210.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 13.3   Verify reception of TM(6,6)

 

   

Note:
Several TM(6,6) packets will be received for each 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 13.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 13.5   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.

 

 

 13.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

 14     Manual Stack manipulation
Load command sequence OFCP121B on Manual Stack

 

 Next Step:
  15

 

 14.1   Sequence data

FP:   N/A
TT:   N/A
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  File: H_FCP_OBS_1210.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment
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 15     Manual Stack manipulation
Load command stack file for CDMS OBS load in CDMU 
EEPROM2 on Manual Stack

 

 Next Step:
  16

Load command stack file at line 2 of Manual Stack.  

NOTE:
The current procedure assumes that the memory load is 
performed using commands with immediate execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 15.1   IF
CDMU A

 

   

Select file

CDMEE2PG_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE2PG_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 15.2   ELSE
CDMU B

 

   

Select file

CDMEE2PB_PI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PB

as indicated by the OBSM engineer
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls
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Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE2PB_PI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 15.3   Check memory load command stack loaded 

 

   

Note:
The start and end address address of the EEPROM 'Im age 
2' are (Memory ID included):

Start Address = 0090.0000 hex
End Address   = 009F.FFFF hex
Length        = 100000 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

 

 15.3.1  Check number of memory load commands in the  stack

 

   

Check that loaded stack contains:
   4600 TCs XC000999

 

 

 15.3.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 commands is 
set to 009 hex:

Memory ID = 009 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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Execute Telecommand
                                     Patch APID 16

Command Parameter(s) :
      Memory Id (------------)            XH000999
      Start Address (--------)            XH001999
      Length of Block (8 bits)            XH003999
       Variable len. octet str            XH004999
      Checksum (-------------)            XH005999

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 1      
Det. descr. : Patch APID 16

      XC000999

009x <hex>  
 <hex> (Def)
 <dec> (Def)
 <hex> (Def)
 <hex> (Def)

TC  

This Telecommand will not be included in the export

 

 15.3.3  Check start address and length of the first  command 
in the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the first XC000999 command 
(Memory ID included):

Start Address = 0090.0000 hex
Length        = 228 dec

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                     Patch APID 16

Command Parameter(s) :
      Memory Id (------------)            XH000999
      Start Address (--------)            XH001999
      Length of Block (8 bits)            XH003999
       Variable len. octet str            XH004999
      Checksum (-------------)            XH005999

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 1      
Det. descr. : Patch APID 16

      XC000999

0090 <hex> 
0000 <hex> 
228 <dec> 
patch data  
calculated by OBSM  

TC  

This Telecommand will not be included in the export

 

 15.3.4  Check start address and length of the last command  in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address and Length in the last XC000999 command 
(Memory ID included):

Start Address = 009F.FFFC hex
Length        = 4 dec

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                     Patch APID 16

Command Parameter(s) :
      Memory Id (------------)            XH000999
      Start Address (--------)            XH001999
      Length of Block (8 bits)            XH003999
       Variable len. octet str            XH004999
      Checksum (-------------)            XH005999

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 1      
Det. descr. : Patch APID 16

      XC000999

009F <hex> 
FFFC <hex> 
4 <dec> 
patch data  
calculated by OBSM  

TC  

This Telecommand will not be included in the export

 

 16     Load CDMU OBS 'Image 2' in EEPROM2

 

 Next Step:
  17

 

 16.1   Disable EEPROM write protection

 

   

Verify Telemetry
               EEPromWriteProt            DEL0J160  = ENABLED AND=ZAD51999

Uplink TC with ARM GO  

Execute Telecommand
                                     EnableEEWrite

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Enable write to EEPROM

      DC806180  
TC  

Verify Telemetry
               EEPromWriteProt            DEL0J160  = DISABLED AND=ZAD51999

 

 16.2   Uplink the memory load commands

 

   

Memory load details:

 Start address: 0090.0000 hex
 End address  : 009F.FFFF hex
 # of TCs     : 4600 dec

 

Uplink TCs XC000999 with ARM-GO  

For each TC XC000999 successfuly executed on-board,  a 
TM(1,1) and a TM(1,7) packet shall be received on 
ground.

 

Verify Packet Reception

Telecommand Acceptance Report - Success
Packet Mnemonic :        D_TcAccSucc
APID :                   16
Type :                   1
Subtype :                1
PI1 :                    
PI2 :                    

Page 30 of 41
Status      : Version 4 - Unchanged
Last Checkin: 17/07/09 



Doc No.   :PT-HMOC-OPS-FOP-6001-OPS-OAH
Fop Issue :                         3.0
Issue Date:                    13/04/10

  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Verify Packet Reception

Telecommand Execution Report - Completed
Packet Mnemonic :        D_TcExeComp
APID :                   16
Type :                   1
Subtype :                7
PI1 :                    
PI2 :                    
 

 16.3   Enable EEPROM write protection

 

   

Verify Telemetry
               EEPromWriteProt            DEL0J160  = DISABLED AND=ZAD51999

Uplink TC with ARM GO  

Execute Telecommand
                                    DisableEEWrite

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Disable write to EEPROM

      DC805180  
TC  

Verify Telemetry
               EEPromWriteProt            DEL0J160  = ENABLED AND=ZAD51999

 

 17     Manual Stack manipulation
Load command stack file for CDMS OBS 'Image 2' chec k 
on the Manual Stack

 

 Next Step:
  18

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 17.1   IF
CDMU A

 

   

Select file

CDMEE2PG_CI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

File name example:

- No model associated to the memory image:

CDMEE2PG_CI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 17.2   ELSE
CDMU B

 

   

Select file

CDMEE2PB_CI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PB

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example:

- No model associated to the memory image:

CDMEE2PB_CI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 17.3   Check command stack loaded 

 

   

With the Manual Stack in 'Full mode', check the 17 TCs 
DC603180 in loaded stack.

TC #    Memory_ID    Start_Address    N
  1      0090          0000          FFFF
  2      0090          FFFF          FFFF
  3      0091          FFFE          FFFF
  4      0092          FFFD          FFFF
  5      0093          FFFC          FFFF
  6      0094          FFFB          FFFF
  7      0095          FFFA          FFFF
  8      0096          FFF9          FFFF
  9      0097          FFF8          FFFF

 

 10      0098          FFF7          FFFF
 11      0099          FFF6          FFFF
 12      009A          FFF5          FFFF
 13      009B          FFF4          FFFF
 14      009C          FFF3          FFFF
 15      009D          FFF2          FFFF
 16      009E          FFF1          FFFF
 17      009F          FFF0          0010

 

Note:
Only the first TC DC603180 is included below, as 
example.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                     ChkMem_AbsAdd

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Check Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC603180

0090 <hex> 
0000 <hex> 
FFFF <hex> 

TC  

 

 18     Check 'Image 2' loaded in CDMU EEPROM2 memo ry area

 

 Next Step:
  19

 

 18.1   Command memory checksum calculation

 

   

Uplink the 17 DC603180 memory check commands (one by 
one) with ARM-GO

 

For each TC DC603180 uplinked, a TM(6,10) packet sh all 
be received on ground.

 

 

 18.2   Verify reception and contents of TM(6,10)

 

   

Verify Packet Reception

Memory Check Report - Absolute Addresses
Packet Mnemonic :        MemChkRepAbs
APID :                   16
Type :                   6
Subtype :                10
PI1 :                    
PI2 :                    
Verify Telemetry
                     Memory_ID            DE060180  =  <hex>

Verify Telemetry
                 Start_Address            DE061180  =  <hex> (None)

Verify Telemetry
                             N            DE062180  =  <hex> (None)

Verify Telemetry
                      CheckSum            DE064180  =  <hex> (None)

 

 18.2.1  Verify checksum values

 

   

Check the received checksums against the expected 
values listed in Attachment 1 (worksheet " CRC 
checksums").

IMPORTANT:
Checksum values depend on the OBS version.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Verify Telemetry
                      CheckSum            DE064180    = expected 

value 
(None)

 

 19     Manual Stack manipulation
Load command stack file for CDMS new OBS dump from 
CDMU EEPROM2 on Manual Stack

 

 Next Step:
  20

NOTE:
The current procedure assumes that the memory dump in 
Live mode is performed using commands with immediat e 
execution.

 

Select the File -> LoadStack option from the main 
menu of the Manual Stack window

 

 

 19.1   IF
CDMU A

 

   

Select file

CDMEE2PG_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PG

as indicated by the OBSM engineer

 

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE2PG_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 19.2   ELSE
CDMU B

 

   

Select file

CDMEE2PB_DI_XXXXYYY_N_NoModel_NoModel_YYYY_DDDThhmmss.
machine

from directory 

/home/hmcsops/HPMCS/SESSION/current/data/CMD/STACKS /OB
SM/CDMEE2PB

as indicated by the OBSM engineer
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

IMPORTANT:

XXXXYYYY = Image ID(X) and Version(Y) -  depend on 
image used for stack generation

YYYY_DDD hhmmss - depend on stack generation time

machine  - depends on the name of the machine used for 
stack generation

 

File name example

CDMEE2PB_DI_0002001_N_NoModel_NoModel_2007_254T1233 00.
sun043

 

 

 19.3   Check memory dump command stack loaded 

 

   

Note:
The start and end address of the EEPROM 'Image 2' a re 
(Memory ID included):

Start Address = 0090.0000 hex
End Address   = 009F.FFFF hex
Length        = 100000 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

 

 19.3.1  Check number of memory dump commands in the  stack

 

   

Check that loaded stack contains:
   17 TCs DC602180

 

 

 19.3.2  Check Memory ID

 

   

Display the Manual Stack in 'Full mode' and check t hat 
the Memory ID parameter in the DC602180 commands is 
set to 009 hex:

Memory ID = 009 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

009x <hex>  
 <hex> (Def)
 <hex> (Def)

TC  

 

 19.3.3  Check start address and length of first com mand in 
the stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address in the first DC602180 command (Memory ID 
included):

Start Address = 0090.0000 hex
Length        = FFFF hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.

 

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

0090 <hex> 
0000 <hex> 
FFFF <hex> 

TC  

 

 19.3.4  Check start address and length of last command in the 
stack

 

   

With the Manual Stack in 'Full mode', check  the Start 
Address in the last DC602180 command (Memory ID 
included):

Start Address = 009F.FFF0 hex
Length        = 10 hex

Note:
The Memory ID of the target memory device is stored  in 
the MS 12 bits of the 16-bit long Mem ID TC paramet er.
The LS 4 bits of the same parameter carry the most 
significant 4 bits of the Start Address.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Execute Telecommand
                                   DumpMem_AbsAddr

Command Parameter(s) :
                     Memory_ID            DH003180
                 Start_Address            DH004180
                             N            DH105180

TC Control Flags :
                                        GBM IL DSE
                                        --Y -- ---
Subsch. ID : 10      
Det. descr. : Dump Memory Using Absolute Addresses
This Telecommand will not be included in the export

      DC602180

009F <hex> 
FFF0 <hex> 
10 <hex> 

TC  

 

 20     Dump CDMS new OBS image from CDMU EEPROM2

 

 Next Step:
  END

 

 20.1   MCS OBSM preparation for Image monitor in L IVE mode

 

   

Note:
It is assumed that the OBSM application is already 
running and the OBSM Desktop is displayed on the MC S 
client.
Starting the OBSM application is not covered by the  
current procedure.

 

 

 20.1.1  Select 'Image MONITOR' from the menu

 

   

Select the Image menu of the OBSM Desktop .

From the Image menu, select Monitor. 

The 'Image Catalog' window opens.

 

 

 20.1.2  Select image to be monitored

 

   

 

 
20.1.2.
1

 IF
CDMU A

 

   

Select the image to be monitored for the memory dev ice 
CDMEE2PG.

The 'Image MONITOR' window opens.

 

 

 
20.1.2.
2

 ELSE
CDMU B
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

Select the image to be monitored for the memory dev ice 
CDMEE2PB.

The 'Image MONITOR' window opens.

 

 

 20.1.3  Start dump TM processing

 

   

In LIVE mode, processing of incoming real-time 
telemetry starts automatically after the image 
selection.

 

 

 20.2   Upload commands to dump the CDMS current OB S image 
from CDMU EEPROM2

 

   

Uplink the DC602180 memory dump commands with ARM-GO  

For each command, several TM(6,6) packets must be 
received on ground.

 

 

 20.3   Verify reception of TM(6,6)

 

   

Note:
Several TM(6,6) packets will be received for each 
memory dump command uplinked.

 

Verify Packet Reception

Memory Dump - Absolute Addresses - SAU 8
Packet Mnemonic :        MemDmpAbsAdd
APID :                   16
Type :                   6
Subtype :                6
PI1 :                    
PI2 :                    
 

 20.4   Check OBSM dump packet processing

 

   

Check that the OBSM is processing the incoming memo ry 
dump packets.

 

 

 20.5   Check contents of memory dump packets

 

   

Verify that there are NO OBSM reported differences 
between the memory dump data and the ground image u sed 
for monitoring.

 

IF there are differences reported by OBSM between the 
dump data and the ground image, the merged image shall 
be saved for offline analysis.
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  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: lstefanov-hp

Step 
No. Time Activity/Remarks TC/TLM Display/ Branch AIT Comment

e

 20.5.1  Save merged image

 

   

IF there are mismatches reported by OBSM, save merged 
image with new ID.

 

Conduct off-line analysis of the reported mismatche s.  

 

End of Sequence 

End of Procedure
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Herschel CDMU OBS image CRC checksums Attachment 1

  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: t.loureiro-hp

CRC checksums
Start address End address Start address End address CDMS OBS 4.0B1114

1 0080.0000 0080.FFFE 0090.0000 0090.FFFE AFCC
2 0080.FFFF 0081.FFFD 0090.FFFF 0091.FFFD E8BB
3 0081.FFFE 0082.FFFC 0091.FFFE 0092.FFFC F324
4 0082.FFFD 0083.FFFB 0092.FFFD 0093.FFFB 773E
5 0083.FFFC 0084.FFFA 0093.FFFC 0094.FFFA 4CAA
6 0084.FFFB 0085.FFF9 0094.FFFB 0095.FFF9 059E
7 0085.FFFA 0086.FFF8 0095.FFFA 0096.FFF8 3337
8 0086.FFF9 0087.FFF7 0096.FFF9 0097.FFF7 E102
9 0087.FFF8 0088.FFF6 0097.FFF8 0098.FFF6 DFEC

10 0088.FFF7 0089.FFF5 0098.FFF7 0099.FFF5 A5C0
11 0089.FFF6 008A.FFF4 0099.FFF6 009A.FFF4 7994
12 008A.FFF5 008B.FFF3 009A.FFF5 009B.FFF3 F16B
13 008B.FFF4 008C.FFF2 009B.FFF4 009C.FFF2 D791
14 008C.FFF3 008D.FFF1 009C.FFF3 009D.FFF1 4CE0
15 008D.FFF2 008E.FFF0 009D.FFF2 009E.FFF0 6B94
16 008E.FFF1 008F.FFEF 009E.FFF1 009F.FFEF D652
17 008F.FFF0 008F.FFFF 009F.FFF0 009F.FFFF 3140

EEPROM1 EEPROM2Checksum #
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Herschel CDMU OBS image ANC32 checksums Attachment 2

  Load CDMU OBS in EEPROM

  File: H_FCP_OBS_1210.xls

  Author: t.loureiro-hp

ANC32 checksums
Start address End address Start address End address CDMS OBS 4.0B1114

1 0080.0000 0080.FFFF 0090.0000 0090.FFFF 75A965AF
2 0081.0000 0081.FFFF 0091.0000 0091.FFFF E7647348
3 0082.0000 0082.FFFF 0092.0000 0092.FFFF 4742F080
4 0083.0000 0083.FFFF 0093.0000 0093.FFFF CB272D76
5 0084.0000 0084.FFFF 0094.0000 0094.FFFF 9742CA0F
6 0085.0000 0084.FFFF 0095.0000 0094.FFFF B6884A50
7 0086.0000 0086.FFFF 0096.0000 0096.FFFF 4D6B90B4
8 0087.0000 0087.FFFF 0097.0000 0097.FFFF C50F26DF
9 0088.0000 0088.FFFF 0098.0000 0098.FFFF FF11691E
10 0089.0000 0089.FFFF 0099.0000 0099.FFFF 2120766F
11 008A.0000 008A.FFFF 009A.0000 009A.FFFF 8DED9D2C
12 008B.0000 008B.FFFF 009B.0000 009B.FFFF 53B8CCC8
13 008C.0000 008C.FFFF 009C.0000 009C.FFFF EA929721
14 008D.0000 008D.FFFF 009D.0000 009D.FFFF 16D2873C
15 008E.0000 008E.FFFF 009E.0000 009E.FFFF 671B4C69
16 008F.0000 008F.FFBF 009F.0000 009F.FFBF 7CDC3C88

Block # EEPROM1 EEPROM2
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